diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-08-26 18:10:59 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-08-26 18:14:58 +0100 |
commit | b8187a1176346311c950d458b8dfa6233ec9713e (patch) | |
tree | 36cff1ab07494a1023f2391ff2351d28aa1d0270 /meta/packages/opkg-utils | |
parent | 5680a1d906e9aa07f486bd0946a1f4c5134acd8e (diff) | |
download | poky-b8187a1176346311c950d458b8dfa6233ec9713e.tar.gz |
opkg-utils: Add patch to avoid errors when packages change while rebuilding the package indexes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/opkg-utils')
-rw-r--r-- | meta/packages/opkg-utils/opkg-utils-native_svn.bb | 9 | ||||
-rw-r--r-- | meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch | 29 | ||||
-rw-r--r-- | meta/packages/opkg-utils/opkg-utils_svn.bb | 13 |
3 files changed, 38 insertions, 13 deletions
diff --git a/meta/packages/opkg-utils/opkg-utils-native_svn.bb b/meta/packages/opkg-utils/opkg-utils-native_svn.bb deleted file mode 100644 index b12b5456bf..0000000000 --- a/meta/packages/opkg-utils/opkg-utils-native_svn.bb +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | require opkg-utils_svn.bb | ||
2 | |||
3 | RDEPENDS = "" | ||
4 | |||
5 | inherit native | ||
6 | |||
7 | # Avoid circular dependencies from package_ipk.bbclass | ||
8 | PACKAGES = "" | ||
9 | |||
diff --git a/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch new file mode 100644 index 0000000000..3eb2c9349a --- /dev/null +++ b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | If we're building an image and some package rebuilds while this is happening | ||
2 | some package can be removed/added to the ipk deploy directory. The image will | ||
3 | not depend on this package so we can safely ignore these cases rather than | ||
4 | error out. | ||
5 | |||
6 | RP - 26/8/09 | ||
7 | |||
8 | Index: opkg-utils/opkg-make-index | ||
9 | =================================================================== | ||
10 | --- opkg-utils.orig/opkg-make-index 2009-08-26 17:21:26.000000000 +0100 | ||
11 | +++ opkg-utils/opkg-make-index 2009-08-26 17:24:05.000000000 +0100 | ||
12 | @@ -96,6 +96,7 @@ | ||
13 | files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb') | ||
14 | files.sort() | ||
15 | for filename in files: | ||
16 | + try: | ||
17 | basename = os.path.basename(filename) | ||
18 | pkg = None | ||
19 | fnameStat = os.stat(filename) | ||
20 | @@ -130,6 +131,9 @@ | ||
21 | to_morgue(basename) | ||
22 | if opt_s: | ||
23 | print filename | ||
24 | + except OSError: | ||
25 | + sys.stderr.write("Package %s disappeared on us!\n" % (filename,)) | ||
26 | + continue | ||
27 | |||
28 | pkgsStampsFile = open(stamplist_filename, "w") | ||
29 | for f in pkgsStamps.keys(): | ||
diff --git a/meta/packages/opkg-utils/opkg-utils_svn.bb b/meta/packages/opkg-utils/opkg-utils_svn.bb index c896300642..53b208db14 100644 --- a/meta/packages/opkg-utils/opkg-utils_svn.bb +++ b/meta/packages/opkg-utils/opkg-utils_svn.bb | |||
@@ -3,12 +3,17 @@ SECTION = "base" | |||
3 | PRIORITY = "optional" | 3 | PRIORITY = "optional" |
4 | LICENSE = "GPL" | 4 | LICENSE = "GPL" |
5 | RDEPENDS = "python" | 5 | RDEPENDS = "python" |
6 | PR = "r2" | 6 | RDEPENDS_virtclass-native = "" |
7 | PR = "r4" | ||
7 | 8 | ||
8 | SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http" | 9 | SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \ |
9 | 10 | file://index-ignore-filenotfound.patch;patch=1" | |
10 | S = "${WORKDIR}/opkg-utils" | ||
11 | 11 | ||
12 | inherit autotools_stage | 12 | inherit autotools_stage |
13 | 13 | ||
14 | S = "${WORKDIR}/opkg-utils" | 14 | S = "${WORKDIR}/opkg-utils" |
15 | |||
16 | # Avoid circular dependencies from package_ipk.bbclass | ||
17 | PACKAGES_virtclass-native = "" | ||
18 | |||
19 | BBCLASSEXTEND = "native" | ||