diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-04-25 12:39:49 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-04-25 12:39:49 +0000 |
commit | b6e43a2e89bcfd40dac884639d6560f15aaf1a1e (patch) | |
tree | c4470d939417057c5bb235c205cf679af9e6ccf0 /meta/packages/opensync | |
parent | caf3b5b1bc3733abcf7a180a411b23d37ab9295c (diff) | |
download | poky-b6e43a2e89bcfd40dac884639d6560f15aaf1a1e.tar.gz |
libopensync: make SVN version buildable (disabled by default)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1556 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/opensync')
-rw-r--r-- | meta/packages/opensync/libopensync/fix-attr.patch | 13 | ||||
-rw-r--r-- | meta/packages/opensync/libopensync/gcc.patch | 29 | ||||
-rw-r--r-- | meta/packages/opensync/libopensync/no-werror.patch | 13 | ||||
-rw-r--r-- | meta/packages/opensync/libopensync/zlib.patch | 13 | ||||
-rw-r--r-- | meta/packages/opensync/libopensync_svn.bb | 103 |
5 files changed, 167 insertions, 4 deletions
diff --git a/meta/packages/opensync/libopensync/fix-attr.patch b/meta/packages/opensync/libopensync/fix-attr.patch new file mode 100644 index 0000000000..7a2e5441c8 --- /dev/null +++ b/meta/packages/opensync/libopensync/fix-attr.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: trunk/opensync/merger/opensync_xmlfield.c | ||
2 | =================================================================== | ||
3 | --- trunk.orig/opensync/merger/opensync_xmlfield.c 2007-04-12 16:40:07.000000000 +0200 | ||
4 | +++ trunk/opensync/merger/opensync_xmlfield.c 2007-04-12 16:40:11.000000000 +0200 | ||
5 | @@ -298,7 +298,7 @@ | ||
6 | int count; | ||
7 | xmlAttrPtr attr = xmlfield->node->properties; | ||
8 | |||
9 | - for(count=0; attribute != NULL; count++) { | ||
10 | + for(count=0; attr != NULL; count++) { | ||
11 | if(count == nth) | ||
12 | return (const char *)attr->name; | ||
13 | attr = attr->next; | ||
diff --git a/meta/packages/opensync/libopensync/gcc.patch b/meta/packages/opensync/libopensync/gcc.patch new file mode 100644 index 0000000000..3eee014339 --- /dev/null +++ b/meta/packages/opensync/libopensync/gcc.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | Index: trunk/SConstruct | ||
2 | =================================================================== | ||
3 | --- trunk.orig/SConstruct 2007-04-25 13:20:13.000000000 +0200 | ||
4 | +++ trunk/SConstruct 2007-04-25 14:00:02.000000000 +0200 | ||
5 | @@ -36,7 +36,11 @@ | ||
6 | opts.Add(BoolOption('enable_python', 'Build python wrapper? (swig required)', 0)) | ||
7 | opts.Add(BoolOption('debug_modules', 'Should unloading of shared modules be avoided (DEBUGGING ONLY!)', 0)) | ||
8 | opts.Add(BoolOption('enable_doxygen', 'Generating OpenSync API with doxygen?', 0)) | ||
9 | - | ||
10 | +opts.AddOptions( | ||
11 | +('CC', 'Path to Custom c compiler', 'gcc'), | ||
12 | +('CXX', 'Path to Custom c++ compiler flags', 'g++'), | ||
13 | +('LDFLAGS', 'Linker flags', ''), | ||
14 | +) | ||
15 | |||
16 | target_dir = SelectBuildDir('build') | ||
17 | sys.path.append(target_dir) | ||
18 | @@ -63,6 +67,11 @@ | ||
19 | env.Append(CCFLAGS = r'-DENABLE_TOOLS=$enable_tools') | ||
20 | env.Append(CCFLAGS = r'-DENABLE_PROFILING=$enable_profiling') | ||
21 | |||
22 | +env.Replace( | ||
23 | + CC = env['CC'], | ||
24 | + CXX = env['CXX'], | ||
25 | + LDFLAGS = env['LDFLAGS'] | ||
26 | +) | ||
27 | |||
28 | # pkg config files | ||
29 | subst_dict={'@prefix@': '$prefix', | ||
diff --git a/meta/packages/opensync/libopensync/no-werror.patch b/meta/packages/opensync/libopensync/no-werror.patch new file mode 100644 index 0000000000..523ceaaeb5 --- /dev/null +++ b/meta/packages/opensync/libopensync/no-werror.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: trunk/build/linux/osync_build.py | ||
2 | =================================================================== | ||
3 | --- trunk.orig/build/linux/osync_build.py 2007-04-25 13:28:44.000000000 +0200 | ||
4 | +++ trunk/build/linux/osync_build.py 2007-04-25 13:28:54.000000000 +0200 | ||
5 | @@ -48,7 +48,7 @@ | ||
6 | env.ParseConfig('pkg-config --cflags --libs libxml-2.0') | ||
7 | env.ParseConfig('pkg-config --cflags --libs sqlite3') | ||
8 | env.Append(CCFLAGS = r'-I.') | ||
9 | - env.Append(CCFLAGS = [r'-Wall', r'-Werror']) | ||
10 | + env.Append(CCFLAGS = [r'-Wall']) | ||
11 | |||
12 | testenv = env.Copy() | ||
13 | testenv.Append(CCFLAGS = r'-I' + testenv.GetLaunchDir() + '/tests') | ||
diff --git a/meta/packages/opensync/libopensync/zlib.patch b/meta/packages/opensync/libopensync/zlib.patch new file mode 100644 index 0000000000..89c10a85bc --- /dev/null +++ b/meta/packages/opensync/libopensync/zlib.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: trunk/opensync/SConscript | ||
2 | =================================================================== | ||
3 | --- trunk.orig/opensync/SConscript 2007-04-25 14:08:21.000000000 +0200 | ||
4 | +++ trunk/opensync/SConscript 2007-04-25 14:08:40.000000000 +0200 | ||
5 | @@ -149,6 +149,8 @@ | ||
6 | gmodule-2.0 | ||
7 | libxml2 | ||
8 | sqlite3 | ||
9 | +z | ||
10 | +m | ||
11 | """ | ||
12 | |||
13 | libopensync = env.SharedLibrary('opensync', Split(sources), LIBS = Split(Libraries)) | ||
diff --git a/meta/packages/opensync/libopensync_svn.bb b/meta/packages/opensync/libopensync_svn.bb index ac7da051c8..0fb86381e6 100644 --- a/meta/packages/opensync/libopensync_svn.bb +++ b/meta/packages/opensync/libopensync_svn.bb | |||
@@ -2,17 +2,112 @@ LICENSE = "LGPL" | |||
2 | HOMEPAGE = "http://www.opensync.org/" | 2 | HOMEPAGE = "http://www.opensync.org/" |
3 | DEPENDS = "sqlite3 libxml2 zlib glib-2.0" | 3 | DEPENDS = "sqlite3 libxml2 zlib glib-2.0" |
4 | PV = "0.22+svn${SRCDATE}" | 4 | PV = "0.22+svn${SRCDATE}" |
5 | SRC_URI = "svn://svn.opensync.org;module=trunk;proto=http" | ||
6 | 5 | ||
7 | inherit autotools pkgconfig lib_package | 6 | SRC_URI = "svn://svn.opensync.org;module=trunk;proto=http \ |
7 | file://fix-attr.patch;patch=1 \ | ||
8 | file://gcc.patch;patch=1 \ | ||
9 | file://zlib.patch;patch=1 \ | ||
10 | file://no-werror.patch;patch=1" | ||
11 | |||
12 | inherit scons | ||
8 | 13 | ||
9 | S = "${WORKDIR}/trunk" | 14 | S = "${WORKDIR}/trunk" |
15 | |||
16 | DEFAULT_PREFERENCE = "-1" | ||
17 | |||
10 | EXTRA_OECONF = "--disable-python" | 18 | EXTRA_OECONF = "--disable-python" |
11 | LEAD_SONAME = "libopensync.so" | 19 | LEAD_SONAME = "libopensync.so" |
12 | 20 | ||
13 | FILES_${PN} += " ${libdir}/opensync/formats/*.so" | 21 | FILES_${PN} += " ${libdir}/opensync/formats/*.so ${datadir}/opensync/ ${libdir}/*.so" |
22 | |||
23 | export HOST_SYS = "${HOST_ARCH}${HOST_VENDOR}-${HOST_OS}" | ||
14 | 24 | ||
15 | do_stage() { | 25 | do_stage() { |
16 | autotools_stage_all | 26 | install -d ${STAGING_LIBDIR}/formats |
27 | |||
28 | install -m 0644 formats/libcontact.so ${STAGING_LIBDIR}/formats/ | ||
29 | install -m 0644 formats/libdata.so ${STAGING_LIBDIR}/formats/ | ||
30 | install -m 0644 formats/libevent.so ${STAGING_LIBDIR}/formats/ | ||
31 | install -m 0644 formats/libfile.so ${STAGING_LIBDIR}/formats/ | ||
32 | install -m 0644 formats/libopensync-*format.so ${STAGING_LIBDIR}/formats/ | ||
33 | install -m 0644 formats/libtodo.so ${STAGING_LIBDIR}/formats/ | ||
34 | install -m 0644 formats/libxmlformat-*.so ${STAGING_LIBDIR}/formats/ | ||
35 | install -m 0644 opensync/libopensync.so ${STAGING_LIBDIR} | ||
36 | |||
37 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ | ||
38 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | ||
39 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
40 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
41 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
42 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | ||
43 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
44 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
45 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
46 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
47 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/version/ | ||
48 | |||
49 | install -m 0644 formats/file.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
50 | install -m 0644 opensync/opensync-client.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
51 | install -m 0644 opensync/opensync-context.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
52 | install -m 0644 opensync/opensync-data.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
53 | install -m 0644 opensync/opensync-engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
54 | install -m 0644 opensync/opensync-error.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
55 | install -m 0644 opensync/opensync-format.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
56 | install -m 0644 opensync/opensync-group.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
57 | install -m 0644 opensync/opensync.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
58 | install -m 0644 opensync/opensync-helper.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
59 | install -m 0644 opensync/opensync-ipc.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
60 | install -m 0644 opensync/opensync_list.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
61 | install -m 0644 opensync/opensync-mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
62 | install -m 0644 opensync/opensync-merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
63 | install -m 0644 opensync/opensync-module.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
64 | install -m 0644 opensync/opensync-plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
65 | install -m 0644 opensync/opensync-serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
66 | install -m 0644 opensync/opensync-support.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
67 | install -m 0644 opensync/opensync-time.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
68 | install -m 0644 opensync/opensync-version.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
69 | install -m 0644 opensync/opensync_xml.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
70 | |||
71 | install -m 0644 opensync/archive/opensync_archive.h ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ | ||
72 | install -m 0644 opensync/data/opensync_change.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | ||
73 | install -m 0644 opensync/data/opensync_data.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | ||
74 | install -m 0644 opensync/engine/opensync_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
75 | install -m 0644 opensync/engine/opensync_obj_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
76 | install -m 0644 opensync/engine/opensync_status.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
77 | install -m 0644 opensync/format/opensync_converter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
78 | install -m 0644 opensync/format/opensync_filter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
79 | install -m 0644 opensync/format/opensync_format_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
80 | install -m 0644 opensync/format/opensync_objformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
81 | install -m 0644 opensync/format/opensync_time.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
82 | install -m 0644 opensync/group/opensync_group_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
83 | install -m 0644 opensync/group/opensync_group.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
84 | install -m 0644 opensync/group/opensync_member.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
85 | install -m 0644 opensync/helper/opensync_anchor.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | ||
86 | install -m 0644 opensync/helper/opensync_hashtable.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | ||
87 | install -m 0644 opensync/ipc/opensync_message.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
88 | install -m 0644 opensync/ipc/opensync_queue.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
89 | install -m 0644 opensync/ipc/opensync_serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
90 | install -m 0644 opensync/mapping/opensync_mapping_entry.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
91 | install -m 0644 opensync/mapping/opensync_mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
92 | install -m 0644 opensync/mapping/opensync_mapping_table.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
93 | install -m 0644 opensync/mapping/opensync_mapping_view.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
94 | install -m 0644 opensync/merger/opensync_capabilities.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
95 | install -m 0644 opensync/merger/opensync_capability.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
96 | install -m 0644 opensync/merger/opensync_merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
97 | install -m 0644 opensync/merger/opensync_xmlfield.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
98 | install -m 0644 opensync/merger/opensync_xmlfieldlist.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
99 | install -m 0644 opensync/merger/opensync_xmlformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
100 | install -m 0644 opensync/plugin/opensync_plugin_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
101 | install -m 0644 opensync/plugin/opensync_plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
102 | install -m 0644 opensync/plugin/opensync_plugin_info.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
103 | install -m 0644 opensync/plugin/opensync_sink.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
104 | install -m 0644 opensync/version/opensync_version.h ${STAGING_INCDIR}/opensync-1.0/opensync/version/ | ||
105 | |||
106 | cat ${S}/opensync-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/opensync-1.0.pc | ||
107 | cat ${S}/osengine-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/osengine-1.0.pc | ||
108 | |||
17 | } | 109 | } |
18 | 110 | ||
111 | do_install_prepend() { | ||
112 | install -d ${D}${libdir} | ||
113 | } | ||