diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-08-09 13:03:24 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-08-09 13:03:24 +0000 |
commit | 895e719c85c5685ca438c6a9447e3e2ec6a94623 (patch) | |
tree | 321919a2f32d620b2d03983ada7fc1c1566fc633 /meta/packages/opensync | |
parent | dc5ff1440c973fc8c3bcc393ab342929cf73781f (diff) | |
download | poky-895e719c85c5685ca438c6a9447e3e2ec6a94623.tar.gz |
opensync stuff: switched to SRCREV
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2463 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/opensync')
-rw-r--r-- | meta/packages/opensync/libopensync-plugin.inc | 12 | ||||
-rw-r--r-- | meta/packages/opensync/libopensync_svn.bb | 254 | ||||
-rw-r--r-- | meta/packages/opensync/libsyncml_svn.bb | 3 | ||||
-rw-r--r-- | meta/packages/opensync/msynctool_svn.bb | 9 |
4 files changed, 181 insertions, 97 deletions
diff --git a/meta/packages/opensync/libopensync-plugin.inc b/meta/packages/opensync/libopensync-plugin.inc index b1986a9e64..a15623bb1a 100644 --- a/meta/packages/opensync/libopensync-plugin.inc +++ b/meta/packages/opensync/libopensync-plugin.inc | |||
@@ -1,15 +1,14 @@ | |||
1 | LICENSE ?= "LGPL" | ||
2 | DEPENDS += " libopensync" | ||
3 | RRECOMMENDS += " msynctool" | ||
4 | HOMEPAGE ?= "http://www.opensync.org/" | ||
5 | PV = "0.22+svnr${SRCREV}" | ||
1 | 6 | ||
2 | PV = "0.22+svn${SRCDATE}" | ||
3 | PLUGIN_NAME ?= "${@bb.data.getVar('PN', d, 1).replace('libopensync-plugin-','')}" | 7 | PLUGIN_NAME ?= "${@bb.data.getVar('PN', d, 1).replace('libopensync-plugin-','')}" |
4 | PLUGIN_SONAME ?= "${@bb.data.getVar('PLUGIN_NAME', d, 1).replace('-','_')}.so" | 8 | PLUGIN_SONAME ?= "${@bb.data.getVar('PLUGIN_NAME', d, 1).replace('-','_')}.so" |
5 | SRC_URI ?= "svn://svn.opensync.org/plugins;module=${PLUGIN_NAME};proto=http" | 9 | SRC_URI ?= "svn://svn.opensync.org/plugins;module=${PLUGIN_NAME};proto=http" |
6 | S ?= "${WORKDIR}/${PLUGIN_NAME}" | 10 | S ?= "${WORKDIR}/${PLUGIN_NAME}" |
7 | 11 | ||
8 | LICENSE ?= "LGPL" | ||
9 | DEPENDS += " libopensync" | ||
10 | RRECOMMENDS += " msynctool" | ||
11 | HOMEPAGE ?= "http://www.opensync.org/" | ||
12 | |||
13 | inherit autotools pkgconfig | 12 | inherit autotools pkgconfig |
14 | 13 | ||
15 | FILES_${PN} += "${datadir} ${libdir}/opensync/plugins/*.so" | 14 | FILES_${PN} += "${datadir} ${libdir}/opensync/plugins/*.so" |
@@ -21,4 +20,3 @@ do_install() { | |||
21 | install -m 644 src/${PLUGIN_NAME} ${D}${datadir}/opensync/defaults | 20 | install -m 644 src/${PLUGIN_NAME} ${D}${datadir}/opensync/defaults |
22 | install -m 755 src/.libs/${PLUGIN_SONAME} ${D}${libdir}/opensync/plugins/ | 21 | install -m 755 src/.libs/${PLUGIN_SONAME} ${D}${libdir}/opensync/plugins/ |
23 | } | 22 | } |
24 | |||
diff --git a/meta/packages/opensync/libopensync_svn.bb b/meta/packages/opensync/libopensync_svn.bb index 0fb86381e6..e3631136e3 100644 --- a/meta/packages/opensync/libopensync_svn.bb +++ b/meta/packages/opensync/libopensync_svn.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | LICENSE = "LGPL" | 1 | LICENSE = "LGPL" |
2 | HOMEPAGE = "http://www.opensync.org/" | 2 | HOMEPAGE = "http://www.opensync.org/" |
3 | DEPENDS = "sqlite3 libxml2 zlib glib-2.0" | 3 | DEPENDS = "sqlite3 libxml2 zlib glib-2.0" |
4 | PV = "0.22+svn${SRCDATE}" | 4 | PV = "0.22+svnr${SRCREV}" |
5 | 5 | ||
6 | SRC_URI = "svn://svn.opensync.org;module=trunk;proto=http \ | 6 | SRC_URI = "svn://svn.opensync.org;module=trunk;proto=http \ |
7 | file://fix-attr.patch;patch=1 \ | 7 | file://fix-attr.patch;patch=1 \ |
@@ -21,90 +21,178 @@ LEAD_SONAME = "libopensync.so" | |||
21 | FILES_${PN} += " ${libdir}/opensync/formats/*.so ${datadir}/opensync/ ${libdir}/*.so" | 21 | FILES_${PN} += " ${libdir}/opensync/formats/*.so ${datadir}/opensync/ ${libdir}/*.so" |
22 | 22 | ||
23 | export HOST_SYS = "${HOST_ARCH}${HOST_VENDOR}-${HOST_OS}" | 23 | export HOST_SYS = "${HOST_ARCH}${HOST_VENDOR}-${HOST_OS}" |
24 | #export PKG_CONFIG_PATH = "${STAGING_DIR}/${TARGET_SYS}/share/pkgconfig" | ||
24 | 25 | ||
25 | do_stage() { | 26 | do_stage() { |
26 | install -d ${STAGING_LIBDIR}/formats | 27 | install -d ${STAGING_LIBDIR}/formats |
27 | 28 | ||
28 | install -m 0644 formats/libcontact.so ${STAGING_LIBDIR}/formats/ | 29 | install -m 0644 formats/libcontact.so ${STAGING_LIBDIR}/formats/ |
29 | install -m 0644 formats/libdata.so ${STAGING_LIBDIR}/formats/ | 30 | install -m 0644 formats/libdata.so ${STAGING_LIBDIR}/formats/ |
30 | install -m 0644 formats/libevent.so ${STAGING_LIBDIR}/formats/ | 31 | install -m 0644 formats/libevent.so ${STAGING_LIBDIR}/formats/ |
31 | install -m 0644 formats/libfile.so ${STAGING_LIBDIR}/formats/ | 32 | install -m 0644 formats/libfile.so ${STAGING_LIBDIR}/formats/ |
32 | install -m 0644 formats/libopensync-*format.so ${STAGING_LIBDIR}/formats/ | 33 | install -m 0644 formats/libopensync-vformat.so ${STAGING_LIBDIR}/formats/ |
33 | install -m 0644 formats/libtodo.so ${STAGING_LIBDIR}/formats/ | 34 | install -m 0644 formats/libopensync-xmlformat.so ${STAGING_LIBDIR}/formats/ |
34 | install -m 0644 formats/libxmlformat-*.so ${STAGING_LIBDIR}/formats/ | 35 | install -m 0644 formats/libtodo.so ${STAGING_LIBDIR}/formats/ |
35 | install -m 0644 opensync/libopensync.so ${STAGING_LIBDIR} | 36 | install -m 0644 formats/libxmlformat-doc.so ${STAGING_LIBDIR}/formats/ |
36 | 37 | install -m 0644 formats/libxmlformat-vcal.so ${STAGING_LIBDIR}/formats/ | |
37 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ | 38 | install -m 0644 formats/libxmlformat-vcard.so ${STAGING_LIBDIR}/formats/ |
38 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | 39 | install -m 0644 formats/libxmlformat-vtodo.so ${STAGING_LIBDIR}/formats/ |
39 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | 40 | install -m 0644 opensync/libopensync.so ${STAGING_LIBDIR} |
40 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | 41 | |
41 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | 42 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ |
42 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | 43 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/data/ |
43 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | 44 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ |
44 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | 45 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/format/ |
45 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | 46 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/group/ |
46 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | 47 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ |
47 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/version/ | 48 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ |
48 | 49 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | |
49 | install -m 0644 formats/file.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 50 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ |
50 | install -m 0644 opensync/opensync-client.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 51 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ |
51 | install -m 0644 opensync/opensync-context.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 52 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/version/ |
52 | install -m 0644 opensync/opensync-data.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 53 | |
53 | install -m 0644 opensync/opensync-engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 54 | install -m 0644 formats/file.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
54 | install -m 0644 opensync/opensync-error.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 55 | install -m 0644 opensync/opensync-client.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
55 | install -m 0644 opensync/opensync-format.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 56 | install -m 0644 opensync/opensync-context.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
56 | install -m 0644 opensync/opensync-group.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 57 | install -m 0644 opensync/opensync-data.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
57 | install -m 0644 opensync/opensync.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 58 | install -m 0644 opensync/opensync-engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
58 | install -m 0644 opensync/opensync-helper.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 59 | install -m 0644 opensync/opensync-error.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
59 | install -m 0644 opensync/opensync-ipc.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 60 | install -m 0644 opensync/opensync-format.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
60 | install -m 0644 opensync/opensync_list.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 61 | install -m 0644 opensync/opensync-group.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
61 | install -m 0644 opensync/opensync-mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 62 | install -m 0644 opensync/opensync.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
62 | install -m 0644 opensync/opensync-merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 63 | install -m 0644 opensync/opensync-helper.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
63 | install -m 0644 opensync/opensync-module.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 64 | install -m 0644 opensync/opensync-ipc.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
64 | install -m 0644 opensync/opensync-plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 65 | install -m 0644 opensync/opensync_list.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
65 | install -m 0644 opensync/opensync-serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 66 | install -m 0644 opensync/opensync-mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
66 | install -m 0644 opensync/opensync-support.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 67 | install -m 0644 opensync/opensync-merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
67 | install -m 0644 opensync/opensync-time.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 68 | install -m 0644 opensync/opensync-module.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
68 | install -m 0644 opensync/opensync-version.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 69 | install -m 0644 opensync/opensync-plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
69 | install -m 0644 opensync/opensync_xml.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | 70 | install -m 0644 opensync/opensync-serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
70 | 71 | install -m 0644 opensync/opensync-support.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | |
71 | install -m 0644 opensync/archive/opensync_archive.h ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ | 72 | install -m 0644 opensync/opensync-time.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
72 | install -m 0644 opensync/data/opensync_change.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | 73 | install -m 0644 opensync/opensync-version.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
73 | install -m 0644 opensync/data/opensync_data.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | 74 | install -m 0644 opensync/opensync_xml.h ${STAGING_INCDIR}/opensync-1.0/opensync/ |
74 | install -m 0644 opensync/engine/opensync_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | 75 | |
75 | install -m 0644 opensync/engine/opensync_obj_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | 76 | install -m 0644 opensync/archive/opensync_archive.h ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ |
76 | install -m 0644 opensync/engine/opensync_status.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | 77 | install -m 0644 opensync/data/opensync_change.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ |
77 | install -m 0644 opensync/format/opensync_converter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | 78 | install -m 0644 opensync/data/opensync_data.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ |
78 | install -m 0644 opensync/format/opensync_filter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | 79 | install -m 0644 opensync/engine/opensync_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ |
79 | install -m 0644 opensync/format/opensync_format_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | 80 | install -m 0644 opensync/engine/opensync_obj_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ |
80 | install -m 0644 opensync/format/opensync_objformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | 81 | install -m 0644 opensync/engine/opensync_status.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ |
81 | install -m 0644 opensync/format/opensync_time.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | 82 | install -m 0644 opensync/format/opensync_converter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ |
82 | install -m 0644 opensync/group/opensync_group_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | 83 | install -m 0644 opensync/format/opensync_filter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ |
83 | install -m 0644 opensync/group/opensync_group.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | 84 | install -m 0644 opensync/format/opensync_format_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ |
84 | install -m 0644 opensync/group/opensync_member.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | 85 | install -m 0644 opensync/format/opensync_objformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ |
85 | install -m 0644 opensync/helper/opensync_anchor.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | 86 | install -m 0644 opensync/format/opensync_time.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ |
86 | install -m 0644 opensync/helper/opensync_hashtable.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | 87 | install -m 0644 opensync/group/opensync_group_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ |
87 | install -m 0644 opensync/ipc/opensync_message.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | 88 | install -m 0644 opensync/group/opensync_group.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ |
88 | install -m 0644 opensync/ipc/opensync_queue.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | 89 | install -m 0644 opensync/group/opensync_member.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ |
89 | install -m 0644 opensync/ipc/opensync_serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | 90 | install -m 0644 opensync/helper/opensync_anchor.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ |
90 | install -m 0644 opensync/mapping/opensync_mapping_entry.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | 91 | install -m 0644 opensync/helper/opensync_hashtable.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ |
91 | install -m 0644 opensync/mapping/opensync_mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | 92 | install -m 0644 opensync/ipc/opensync_message.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ |
92 | install -m 0644 opensync/mapping/opensync_mapping_table.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | 93 | install -m 0644 opensync/ipc/opensync_queue.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ |
93 | install -m 0644 opensync/mapping/opensync_mapping_view.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | 94 | install -m 0644 opensync/ipc/opensync_serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ |
94 | install -m 0644 opensync/merger/opensync_capabilities.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | 95 | install -m 0644 opensync/mapping/opensync_mapping_entry.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ |
95 | install -m 0644 opensync/merger/opensync_capability.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | 96 | install -m 0644 opensync/mapping/opensync_mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ |
96 | install -m 0644 opensync/merger/opensync_merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | 97 | install -m 0644 opensync/mapping/opensync_mapping_table.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ |
97 | install -m 0644 opensync/merger/opensync_xmlfield.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | 98 | install -m 0644 opensync/mapping/opensync_mapping_view.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ |
98 | install -m 0644 opensync/merger/opensync_xmlfieldlist.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | 99 | install -m 0644 opensync/merger/opensync_capabilities.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ |
99 | install -m 0644 opensync/merger/opensync_xmlformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | 100 | install -m 0644 opensync/merger/opensync_capability.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ |
100 | install -m 0644 opensync/plugin/opensync_plugin_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | 101 | install -m 0644 opensync/merger/opensync_merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ |
101 | install -m 0644 opensync/plugin/opensync_plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | 102 | install -m 0644 opensync/merger/opensync_xmlfield.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ |
102 | install -m 0644 opensync/plugin/opensync_plugin_info.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | 103 | install -m 0644 opensync/merger/opensync_xmlfieldlist.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ |
103 | install -m 0644 opensync/plugin/opensync_sink.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | 104 | install -m 0644 opensync/merger/opensync_xmlformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ |
104 | install -m 0644 opensync/version/opensync_version.h ${STAGING_INCDIR}/opensync-1.0/opensync/version/ | 105 | install -m 0644 opensync/plugin/opensync_plugin_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ |
105 | 106 | install -m 0644 opensync/plugin/opensync_plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | |
106 | cat ${S}/opensync-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/opensync-1.0.pc | 107 | install -m 0644 opensync/plugin/opensync_plugin_info.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ |
107 | cat ${S}/osengine-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/osengine-1.0.pc | 108 | install -m 0644 opensync/plugin/opensync_sink.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ |
109 | install -m 0644 opensync/version/opensync_version.h ${STAGING_INCDIR}/opensync-1.0/opensync/version/ | ||
110 | |||
111 | cat ${S}/opensync-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/opensync-1.0.pc | ||
112 | cat ${S}/osengine-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/osengine-1.0.pc | ||
113 | |||
114 | install -d ${STAGING_LIBDIR}/formats | ||
115 | |||
116 | install -m 0644 formats/libcontact.so ${STAGING_LIBDIR}/formats/ | ||
117 | install -m 0644 formats/libdata.so ${STAGING_LIBDIR}/formats/ | ||
118 | install -m 0644 formats/libevent.so ${STAGING_LIBDIR}/formats/ | ||
119 | install -m 0644 formats/libfile.so ${STAGING_LIBDIR}/formats/ | ||
120 | install -m 0644 formats/libopensync-*format.so ${STAGING_LIBDIR}/formats/ | ||
121 | install -m 0644 formats/libtodo.so ${STAGING_LIBDIR}/formats/ | ||
122 | install -m 0644 formats/libxmlformat-*.so ${STAGING_LIBDIR}/formats/ | ||
123 | install -m 0644 opensync/libopensync.so ${STAGING_LIBDIR} | ||
124 | |||
125 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ | ||
126 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | ||
127 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
128 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
129 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
130 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | ||
131 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
132 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
133 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
134 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
135 | install -d ${STAGING_INCDIR}/opensync-1.0/opensync/version/ | ||
136 | |||
137 | install -m 0644 formats/file.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
138 | install -m 0644 opensync/opensync-client.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
139 | install -m 0644 opensync/opensync-context.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
140 | install -m 0644 opensync/opensync-data.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
141 | install -m 0644 opensync/opensync-engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
142 | install -m 0644 opensync/opensync-error.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
143 | install -m 0644 opensync/opensync-format.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
144 | install -m 0644 opensync/opensync-group.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
145 | install -m 0644 opensync/opensync.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
146 | install -m 0644 opensync/opensync-helper.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
147 | install -m 0644 opensync/opensync-ipc.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
148 | install -m 0644 opensync/opensync_list.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
149 | install -m 0644 opensync/opensync-mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
150 | install -m 0644 opensync/opensync-merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
151 | install -m 0644 opensync/opensync-module.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
152 | install -m 0644 opensync/opensync-plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
153 | install -m 0644 opensync/opensync-serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
154 | install -m 0644 opensync/opensync-support.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
155 | install -m 0644 opensync/opensync-time.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
156 | install -m 0644 opensync/opensync-version.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
157 | install -m 0644 opensync/opensync_xml.h ${STAGING_INCDIR}/opensync-1.0/opensync/ | ||
158 | |||
159 | install -m 0644 opensync/archive/opensync_archive.h ${STAGING_INCDIR}/opensync-1.0/opensync/archive/ | ||
160 | install -m 0644 opensync/data/opensync_change.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | ||
161 | install -m 0644 opensync/data/opensync_data.h ${STAGING_INCDIR}/opensync-1.0/opensync/data/ | ||
162 | install -m 0644 opensync/engine/opensync_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
163 | install -m 0644 opensync/engine/opensync_obj_engine.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
164 | install -m 0644 opensync/engine/opensync_status.h ${STAGING_INCDIR}/opensync-1.0/opensync/engine/ | ||
165 | install -m 0644 opensync/format/opensync_converter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
166 | install -m 0644 opensync/format/opensync_filter.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
167 | install -m 0644 opensync/format/opensync_format_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
168 | install -m 0644 opensync/format/opensync_objformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
169 | install -m 0644 opensync/format/opensync_time.h ${STAGING_INCDIR}/opensync-1.0/opensync/format/ | ||
170 | install -m 0644 opensync/group/opensync_group_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
171 | install -m 0644 opensync/group/opensync_group.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
172 | install -m 0644 opensync/group/opensync_member.h ${STAGING_INCDIR}/opensync-1.0/opensync/group/ | ||
173 | install -m 0644 opensync/helper/opensync_anchor.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | ||
174 | install -m 0644 opensync/helper/opensync_hashtable.h ${STAGING_INCDIR}/opensync-1.0/opensync/helper/ | ||
175 | install -m 0644 opensync/ipc/opensync_message.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
176 | install -m 0644 opensync/ipc/opensync_queue.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
177 | install -m 0644 opensync/ipc/opensync_serializer.h ${STAGING_INCDIR}/opensync-1.0/opensync/ipc/ | ||
178 | install -m 0644 opensync/mapping/opensync_mapping_entry.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
179 | install -m 0644 opensync/mapping/opensync_mapping.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
180 | install -m 0644 opensync/mapping/opensync_mapping_table.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
181 | install -m 0644 opensync/mapping/opensync_mapping_view.h ${STAGING_INCDIR}/opensync-1.0/opensync/mapping/ | ||
182 | install -m 0644 opensync/merger/opensync_capabilities.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
183 | install -m 0644 opensync/merger/opensync_capability.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
184 | install -m 0644 opensync/merger/opensync_merger.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
185 | install -m 0644 opensync/merger/opensync_xmlfield.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
186 | install -m 0644 opensync/merger/opensync_xmlfieldlist.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
187 | install -m 0644 opensync/merger/opensync_xmlformat.h ${STAGING_INCDIR}/opensync-1.0/opensync/merger/ | ||
188 | install -m 0644 opensync/plugin/opensync_plugin_env.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
189 | install -m 0644 opensync/plugin/opensync_plugin.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
190 | install -m 0644 opensync/plugin/opensync_plugin_info.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
191 | install -m 0644 opensync/plugin/opensync_sink.h ${STAGING_INCDIR}/opensync-1.0/opensync/plugin/ | ||
192 | install -m 0644 opensync/version/opensync_version.h ${STAGING_INCDIR}/opensync-1.0/opensync/version/ | ||
193 | |||
194 | cat ${S}/opensync-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/opensync-1.0.pc | ||
195 | cat ${S}/osengine-1.0.pc | sed -e "s:=${WORKDIR}/image${libdir}:=${STAGING_LIBDIR}:" -e "s:=${WORKDIR}/image${includedir}:=${STAGING_INCDIR}:" -e "s:=${WORKDIR}/image${datadir}:=${STAGING_DATADIR}:" > ${PKG_CONFIG_PATH}/osengine-1.0.pc | ||
108 | 196 | ||
109 | } | 197 | } |
110 | 198 | ||
diff --git a/meta/packages/opensync/libsyncml_svn.bb b/meta/packages/opensync/libsyncml_svn.bb index 3bb61c4865..61fca06857 100644 --- a/meta/packages/opensync/libsyncml_svn.bb +++ b/meta/packages/opensync/libsyncml_svn.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | DESCRIPTION = "Libsyncml is a implementation of the SyncML protocol." | 1 | DESCRIPTION = "Libsyncml is a implementation of the SyncML protocol." |
2 | HOMEPAGE = "http://libsyncml.opensync.org/" | 2 | HOMEPAGE = "http://libsyncml.opensync.org/" |
3 | LICENSE = "LGPL" | 3 | LICENSE = "LGPL" |
4 | |||
5 | DEPENDS = "sed-native wbxml2 libsoup libxml2 bluez-libs openobex" | 4 | DEPENDS = "sed-native wbxml2 libsoup libxml2 bluez-libs openobex" |
5 | PV = "0.4.2+svnr${SRCREV}" | ||
6 | 6 | ||
7 | PV = "0.4.2+svn${SRCDATE}" | ||
8 | SRC_URI = "svn://svn.opensync.org/libsyncml;module=trunk;proto=http" | 7 | SRC_URI = "svn://svn.opensync.org/libsyncml;module=trunk;proto=http" |
9 | S = "${WORKDIR}/trunk" | 8 | S = "${WORKDIR}/trunk" |
10 | 9 | ||
diff --git a/meta/packages/opensync/msynctool_svn.bb b/meta/packages/opensync/msynctool_svn.bb index 319cf39d05..88cb8f4b54 100644 --- a/meta/packages/opensync/msynctool_svn.bb +++ b/meta/packages/opensync/msynctool_svn.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | PV = "0.22+svn${SRCDATE}" | ||
2 | SRC_URI = "svn://svn.opensync.org/multisync;module=trunk;proto=http" | ||
3 | S = "${WORKDIR}/trunk" | ||
4 | |||
5 | LICENSE = "GPL" | 1 | LICENSE = "GPL" |
6 | DEPENDS = "libopensync" | 2 | DEPENDS = "libopensync" |
7 | HOMEPAGE = "http://www.opensync.org/" | 3 | HOMEPAGE = "http://www.opensync.org/" |
4 | PV = "0.22+svnr${SRCREV}" | ||
8 | 5 | ||
9 | inherit autotools pkgconfig | 6 | SRC_URI = "svn://svn.opensync.org/multisync;module=trunk;proto=http" |
7 | S = "${WORKDIR}/trunk" | ||
10 | 8 | ||
9 | inherit autotools pkgconfig | ||