summaryrefslogtreecommitdiffstats
path: root/meta/packages/openssl/openssl-0.9.8o/debian/perl-path.diff
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-06-25 17:09:40 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:19:05 +0100
commitc4713d040a5b3ae90781cbb31a19868a1fa39f4e (patch)
tree066b4062f2a0646829254c5e1a7195e287a1c4a1 /meta/packages/openssl/openssl-0.9.8o/debian/perl-path.diff
parent7ec15f47750b2977972bbbbbe2aadf064c9671d5 (diff)
downloadpoky-c4713d040a5b3ae90781cbb31a19868a1fa39f4e.tar.gz
openssl: upgrade to version 0.9.8o
from 0.9.8g update bugtracker and license 1.0.0 and 1.0.0a are available, but introduce some interface changes. Stick on 0.9.8 versions for now for stability (0.9.8 branch is still updated for security fixes) changes: - add perl-native as build dependency - include /usr/lib/ssl/* in the package - break down debian.package into separate patches under directory debian. Original monolithic patch is >1000 lines, and not very maintainable. Verbatim copy the debian patches, among which two are not needed, but still included with apply=no to increase readability The new patches are ~700 lines. Most that was in the monolithic patch but not here have already been fixed in upstream. - fix-md5-x86_64.patch is in upstream and thus removed - rebase shared-libs.patch Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/openssl/openssl-0.9.8o/debian/perl-path.diff')
-rw-r--r--meta/packages/openssl/openssl-0.9.8o/debian/perl-path.diff760
1 files changed, 760 insertions, 0 deletions
diff --git a/meta/packages/openssl/openssl-0.9.8o/debian/perl-path.diff b/meta/packages/openssl/openssl-0.9.8o/debian/perl-path.diff
new file mode 100644
index 0000000000..a72f938d82
--- /dev/null
+++ b/meta/packages/openssl/openssl-0.9.8o/debian/perl-path.diff
@@ -0,0 +1,760 @@
1From: Kurt Roeckx <kurt@roeckx.be>
2Subject: Change the perl path's to /usr/bin/perl
3
4This is the result of running:
5perl util/perlpath.pl /usr/bin
6
7The upstream sources have this set to various different paths.
8
9--- openssl-0.9.8m.orig/Configure
10+++ openssl-0.9.8m/Configure
11@@ -1,4 +1,4 @@
12-:
13+#!/usr/bin/perl
14 eval 'exec perl -S $0 ${1+"$@"}'
15 if $running_under_some_shell;
16 ##
17--- openssl-0.9.8m.orig/VMS/VMSify-conf.pl
18+++ openssl-0.9.8m/VMS/VMSify-conf.pl
19@@ -1,4 +1,4 @@
20-#! /usr/bin/perl
21+#!/usr/bin/perl
22
23 use strict;
24 use warnings;
25--- openssl-0.9.8m.orig/Netware/do_tests.pl
26+++ openssl-0.9.8m/Netware/do_tests.pl
27@@ -1,4 +1,4 @@
28-# perl script to run OpenSSL tests
29+#!/usr/bin/perl
30
31
32 my $base_path = "\\openssl";
33--- openssl-0.9.8m.orig/apps/progs.pl
34+++ openssl-0.9.8m/apps/progs.pl
35@@ -1,4 +1,4 @@
36-#!/usr/local/bin/perl
37+#!/usr/bin/perl
38
39 print "/* apps/progs.h */\n";
40 print "/* automatically generated by progs.pl for openssl.c */\n\n";
41--- openssl-0.9.8m.orig/os2/backwardify.pl
42+++ openssl-0.9.8m/os2/backwardify.pl
43@@ -1,4 +1,4 @@
44-#!/usr/bin/perl -w
45+#!/usr/bin/perl
46 use strict;
47
48 # Use as $0
49--- openssl-0.9.8m.orig/times/091/mips-rel.pl
50+++ openssl-0.9.8m/times/091/mips-rel.pl
51@@ -1,4 +1,4 @@
52-#!/usr/local/bin/perl
53+#!/usr/bin/perl
54
55 &doit(100,"Pentium 100 32",0.0195,0.1000,0.6406,4.6100); # pentium-100
56 &doit(200,"PPro 200 32",0.0070,0.0340,0.2087,1.4700); # pentium-100
57--- openssl-0.9.8m.orig/fips/mkfipsscr.pl
58+++ openssl-0.9.8m/fips/mkfipsscr.pl
59@@ -1,4 +1,4 @@
60-#!/usr/local/bin/perl -w
61+#!/usr/bin/perl
62 # Quick & dirty utility to generate a script for executing the
63 # FIPS 140-2 CMVP algorithm tests based on the pathnames of
64 # input algorithm test files actually present (the unqualified
65--- openssl-0.9.8m.orig/fips/fipsalgtest.pl
66+++ openssl-0.9.8m/fips/fipsalgtest.pl
67@@ -1,4 +1,4 @@
68-#!/usr/bin/perl -w
69+#!/usr/bin/perl
70 # Perl utility to run or verify FIPS 140-2 CMVP algorithm tests based on the
71 # pathnames of input algorithm test files actually present (the unqualified
72 # file names are consistent but the pathnames are not).
73--- openssl-0.9.8m.orig/ms/uplink.pl
74+++ openssl-0.9.8m/ms/uplink.pl
75@@ -1,4 +1,4 @@
76-#!/usr/bin/env perl
77+#!/usr/bin/perl
78 #
79 # For Microsoft CL this is implemented as inline assembler. So that
80 # even though this script can generate even Win32 code, we'll be
81--- openssl-0.9.8m.orig/ms/segrenam.pl
82+++ openssl-0.9.8m/ms/segrenam.pl
83@@ -1,4 +1,4 @@
84-#!/usr/bin/env perl
85+#!/usr/bin/perl
86
87 my $quiet = 1;
88
89--- openssl-0.9.8m.orig/ms/cmp.pl
90+++ openssl-0.9.8m/ms/cmp.pl
91@@ -1,4 +1,4 @@
92-#!/usr/local/bin/perl
93+#!/usr/bin/perl
94
95 ($#ARGV == 1) || die "usage: cmp.pl <file1> <file2>\n";
96
97--- openssl-0.9.8m.orig/test/cms-test.pl
98+++ openssl-0.9.8m/test/cms-test.pl
99@@ -1,4 +1,4 @@
100-# test/cms-test.pl
101+#!/usr/bin/perl
102 # Written by Dr Stephen N Henson (steve@openssl.org) for the OpenSSL
103 # project.
104 #
105--- openssl-0.9.8m.orig/test/cms-examples.pl
106+++ openssl-0.9.8m/test/cms-examples.pl
107@@ -1,4 +1,4 @@
108-# test/cms-examples.pl
109+#!/usr/bin/perl
110 # Written by Dr Stephen N Henson (steve@openssl.org) for the OpenSSL
111 # project.
112 #
113--- openssl-0.9.8m.orig/demos/b64.pl
114+++ openssl-0.9.8m/demos/b64.pl
115@@ -1,4 +1,4 @@
116-#!/usr/local/bin/perl
117+#!/usr/bin/perl
118
119 #
120 # Make PEM encoded data have lines of 64 bytes of data
121--- openssl-0.9.8m.orig/demos/tunala/configure.in
122+++ openssl-0.9.8m/demos/tunala/configure.in
123@@ -1,4 +1,4 @@
124-dnl Process this file with autoconf to produce a configure script.
125+#!/usr/bin/perl
126 AC_INIT(tunala.c)
127 AM_CONFIG_HEADER(config.h)
128 AM_INIT_AUTOMAKE(tunala, 0.0.1-dev)
129--- openssl-0.9.8m.orig/crypto/x86cpuid.pl
130+++ openssl-0.9.8m/crypto/x86cpuid.pl
131@@ -1,4 +1,4 @@
132-#!/usr/bin/env perl
133+#!/usr/bin/perl
134
135 push(@INC,"perlasm");
136 require "x86asm.pl";
137--- openssl-0.9.8m.orig/crypto/x86_64cpuid.pl
138+++ openssl-0.9.8m/crypto/x86_64cpuid.pl
139@@ -1,4 +1,4 @@
140-#!/usr/bin/env perl
141+#!/usr/bin/perl
142
143 $output=shift;
144 $masm=1 if ($output =~ /\.asm/);
145--- openssl-0.9.8m.orig/crypto/md5/asm/md5-586.pl
146+++ openssl-0.9.8m/crypto/md5/asm/md5-586.pl
147@@ -1,4 +1,4 @@
148-#!/usr/local/bin/perl
149+#!/usr/bin/perl
150
151 # Normal is the
152 # md5_block_x86(MD5_CTX *c, ULONG *X);
153--- openssl-0.9.8m.orig/crypto/md5/asm/md5-x86_64.pl
154+++ openssl-0.9.8m/crypto/md5/asm/md5-x86_64.pl
155@@ -1,4 +1,4 @@
156-#!/usr/bin/perl -w
157+#!/usr/bin/perl
158 #
159 # MD5 optimized for AMD64.
160 #
161--- openssl-0.9.8m.orig/crypto/sha/asm/sha1-ia64.pl
162+++ openssl-0.9.8m/crypto/sha/asm/sha1-ia64.pl
163@@ -1,4 +1,4 @@
164-#!/usr/bin/env perl
165+#!/usr/bin/perl
166 #
167 # ====================================================================
168 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
169--- openssl-0.9.8m.orig/crypto/sha/asm/sha1-x86_64.pl
170+++ openssl-0.9.8m/crypto/sha/asm/sha1-x86_64.pl
171@@ -1,4 +1,4 @@
172-#!/usr/bin/env perl
173+#!/usr/bin/perl
174 #
175 # ====================================================================
176 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
177--- openssl-0.9.8m.orig/crypto/sha/asm/sha512-sse2.pl
178+++ openssl-0.9.8m/crypto/sha/asm/sha512-sse2.pl
179@@ -1,4 +1,4 @@
180-#!/usr/bin/env perl
181+#!/usr/bin/perl
182 #
183 # ====================================================================
184 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
185--- openssl-0.9.8m.orig/crypto/sha/asm/sha512-ia64.pl
186+++ openssl-0.9.8m/crypto/sha/asm/sha512-ia64.pl
187@@ -1,4 +1,4 @@
188-#!/usr/bin/env perl
189+#!/usr/bin/perl
190 #
191 # ====================================================================
192 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
193--- openssl-0.9.8m.orig/crypto/sha/asm/sha512-x86_64.pl
194+++ openssl-0.9.8m/crypto/sha/asm/sha512-x86_64.pl
195@@ -1,4 +1,4 @@
196-#!/usr/bin/env perl
197+#!/usr/bin/perl
198 #
199 # ====================================================================
200 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
201--- openssl-0.9.8m.orig/crypto/sha/asm/sha1-586.pl
202+++ openssl-0.9.8m/crypto/sha/asm/sha1-586.pl
203@@ -1,4 +1,4 @@
204-#!/usr/bin/env perl
205+#!/usr/bin/perl
206
207 # ====================================================================
208 # [Re]written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
209--- openssl-0.9.8m.orig/crypto/des/asm/des-586.pl
210+++ openssl-0.9.8m/crypto/des/asm/des-586.pl
211@@ -1,4 +1,4 @@
212-#!/usr/local/bin/perl
213+#!/usr/bin/perl
214 #
215 # The inner loop instruction sequence and the IP/FP modifications are from
216 # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
217--- openssl-0.9.8m.orig/crypto/des/asm/desboth.pl
218+++ openssl-0.9.8m/crypto/des/asm/desboth.pl
219@@ -1,4 +1,4 @@
220-#!/usr/local/bin/perl
221+#!/usr/bin/perl
222
223 $L="edi";
224 $R="esi";
225--- openssl-0.9.8m.orig/crypto/des/asm/des686.pl
226+++ openssl-0.9.8m/crypto/des/asm/des686.pl
227@@ -1,4 +1,4 @@
228-#!/usr/local/bin/perl
229+#!/usr/bin/perl
230
231 $prog="des686.pl";
232
233--- openssl-0.9.8m.orig/crypto/des/asm/crypt586.pl
234+++ openssl-0.9.8m/crypto/des/asm/crypt586.pl
235@@ -1,4 +1,4 @@
236-#!/usr/local/bin/perl
237+#!/usr/bin/perl
238 #
239 # The inner loop instruction sequence and the IP/FP modifications are from
240 # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
241--- openssl-0.9.8m.orig/crypto/lhash/num.pl
242+++ openssl-0.9.8m/crypto/lhash/num.pl
243@@ -1,4 +1,4 @@
244-#!/usr/local/bin/perl
245+#!/usr/bin/perl
246
247 #node 10 -> 4
248
249--- openssl-0.9.8m.orig/crypto/ripemd/asm/rmd-586.pl
250+++ openssl-0.9.8m/crypto/ripemd/asm/rmd-586.pl
251@@ -1,4 +1,4 @@
252-#!/usr/local/bin/perl
253+#!/usr/bin/perl
254
255 # Normal is the
256 # ripemd160_block_asm_data_order(RIPEMD160_CTX *c, ULONG *X,int blocks);
257--- openssl-0.9.8m.orig/crypto/rc4/asm/rc4-586.pl
258+++ openssl-0.9.8m/crypto/rc4/asm/rc4-586.pl
259@@ -1,4 +1,4 @@
260-#!/usr/local/bin/perl
261+#!/usr/bin/perl
262
263 # At some point it became apparent that the original SSLeay RC4
264 # assembler implementation performs suboptimaly on latest IA-32
265--- openssl-0.9.8m.orig/crypto/rc4/asm/rc4-x86_64.pl
266+++ openssl-0.9.8m/crypto/rc4/asm/rc4-x86_64.pl
267@@ -1,4 +1,4 @@
268-#!/usr/bin/env perl
269+#!/usr/bin/perl
270 #
271 # ====================================================================
272 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
273--- openssl-0.9.8m.orig/crypto/cast/asm/cast-586.pl
274+++ openssl-0.9.8m/crypto/cast/asm/cast-586.pl
275@@ -1,4 +1,4 @@
276-#!/usr/local/bin/perl
277+#!/usr/bin/perl
278
279 # define for pentium pro friendly version
280 $ppro=1;
281--- openssl-0.9.8m.orig/crypto/rc5/asm/rc5-586.pl
282+++ openssl-0.9.8m/crypto/rc5/asm/rc5-586.pl
283@@ -1,4 +1,4 @@
284-#!/usr/local/bin/perl
285+#!/usr/bin/perl
286
287 push(@INC,"perlasm","../../perlasm");
288 require "x86asm.pl";
289--- openssl-0.9.8m.orig/crypto/perlasm/x86ms.pl
290+++ openssl-0.9.8m/crypto/perlasm/x86ms.pl
291@@ -1,4 +1,4 @@
292-#!/usr/local/bin/perl
293+#!/usr/bin/perl
294
295 package x86ms;
296
297--- openssl-0.9.8m.orig/crypto/perlasm/x86asm.pl
298+++ openssl-0.9.8m/crypto/perlasm/x86asm.pl
299@@ -1,4 +1,4 @@
300-#!/usr/local/bin/perl
301+#!/usr/bin/perl
302
303 # require 'x86asm.pl';
304 # &asm_init("cpp","des-586.pl");
305--- openssl-0.9.8m.orig/crypto/perlasm/x86nasm.pl
306+++ openssl-0.9.8m/crypto/perlasm/x86nasm.pl
307@@ -1,4 +1,4 @@
308-#!/usr/local/bin/perl
309+#!/usr/bin/perl
310
311 package x86nasm;
312
313--- openssl-0.9.8m.orig/crypto/perlasm/x86unix.pl
314+++ openssl-0.9.8m/crypto/perlasm/x86unix.pl
315@@ -1,4 +1,4 @@
316-#!/usr/local/bin/perl
317+#!/usr/bin/perl
318
319 package x86unix; # GAS actually...
320
321--- openssl-0.9.8m.orig/crypto/perlasm/cbc.pl
322+++ openssl-0.9.8m/crypto/perlasm/cbc.pl
323@@ -1,4 +1,4 @@
324-#!/usr/local/bin/perl
325+#!/usr/bin/perl
326
327 # void des_ncbc_encrypt(input, output, length, schedule, ivec, enc)
328 # des_cblock (*input);
329--- openssl-0.9.8m.orig/crypto/perlasm/x86_64-xlate.pl
330+++ openssl-0.9.8m/crypto/perlasm/x86_64-xlate.pl
331@@ -1,4 +1,4 @@
332-#!/usr/bin/env perl
333+#!/usr/bin/perl
334
335 # Ascetic x86_64 AT&T to MASM assembler translator by <appro>.
336 #
337--- openssl-0.9.8m.orig/crypto/bf/asm/bf-686.pl
338+++ openssl-0.9.8m/crypto/bf/asm/bf-686.pl
339@@ -1,4 +1,4 @@
340-#!/usr/local/bin/perl
341+#!/usr/bin/perl
342
343 push(@INC,"perlasm","../../perlasm");
344 require "x86asm.pl";
345--- openssl-0.9.8m.orig/crypto/bf/asm/bf-586.pl
346+++ openssl-0.9.8m/crypto/bf/asm/bf-586.pl
347@@ -1,4 +1,4 @@
348-#!/usr/local/bin/perl
349+#!/usr/bin/perl
350
351 push(@INC,"perlasm","../../perlasm");
352 require "x86asm.pl";
353--- openssl-0.9.8m.orig/crypto/objects/objects.pl
354+++ openssl-0.9.8m/crypto/objects/objects.pl
355@@ -1,4 +1,4 @@
356-#!/usr/local/bin/perl
357+#!/usr/bin/perl
358
359 open (NUMIN,"$ARGV[1]") || die "Can't open number file $ARGV[1]";
360 $max_nid=0;
361--- openssl-0.9.8m.orig/crypto/objects/obj_dat.pl
362+++ openssl-0.9.8m/crypto/objects/obj_dat.pl
363@@ -1,4 +1,4 @@
364-#!/usr/local/bin/perl
365+#!/usr/bin/perl
366
367 # fixes bug in floating point emulation on sparc64 when
368 # this script produces off-by-one output on sparc64
369--- openssl-0.9.8m.orig/crypto/conf/keysets.pl
370+++ openssl-0.9.8m/crypto/conf/keysets.pl
371@@ -1,4 +1,4 @@
372-#!/usr/local/bin/perl
373+#!/usr/bin/perl
374
375 $NUMBER=0x01;
376 $UPPER=0x02;
377--- openssl-0.9.8m.orig/crypto/bn/bn_prime.pl
378+++ openssl-0.9.8m/crypto/bn/bn_prime.pl
379@@ -1,4 +1,4 @@
380-#!/usr/local/bin/perl
381+#!/usr/bin/perl
382 # bn_prime.pl
383
384 $num=2048;
385--- openssl-0.9.8m.orig/crypto/bn/asm/x86.pl
386+++ openssl-0.9.8m/crypto/bn/asm/x86.pl
387@@ -1,4 +1,4 @@
388-#!/usr/local/bin/perl
389+#!/usr/bin/perl
390
391 push(@INC,"perlasm","../../perlasm");
392 require "x86asm.pl";
393--- openssl-0.9.8m.orig/crypto/bn/asm/ppc.pl
394+++ openssl-0.9.8m/crypto/bn/asm/ppc.pl
395@@ -1,4 +1,4 @@
396-#!/usr/bin/env perl
397+#!/usr/bin/perl
398 #
399 # Implemented as a Perl wrapper as we want to support several different
400 # architectures with single file. We pick up the target based on the
401--- openssl-0.9.8m.orig/crypto/bn/asm/co-586.pl
402+++ openssl-0.9.8m/crypto/bn/asm/co-586.pl
403@@ -1,4 +1,4 @@
404-#!/usr/local/bin/perl
405+#!/usr/bin/perl
406
407 push(@INC,"perlasm","../../perlasm");
408 require "x86asm.pl";
409--- openssl-0.9.8m.orig/crypto/bn/asm/bn-586.pl
410+++ openssl-0.9.8m/crypto/bn/asm/bn-586.pl
411@@ -1,4 +1,4 @@
412-#!/usr/local/bin/perl
413+#!/usr/bin/perl
414
415 push(@INC,"perlasm","../../perlasm");
416 require "x86asm.pl";
417--- openssl-0.9.8m.orig/crypto/bn/asm/mo-586.pl
418+++ openssl-0.9.8m/crypto/bn/asm/mo-586.pl
419@@ -1,4 +1,4 @@
420-#!/usr/bin/env perl
421+#!/usr/bin/perl
422
423 # This is crypto/bn/asm/x86-mont.pl (with asciz from crypto/perlasm/x86asm.pl)
424 # from OpenSSL 0.9.9-dev
425--- openssl-0.9.8m.orig/crypto/bn/asm/x86_64-mont.pl
426+++ openssl-0.9.8m/crypto/bn/asm/x86_64-mont.pl
427@@ -1,4 +1,4 @@
428-#!/usr/bin/env perl
429+#!/usr/bin/perl
430
431 # ====================================================================
432 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
433--- openssl-0.9.8m.orig/crypto/bn/asm/x86/comba.pl
434+++ openssl-0.9.8m/crypto/bn/asm/x86/comba.pl
435@@ -1,4 +1,4 @@
436-#!/usr/local/bin/perl
437+#!/usr/bin/perl
438 # x86 assember
439
440 sub mul_add_c
441--- openssl-0.9.8m.orig/crypto/bn/asm/x86/add.pl
442+++ openssl-0.9.8m/crypto/bn/asm/x86/add.pl
443@@ -1,4 +1,4 @@
444-#!/usr/local/bin/perl
445+#!/usr/bin/perl
446 # x86 assember
447
448 sub bn_add_words
449--- openssl-0.9.8m.orig/crypto/bn/asm/x86/mul.pl
450+++ openssl-0.9.8m/crypto/bn/asm/x86/mul.pl
451@@ -1,4 +1,4 @@
452-#!/usr/local/bin/perl
453+#!/usr/bin/perl
454 # x86 assember
455
456 sub bn_mul_words
457--- openssl-0.9.8m.orig/crypto/bn/asm/x86/mul_add.pl
458+++ openssl-0.9.8m/crypto/bn/asm/x86/mul_add.pl
459@@ -1,4 +1,4 @@
460-#!/usr/local/bin/perl
461+#!/usr/bin/perl
462 # x86 assember
463
464 sub bn_mul_add_words
465--- openssl-0.9.8m.orig/crypto/bn/asm/x86/sqr.pl
466+++ openssl-0.9.8m/crypto/bn/asm/x86/sqr.pl
467@@ -1,4 +1,4 @@
468-#!/usr/local/bin/perl
469+#!/usr/bin/perl
470 # x86 assember
471
472 sub bn_sqr_words
473--- openssl-0.9.8m.orig/crypto/bn/asm/x86/sub.pl
474+++ openssl-0.9.8m/crypto/bn/asm/x86/sub.pl
475@@ -1,4 +1,4 @@
476-#!/usr/local/bin/perl
477+#!/usr/bin/perl
478 # x86 assember
479
480 sub bn_sub_words
481--- openssl-0.9.8m.orig/crypto/bn/asm/x86/div.pl
482+++ openssl-0.9.8m/crypto/bn/asm/x86/div.pl
483@@ -1,4 +1,4 @@
484-#!/usr/local/bin/perl
485+#!/usr/bin/perl
486 # x86 assember
487
488 sub bn_div_words
489--- openssl-0.9.8m.orig/crypto/aes/asm/aes-586.pl
490+++ openssl-0.9.8m/crypto/aes/asm/aes-586.pl
491@@ -1,4 +1,4 @@
492-#!/usr/bin/env perl
493+#!/usr/bin/perl
494 #
495 # ====================================================================
496 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
497--- openssl-0.9.8m.orig/crypto/aes/asm/aes-x86_64.pl
498+++ openssl-0.9.8m/crypto/aes/asm/aes-x86_64.pl
499@@ -1,4 +1,4 @@
500-#!/usr/bin/env perl
501+#!/usr/bin/perl
502 #
503 # ====================================================================
504 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
505--- openssl-0.9.8m.orig/crypto/asn1/charmap.pl
506+++ openssl-0.9.8m/crypto/asn1/charmap.pl
507@@ -1,4 +1,4 @@
508-#!/usr/local/bin/perl -w
509+#!/usr/bin/perl
510
511 use strict;
512
513--- openssl-0.9.8m.orig/util/mksdef.pl
514+++ openssl-0.9.8m/util/mksdef.pl
515@@ -1,4 +1,4 @@
516-
517+#!/usr/bin/perl
518 # Perl script to split libeay32.def into two distinct DEF files for use in
519 # fipdso mode. It works out symbols in each case by running "link" command and
520 # parsing the output to find the list of missing symbols then splitting
521--- openssl-0.9.8m.orig/util/dirname.pl
522+++ openssl-0.9.8m/util/dirname.pl
523@@ -1,4 +1,4 @@
524-#!/usr/local/bin/perl
525+#!/usr/bin/perl
526
527 if ($#ARGV < 0) {
528 die "dirname.pl: too few arguments\n";
529--- openssl-0.9.8m.orig/util/tab_num.pl
530+++ openssl-0.9.8m/util/tab_num.pl
531@@ -1,4 +1,4 @@
532-#!/usr/local/bin/perl
533+#!/usr/bin/perl
534
535 $num=1;
536 $width=40;
537--- openssl-0.9.8m.orig/util/sp-diff.pl
538+++ openssl-0.9.8m/util/sp-diff.pl
539@@ -1,4 +1,4 @@
540-#!/usr/local/bin/perl
541+#!/usr/bin/perl
542 #
543 # This file takes as input, the files that have been output from
544 # ssleay speed.
545--- openssl-0.9.8m.orig/util/mkerr.pl
546+++ openssl-0.9.8m/util/mkerr.pl
547@@ -1,4 +1,4 @@
548-#!/usr/local/bin/perl -w
549+#!/usr/bin/perl
550
551 my $config = "crypto/err/openssl.ec";
552 my $debug = 0;
553--- openssl-0.9.8m.orig/util/clean-depend.pl
554+++ openssl-0.9.8m/util/clean-depend.pl
555@@ -1,4 +1,4 @@
556-#!/usr/local/bin/perl -w
557+#!/usr/bin/perl
558 # Clean the dependency list in a makefile of standard includes...
559 # Written by Ben Laurie <ben@algroup.co.uk> 19 Jan 1999
560
561--- openssl-0.9.8m.orig/util/add_cr.pl
562+++ openssl-0.9.8m/util/add_cr.pl
563@@ -1,4 +1,4 @@
564-#!/usr/local/bin/perl
565+#!/usr/bin/perl
566 #
567 # This adds a copyright message to a souce code file.
568 # It also gets the file name correct.
569--- openssl-0.9.8m.orig/util/pod2man.pl
570+++ openssl-0.9.8m/util/pod2man.pl
571@@ -1,4 +1,4 @@
572-: #!/usr/bin/perl-5.005
573+#!/usr/bin/perl
574 eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
575 if $running_under_some_shell;
576
577--- openssl-0.9.8m.orig/util/mkstack.pl
578+++ openssl-0.9.8m/util/mkstack.pl
579@@ -1,4 +1,4 @@
580-#!/usr/local/bin/perl -w
581+#!/usr/bin/perl
582
583 # This is a utility that searches out "DECLARE_STACK_OF()"
584 # declarations in .h and .c files, and updates/creates/replaces
585--- openssl-0.9.8m.orig/util/selftest.pl
586+++ openssl-0.9.8m/util/selftest.pl
587@@ -1,4 +1,4 @@
588-#!/usr/local/bin/perl -w
589+#!/usr/bin/perl
590 #
591 # Run the test suite and generate a report
592 #
593--- openssl-0.9.8m.orig/util/ck_errf.pl
594+++ openssl-0.9.8m/util/ck_errf.pl
595@@ -1,4 +1,4 @@
596-#!/usr/local/bin/perl
597+#!/usr/bin/perl
598 #
599 # This is just a quick script to scan for cases where the 'error'
600 # function name in a XXXerr() macro is wrong.
601--- openssl-0.9.8m.orig/util/mklink.pl
602+++ openssl-0.9.8m/util/mklink.pl
603@@ -1,4 +1,4 @@
604-#!/usr/local/bin/perl
605+#!/usr/bin/perl
606
607 # mklink.pl
608
609--- openssl-0.9.8m.orig/util/src-dep.pl
610+++ openssl-0.9.8m/util/src-dep.pl
611@@ -1,4 +1,4 @@
612-#!/usr/local/bin/perl
613+#!/usr/bin/perl
614
615 # we make up an array of
616 # $file{function_name}=filename;
617--- openssl-0.9.8m.orig/util/deleof.pl
618+++ openssl-0.9.8m/util/deleof.pl
619@@ -1,4 +1,4 @@
620-#!/usr/local/bin/perl
621+#!/usr/bin/perl
622
623 while (<>)
624 {
625--- openssl-0.9.8m.orig/util/arx.pl
626+++ openssl-0.9.8m/util/arx.pl
627@@ -1,4 +1,4 @@
628-#!/bin/perl
629+#!/usr/bin/perl
630
631 # Simple perl script to wrap round "ar" program and exclude any
632 # object files in the environment variable EXCL_OBJ
633--- openssl-0.9.8m.orig/util/copy.pl
634+++ openssl-0.9.8m/util/copy.pl
635@@ -1,4 +1,4 @@
636-#!/usr/local/bin/perl
637+#!/usr/bin/perl
638
639 use Fcntl;
640
641--- openssl-0.9.8m.orig/util/mkdir-p.pl
642+++ openssl-0.9.8m/util/mkdir-p.pl
643@@ -1,4 +1,4 @@
644-#!/usr/local/bin/perl
645+#!/usr/bin/perl
646
647 # mkdir-p.pl
648
649--- openssl-0.9.8m.orig/util/mkdef.pl
650+++ openssl-0.9.8m/util/mkdef.pl
651@@ -1,4 +1,4 @@
652-#!/usr/local/bin/perl -w
653+#!/usr/bin/perl
654 #
655 # generate a .def file
656 #
657--- openssl-0.9.8m.orig/util/files.pl
658+++ openssl-0.9.8m/util/files.pl
659@@ -1,4 +1,4 @@
660-#!/usr/local/bin/perl
661+#!/usr/bin/perl
662 #
663 # used to generate the file MINFO for use by util/mk1mf.pl
664 # It is basically a list of all variables from the passed makefile
665--- openssl-0.9.8m.orig/util/mkfiles.pl
666+++ openssl-0.9.8m/util/mkfiles.pl
667@@ -1,4 +1,4 @@
668-#!/usr/local/bin/perl
669+#!/usr/bin/perl
670 #
671 # This is a hacked version of files.pl for systems that can't do a 'make files'.
672 # Do a perl util/mkminfo.pl >MINFO to build MINFO
673--- openssl-0.9.8m.orig/util/perlpath.pl
674+++ openssl-0.9.8m/util/perlpath.pl
675@@ -1,4 +1,4 @@
676-#!/usr/local/bin/perl
677+#!/usr/bin/perl
678 #
679 # modify the '#!/usr/local/bin/perl'
680 # line in all scripts that rely on perl.
681--- openssl-0.9.8m.orig/util/mk1mf.pl
682+++ openssl-0.9.8m/util/mk1mf.pl
683@@ -1,4 +1,4 @@
684-#!/usr/local/bin/perl
685+#!/usr/bin/perl
686 # A bit of an evil hack but it post processes the file ../MINFO which
687 # is generated by `make files` in the top directory.
688 # This script outputs one mega makefile that has no shell stuff or any
689--- openssl-0.9.8m.orig/util/err-ins.pl
690+++ openssl-0.9.8m/util/err-ins.pl
691@@ -1,4 +1,4 @@
692-#!/usr/local/bin/perl
693+#!/usr/bin/perl
694 #
695 # tack error codes onto the end of a file
696 #
697--- openssl-0.9.8m.orig/util/pl/Mingw32.pl
698+++ openssl-0.9.8m/util/pl/Mingw32.pl
699@@ -1,4 +1,4 @@
700-#!/usr/local/bin/perl
701+#!/usr/bin/perl
702 #
703 # Mingw32.pl -- Mingw
704 #
705--- openssl-0.9.8m.orig/util/pl/unix.pl
706+++ openssl-0.9.8m/util/pl/unix.pl
707@@ -1,4 +1,4 @@
708-#!/usr/local/bin/perl
709+#!/usr/bin/perl
710 #
711 # unix.pl - the standard unix makefile stuff.
712 #
713--- openssl-0.9.8m.orig/util/pl/netware.pl
714+++ openssl-0.9.8m/util/pl/netware.pl
715@@ -1,4 +1,4 @@
716-# Metrowerks Codewarrior or gcc / nlmconv for NetWare
717+#!/usr/bin/perl
718 #
719
720 $version_header = "crypto/opensslv.h";
721--- openssl-0.9.8m.orig/util/pl/VC-32.pl
722+++ openssl-0.9.8m/util/pl/VC-32.pl
723@@ -1,4 +1,4 @@
724-#!/usr/local/bin/perl
725+#!/usr/bin/perl
726 # VC-32.pl - unified script for Microsoft Visual C++, covering Win32,
727 # Win64 and WinCE [follow $FLAVOR variable to trace the differences].
728 #
729--- openssl-0.9.8m.orig/util/pl/OS2-EMX.pl
730+++ openssl-0.9.8m/util/pl/OS2-EMX.pl
731@@ -1,4 +1,4 @@
732-#!/usr/local/bin/perl
733+#!/usr/bin/perl
734 #
735 # OS2-EMX.pl - for EMX GCC on OS/2
736 #
737--- openssl-0.9.8m.orig/util/pl/ultrix.pl
738+++ openssl-0.9.8m/util/pl/ultrix.pl
739@@ -1,4 +1,4 @@
740-#!/usr/local/bin/perl
741+#!/usr/bin/perl
742 #
743 # linux.pl - the standard unix makefile stuff.
744 #
745--- openssl-0.9.8m.orig/util/pl/linux.pl
746+++ openssl-0.9.8m/util/pl/linux.pl
747@@ -1,4 +1,4 @@
748-#!/usr/local/bin/perl
749+#!/usr/bin/perl
750 #
751 # linux.pl - the standard unix makefile stuff.
752 #
753--- openssl-0.9.8m.orig/util/pl/BC-32.pl
754+++ openssl-0.9.8m/util/pl/BC-32.pl
755@@ -1,4 +1,4 @@
756-#!/usr/local/bin/perl
757+#!/usr/bin/perl
758 # Borland C++ builder 3 and 4 -- Janez Jere <jj@void.si>
759 #
760