diff options
author | Chris Lord <chris@openedhand.com> | 2007-01-03 20:55:29 +0000 |
---|---|---|
committer | Chris Lord <chris@openedhand.com> | 2007-01-03 20:55:29 +0000 |
commit | 4ffe8f6b1ff640722880cf2cd88990956de87e30 (patch) | |
tree | 736a16d112da36e87f3709ee93555a48b534dba5 /meta/packages/openobex | |
parent | a34d402b9eaf56d23df83c19c422b7d0d9c708d1 (diff) | |
download | poky-4ffe8f6b1ff640722880cf2cd88990956de87e30.tar.gz |
Check in opensync/libsync/synctool bits - Mostly compiles, not tested
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1113 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/openobex')
-rw-r--r-- | meta/packages/openobex/files/disable-cable-test.patch | 16 | ||||
-rw-r--r-- | meta/packages/openobex/files/libusb_crosscompile_check.patch | 12 | ||||
-rw-r--r-- | meta/packages/openobex/openobex_1.2.bb | 32 |
3 files changed, 60 insertions, 0 deletions
diff --git a/meta/packages/openobex/files/disable-cable-test.patch b/meta/packages/openobex/files/disable-cable-test.patch new file mode 100644 index 0000000000..95b636dd8f --- /dev/null +++ b/meta/packages/openobex/files/disable-cable-test.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- openobex-1.2/apps/Makefile.am~disable-cable-test | ||
7 | +++ openobex-1.2/apps/Makefile.am | ||
8 | @@ -6,7 +6,7 @@ | ||
9 | obex_io.c obex_io.h \ | ||
10 | obex_put_common.c obex_put_common.h | ||
11 | |||
12 | -bin_PROGRAMS = irxfer obex_tcp irobex_palm3 obex_test | ||
13 | +bin_PROGRAMS = irxfer obex_tcp irobex_palm3 | ||
14 | |||
15 | obex_test_SOURCES = \ | ||
16 | obex_test.c obex_test.h \ | ||
diff --git a/meta/packages/openobex/files/libusb_crosscompile_check.patch b/meta/packages/openobex/files/libusb_crosscompile_check.patch new file mode 100644 index 0000000000..c28921b8ca --- /dev/null +++ b/meta/packages/openobex/files/libusb_crosscompile_check.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | diff -Naur openobex-1.2_old/acinclude.m4 openobex-1.2/acinclude.m4 | ||
2 | --- openobex-1.2_old/acinclude.m4 2006-03-07 19:57:49.000000000 +0200 | ||
3 | +++ openobex-1.2/acinclude.m4 2006-04-18 23:07:25.000000000 +0300 | ||
4 | @@ -195,7 +195,7 @@ | ||
5 | |||
6 | if (test "${usb_enable}" = "yes" && test "${usb_found}" = "yes"); then | ||
7 | AC_DEFINE(HAVE_USB, 1, [Define if system supports USB and it's enabled]) | ||
8 | - AC_CHECK_FILE(${usb_prefix}/lib/pkgconfig/libusb.pc, REQUIRES="$REQUIRES libusb") | ||
9 | + REQUIRES="libusb" | ||
10 | fi | ||
11 | |||
12 | AM_CONDITIONAL(APPS, test "${apps_enable}" = "yes") | ||
diff --git a/meta/packages/openobex/openobex_1.2.bb b/meta/packages/openobex/openobex_1.2.bb new file mode 100644 index 0000000000..0c8d118cff --- /dev/null +++ b/meta/packages/openobex/openobex_1.2.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = "The Openobex project is an open source implementation of the \ | ||
2 | Object Exchange (OBEX) protocol." | ||
3 | HOMEPAGE = "http://openobex.triq.net" | ||
4 | SECTION = "libs" | ||
5 | PROVIDES = "openobex-apps" | ||
6 | DEPENDS = "libusb bluez-libs" | ||
7 | LICENSE = "GPL" | ||
8 | PR = "r3" | ||
9 | |||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \ | ||
11 | file://disable-cable-test.patch;patch=1" \ | ||
12 | file://libusb_crosscompile_check.patch;patch=1" | ||
13 | |||
14 | inherit autotools binconfig pkgconfig | ||
15 | |||
16 | EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \ | ||
17 | --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.." | ||
18 | |||
19 | do_stage() { | ||
20 | oe_libinstall -so -C lib libopenobex ${STAGING_LIBDIR} | ||
21 | ln -sf libopenobex.so ${STAGING_LIBDIR}/libopenobex-1.2.so | ||
22 | install -d ${STAGING_INCDIR}/openobex | ||
23 | install -m 0644 include/*.h ${STAGING_INCDIR}/openobex/ | ||
24 | install -d ${STAGING_DIR}/aclocal | ||
25 | install -m 0644 openobex.m4 ${STAGING_DATADIR}/aclocal/ | ||
26 | } | ||
27 | |||
28 | # how to stop shlibrename from renaming -apps? | ||
29 | PACKAGES += "openobex-apps" | ||
30 | FILES_${PN} = "${libdir}/lib*.so.*" | ||
31 | FILES_${PN}-dev += "${bindir}/openobex-config" | ||
32 | FILES_${PN}-apps = "${bindir}/*" | ||