summaryrefslogtreecommitdiffstats
path: root/meta/packages/openobex/openobex_1.2.bb
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2007-01-03 20:55:29 +0000
committerChris Lord <chris@openedhand.com>2007-01-03 20:55:29 +0000
commit4ffe8f6b1ff640722880cf2cd88990956de87e30 (patch)
tree736a16d112da36e87f3709ee93555a48b534dba5 /meta/packages/openobex/openobex_1.2.bb
parenta34d402b9eaf56d23df83c19c422b7d0d9c708d1 (diff)
downloadpoky-4ffe8f6b1ff640722880cf2cd88990956de87e30.tar.gz
Check in opensync/libsync/synctool bits - Mostly compiles, not tested
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1113 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/openobex/openobex_1.2.bb')
-rw-r--r--meta/packages/openobex/openobex_1.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/openobex/openobex_1.2.bb b/meta/packages/openobex/openobex_1.2.bb
new file mode 100644
index 0000000000..0c8d118cff
--- /dev/null
+++ b/meta/packages/openobex/openobex_1.2.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "The Openobex project is an open source implementation of the \
2Object Exchange (OBEX) protocol."
3HOMEPAGE = "http://openobex.triq.net"
4SECTION = "libs"
5PROVIDES = "openobex-apps"
6DEPENDS = "libusb bluez-libs"
7LICENSE = "GPL"
8PR = "r3"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
11 file://disable-cable-test.patch;patch=1" \
12 file://libusb_crosscompile_check.patch;patch=1"
13
14inherit autotools binconfig pkgconfig
15
16EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
17 --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
18
19do_stage() {
20 oe_libinstall -so -C lib libopenobex ${STAGING_LIBDIR}
21 ln -sf libopenobex.so ${STAGING_LIBDIR}/libopenobex-1.2.so
22 install -d ${STAGING_INCDIR}/openobex
23 install -m 0644 include/*.h ${STAGING_INCDIR}/openobex/
24 install -d ${STAGING_DIR}/aclocal
25 install -m 0644 openobex.m4 ${STAGING_DATADIR}/aclocal/
26}
27
28# how to stop shlibrename from renaming -apps?
29PACKAGES += "openobex-apps"
30FILES_${PN} = "${libdir}/lib*.so.*"
31FILES_${PN}-dev += "${bindir}/openobex-config"
32FILES_${PN}-apps = "${bindir}/*"