diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/oh | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oh')
-rw-r--r-- | meta/packages/oh/usbinit.bb | 19 | ||||
-rwxr-xr-x | meta/packages/oh/usbinit/usb-gether | 19 |
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/oh/usbinit.bb b/meta/packages/oh/usbinit.bb new file mode 100644 index 0000000000..bfc8490dc1 --- /dev/null +++ b/meta/packages/oh/usbinit.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | DESCRIPTION = "Quick hack to start gadget Ethernet on the 770" | ||
2 | LICENSE = "GPL" | ||
3 | SECTION = "x11" | ||
4 | PRIORITY = "optional" | ||
5 | PR = "r0" | ||
6 | |||
7 | SRC_URI = "file://usb-gether" | ||
8 | S = ${WORKDIR} | ||
9 | |||
10 | do_install() { | ||
11 | install -d ${D}/etc | ||
12 | install -d ${D}/etc/init.d | ||
13 | install usb-gether ${D}/etc/init.d | ||
14 | } | ||
15 | |||
16 | inherit update-rc.d | ||
17 | |||
18 | INITSCRIPT_NAME = "usb-gether" | ||
19 | INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ." | ||
diff --git a/meta/packages/oh/usbinit/usb-gether b/meta/packages/oh/usbinit/usb-gether new file mode 100755 index 0000000000..590e77b22a --- /dev/null +++ b/meta/packages/oh/usbinit/usb-gether | |||
@@ -0,0 +1,19 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | case "$1" in | ||
4 | start) | ||
5 | /sbin/depmod -a | ||
6 | /sbin/modprobe g_ether | ||
7 | ifconfig usb0 192.168.1.120 | ||
8 | ;; | ||
9 | |||
10 | stop) | ||
11 | |||
12 | ;; | ||
13 | |||
14 | *) | ||
15 | echo "usage: $0 { start | stop }" | ||
16 | ;; | ||
17 | esac | ||
18 | |||
19 | exit 0 | ||