summaryrefslogtreecommitdiffstats
path: root/meta/packages/ofono
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/ofono
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/ofono')
-rw-r--r--meta/packages/ofono/files/ofono42
-rw-r--r--meta/packages/ofono/ofono.inc16
-rw-r--r--meta/packages/ofono/ofono_0.17.bb7
-rw-r--r--meta/packages/ofono/ofono_git.bb13
4 files changed, 0 insertions, 78 deletions
diff --git a/meta/packages/ofono/files/ofono b/meta/packages/ofono/files/ofono
deleted file mode 100644
index 6d46fb8966..0000000000
--- a/meta/packages/ofono/files/ofono
+++ /dev/null
@@ -1,42 +0,0 @@
1#!/bin/sh
2
3DAEMON=/usr/sbin/ofonod
4PIDFILE=/var/run/ofonod.pid
5DESC="Telephony daemon"
6
7if [ -f /etc/default/ofono] ; then
8 . /etc/default/ofono
9fi
10
11set -e
12
13do_start() {
14 $DAEMON
15}
16
17do_stop() {
18 start-stop-daemon --stop --name ofonod --quiet
19}
20
21case "$1" in
22 start)
23 echo "Starting $DESC"
24 do_start
25 ;;
26 stop)
27 echo "Stopping $DESC"
28 do_stop
29 ;;
30 restart|force-reload)
31 echo "Restarting $DESC"
32 do_stop
33 sleep 1
34 do_start
35 ;;
36 *)
37 echo "Usage: $0 {start|stop|restart|force-reload}" >&2
38 exit 1
39 ;;
40esac
41
42exit 0
diff --git a/meta/packages/ofono/ofono.inc b/meta/packages/ofono/ofono.inc
deleted file mode 100644
index 8948e57ae7..0000000000
--- a/meta/packages/ofono/ofono.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1HOMEPAGE = "http://www.ofono.org"
2SUMMARY = "open source telephony"
3LICENSE = "GPL"
4
5inherit autotools pkgconfig update-rc.d
6
7DEPENDS = "dbus glib-2.0"
8
9INITSCRIPT_NAME = "ofono"
10INITSCRIPT_PARAMS = "defaults 22"
11
12do_install_append() {
13 install -d ${D}${sysconfdir}/init.d/
14 install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
15}
16
diff --git a/meta/packages/ofono/ofono_0.17.bb b/meta/packages/ofono/ofono_0.17.bb
deleted file mode 100644
index 02b64e5b28..0000000000
--- a/meta/packages/ofono/ofono_0.17.bb
+++ /dev/null
@@ -1,7 +0,0 @@
1require ofono.inc
2
3PR = "r0"
4
5SRC_URI = "http://www.kernel.org/pub/linux/network/ofono/${P}.tar.bz2 \
6 file://ofono"
7
diff --git a/meta/packages/ofono/ofono_git.bb b/meta/packages/ofono/ofono_git.bb
deleted file mode 100644
index 3e2c4108cf..0000000000
--- a/meta/packages/ofono/ofono_git.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1require ofono.inc
2
3S = "${WORKDIR}/git"
4PV = "0.12-git${SRCPV}"
5PR = "r1"
6
7SRC_URI = "git://git.kernel.org/pub/scm/network/ofono/ofono.git;protocol=git \
8 file://ofono"
9
10do_configure_prepend () {
11 ${S}/bootstrap
12}
13