diff options
author | Qing He <qing.he@intel.com> | 2010-07-07 13:55:23 +0800 |
---|---|---|
committer | Saul Wold <Saul.Wold@intel.com> | 2010-07-08 21:14:00 -0700 |
commit | 3451dc818787031b8dfd69db4baf213a4a085024 (patch) | |
tree | 957aeb63a77b9d8c1022cc5d3cbb34d1021fdd40 /meta/packages/nfs-utils | |
parent | 5bd2ba7e23cc90e1e4e99a19f19281f6449edc1e (diff) | |
download | poky-3451dc818787031b8dfd69db4baf213a4a085024.tar.gz |
nfs-utils: upgrade to version 1.2.2
from 1.0.6
changes:
- there are several new dependencies: tirpc, libcap libgss,
libnfsimap, libevent and libwrap. disable tirpc, libgss, libwrap
- several changes are in upstream now, include the bzero change
and stat-include change, remove the patches
- a new build system is used, custom macros are now moved to aclocal/,
acinclude and rpcgen fixes are not necessary any more
- rebase uclibc patch
- enable nfsv41, nfsv3 and nfsv4 are default turned on
- do_compile is no longer needed
- the install target has changed a lot, instead of updating the file
list manually, try to use oe_runmake install for installation.
Several files are built against build environment, they are removed
from the packages.
Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/nfs-utils')
-rw-r--r-- | meta/packages/nfs-utils/files/uclibc_bzero_fix.patch | 17 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch | 142 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines | 5 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch | 13 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch | 11 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch | 11 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch (renamed from meta/packages/nfs-utils/files/nfs-utils-1.0.6-uclibc.patch) | 2 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils/nfsserver (renamed from meta/packages/nfs-utils/files/nfsserver) | 0 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils_1.0.6.bb | 78 | ||||
-rw-r--r-- | meta/packages/nfs-utils/nfs-utils_1.2.2.bb | 54 |
10 files changed, 55 insertions, 278 deletions
diff --git a/meta/packages/nfs-utils/files/uclibc_bzero_fix.patch b/meta/packages/nfs-utils/files/uclibc_bzero_fix.patch deleted file mode 100644 index 2006192d28..0000000000 --- a/meta/packages/nfs-utils/files/uclibc_bzero_fix.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | --- | ||
2 | support/nfs/svc_socket.c | 2 +- | ||
3 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
4 | |||
5 | Index: nfs-utils-1.0.6/support/nfs/svc_socket.c | ||
6 | =================================================================== | ||
7 | --- nfs-utils-1.0.6.orig/support/nfs/svc_socket.c 2007-05-27 16:14:09.000000000 +0100 | ||
8 | +++ nfs-utils-1.0.6/support/nfs/svc_socket.c 2007-05-28 22:43:55.000000000 +0100 | ||
9 | @@ -63,7 +63,7 @@ svc_socket (u_long number, int type, int | ||
10 | } | ||
11 | } | ||
12 | |||
13 | - __bzero ((char *) &addr, sizeof (addr)); | ||
14 | + memset ((char *) &addr,0, sizeof (addr)); | ||
15 | addr.sin_family = AF_INET; | ||
16 | |||
17 | #ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */ | ||
diff --git a/meta/packages/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch b/meta/packages/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch deleted file mode 100644 index 0d2d7f3824..0000000000 --- a/meta/packages/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch +++ /dev/null | |||
@@ -1,142 +0,0 @@ | |||
1 | --- nfs-utils-1.0.6/acinclude.m4.old 2004-11-07 12:28:58.000000000 +0000 | ||
2 | +++ nfs-utils-1.0.6/acinclude.m4 2000-10-11 22:49:45.000000000 +0100 | ||
3 | @@ -0,0 +1,139 @@ | ||
4 | +dnl aclocal.m4 -- custom autoconf macros for various purposes | ||
5 | +dnl Updated for Autoconf v2 | ||
6 | +dnl | ||
7 | +dnl ******** save/restore stuff ********** | ||
8 | +define(AC_KNFSD_SAVE, | ||
9 | + [AC_LANG_SAVE | ||
10 | + save_LDFLAGS=$LDFLAGS | ||
11 | + save_CFLAGS=$CFLAGS | ||
12 | + save_CXXFLAGS=$CXXFLAGS | ||
13 | + save_LIBS=$LIBS | ||
14 | +])dnl | ||
15 | +define(AC_KNFSD_RESTORE, | ||
16 | + [LDFLAGS=$save_LDFLAGS | ||
17 | + CFLAGS=$save_CFLAGS | ||
18 | + CXXFLAGS=$save_CXXFLAGS | ||
19 | + LIBS=$save_LIBS | ||
20 | + AC_LANG_RESTORE | ||
21 | +])dnl | ||
22 | +dnl *********** GNU libc 2 *************** | ||
23 | +define(AC_GNULIBC, | ||
24 | + [AC_MSG_CHECKING(for GNU libc2) | ||
25 | + AC_CACHE_VAL(knfsd_cv_glibc2, | ||
26 | + [AC_TRY_CPP([ | ||
27 | + #include <features.h> | ||
28 | + #if !defined(__GLIBC__) | ||
29 | + # error Nope | ||
30 | + #endif], knfsd_cv_glibc2=yes, knfsd_cv_glibc2=no)]) | ||
31 | + AC_MSG_RESULT($knfsd_cv_glibc2) | ||
32 | + if test $knfsd_cv_glibc2 = yes; then | ||
33 | + CFLAGS="$CFLAGS -D_GNU_SOURCE" | ||
34 | + CXXFLAGS="$CXXFLAGS -D_GNU_SOURCE" | ||
35 | + fi | ||
36 | +]) dnl | ||
37 | +dnl | ||
38 | +dnl ************* egcs ******************* | ||
39 | +define(AC_PROG_EGCS, | ||
40 | + [AC_MSG_CHECKING(for egcs) | ||
41 | + AC_CACHE_VAL(knfsd_cv_prog_EGCS, | ||
42 | + [case `$CC --version 2>/dev/null` in | ||
43 | + egcs*) | ||
44 | + knfsd_cv_prog_EGCS=yes;; | ||
45 | + *) | ||
46 | + knfsd_cv_prog_EGCS=no;; | ||
47 | + esac | ||
48 | + ]) | ||
49 | + AC_MSG_RESULT($knfsd_cv_prog_EGCS) | ||
50 | + test $knfsd_cv_prog_EGCS = yes && AC_DEFINE(HAVE_EGCS) | ||
51 | +]) dnl | ||
52 | +dnl *********** sizeof(dev_t) ************** | ||
53 | +dnl ** We have to kludge this rather than use AC_CHECK_SIZEOF because | ||
54 | +dnl ** we have to include sys/types.h. Ugh. | ||
55 | +define(AC_DEV_T_SIZE, | ||
56 | + [AC_MSG_CHECKING(size of dev_t) | ||
57 | + AC_CACHE_VAL(ac_cv_sizeof_dev_t, | ||
58 | + [AC_TRY_LINK( | ||
59 | + [#include <stdio.h> | ||
60 | + #include <sys/types.h> | ||
61 | + main() | ||
62 | + { | ||
63 | + FILE *f=fopen("conftestval", "w"); | ||
64 | + if (!f) exit(1); | ||
65 | + fprintf(f, "%d\n", sizeof(dev_t)); | ||
66 | + exit(0); | ||
67 | + }], ac_cv_sizeof_dev_t=`cat conftestval`, ac_cv_sizeof_dev_t=0)]) | ||
68 | + AC_MSG_RESULT($ac_cv_sizeof_dev_t) | ||
69 | + AC_DEFINE(SIZEOF_DEV_T,$ac_cv_sizeof_dev_t) | ||
70 | + ]) | ||
71 | +dnl *********** sizeof(xxx_t) ************** | ||
72 | +dnl ** Overwrite the AC_CHECK_SIZEOF macro as we must include sys/types.h | ||
73 | +define([AC_CHECK_SIZEOF], | ||
74 | + [changequote(<<, >>)dnl | ||
75 | + define(<<AC_TYPE_NAME>>,translit(sizeof_$1, [a-z *], [A-Z_P]))dnl | ||
76 | + define(<<AC_CV_NAME>>, translit(ac_cv_sizeof_$1, [ *], [_p]))dnl | ||
77 | + changequote([, ])dnl | ||
78 | + AC_MSG_CHECKING(size of $1) | ||
79 | + AC_CACHE_VAL(AC_CV_NAME, | ||
80 | + [AC_TRY_RUN( | ||
81 | + [#include <stdio.h> | ||
82 | + #include <sys/types.h> | ||
83 | + main() | ||
84 | + { | ||
85 | + FILE *f=fopen("conftestval", "w"); | ||
86 | + if (!f) exit(1); | ||
87 | + fprintf(f, "%d\n", sizeof($1)); | ||
88 | + exit(0); | ||
89 | + }], AC_CV_NAME=`cat conftestval`, AC_CV_NAME=0)]) | ||
90 | + AC_MSG_RESULT($AC_CV_NAME) | ||
91 | + AC_DEFINE_UNQUOTED(AC_TYPE_NAME,$AC_CV_NAME) | ||
92 | + undefine([AC_TYPE_NAME])dnl | ||
93 | + undefine([AC_CV_NAME])dnl | ||
94 | + ]) | ||
95 | +dnl *********** BSD vs. POSIX signal handling ************** | ||
96 | +define([AC_BSD_SIGNALS], | ||
97 | + [AC_MSG_CHECKING(for BSD signal semantics) | ||
98 | + AC_CACHE_VAL(knfsd_cv_bsd_signals, | ||
99 | + [AC_TRY_RUN([ | ||
100 | + #include <signal.h> | ||
101 | + #include <unistd.h> | ||
102 | + #include <sys/wait.h> | ||
103 | + | ||
104 | + static int counter = 0; | ||
105 | + static RETSIGTYPE handler(int num) { counter++; } | ||
106 | + | ||
107 | + int main() | ||
108 | + { | ||
109 | + int s; | ||
110 | + if ((s = fork()) < 0) return 1; | ||
111 | + if (s != 0) { | ||
112 | + if (wait(&s) < 0) return 1; | ||
113 | + return WIFSIGNALED(s)? 1 : 0; | ||
114 | + } | ||
115 | + | ||
116 | + signal(SIGHUP, handler); | ||
117 | + kill(getpid(), SIGHUP); kill(getpid(), SIGHUP); | ||
118 | + return (counter == 2)? 0 : 1; | ||
119 | + } | ||
120 | + ], knfsd_cv_bsd_signals=yes, knfsd_cv_bsd_signals=no)]) dnl | ||
121 | + AC_MSG_RESULT($knfsd_cv_bsd_signals) | ||
122 | + test $knfsd_cv_bsd_signals = yes && AC_DEFINE(HAVE_BSD_SIGNALS) | ||
123 | +])dnl | ||
124 | +dnl *********** the tcp wrapper library *************** | ||
125 | +define(AC_TCP_WRAPPER, | ||
126 | + [AC_MSG_CHECKING(for the tcp wrapper library) | ||
127 | + AC_CACHE_VAL(knfsd_cv_tcp_wrapper, | ||
128 | + [old_LIBS="$LIBS" | ||
129 | + LIBS="$LIBS -lwrap $LIBNSL" | ||
130 | + AC_TRY_LINK([ | ||
131 | + int deny_severity = 0; | ||
132 | + int allow_severity = 0;], | ||
133 | + [return hosts_ctl ("nfsd", "", "")], | ||
134 | + knfsd_cv_tcp_wrapper=yes, knfsd_cv_tcp_wrapper=no) | ||
135 | + LIBS="$old_LIBS"]) | ||
136 | + AC_MSG_RESULT($knfsd_cv_tcp_wrapper) | ||
137 | + if test "$knfsd_cv_tcp_wrapper" = yes; then | ||
138 | + CFLAGS="$CFLAGS -DHAVE_TCP_WRAPPER" | ||
139 | + CXXFLAGS="$CXXFLAGS -DHAVE_TCP_WRAPPER" | ||
140 | + LIBWRAP="-lwrap" | ||
141 | + fi | ||
142 | +]) dnl | ||
diff --git a/meta/packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines b/meta/packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines deleted file mode 100644 index a18333100d..0000000000 --- a/meta/packages/nfs-utils/nfs-utils-1.0.6/forgotten-defines +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | |||
2 | /* This defines the location of the NFS state files | ||
3 | * Warning: these must match definitions in config.mk! | ||
4 | */ | ||
5 | #define NFS_STATEDIR "/var/lib/nfs" | ||
diff --git a/meta/packages/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch b/meta/packages/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch deleted file mode 100644 index 219bed094b..0000000000 --- a/meta/packages/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | --- nfs-utils-1.0.6/tools/getkversion/getkversion.c.orig 2007-02-22 12:33:54.000000000 +0000 | ||
2 | +++ nfs-utils-1.0.6/tools/getkversion/getkversion.c 2007-02-22 12:33:56.000000000 +0000 | ||
3 | @@ -12,6 +12,10 @@ | ||
4 | int | ||
5 | main(void) /* This is for Dan Popp ;) */ | ||
6 | { | ||
7 | + | ||
8 | +#ifdef UTS_RELEASE | ||
9 | printf("%s\n", UTS_RELEASE); | ||
10 | +#endif | ||
11 | + | ||
12 | return 0; | ||
13 | } | ||
diff --git a/meta/packages/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch b/meta/packages/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch deleted file mode 100644 index d1e1fb700d..0000000000 --- a/meta/packages/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | --- nfs-utils-1.0.6/config.mk.in.old 2004-11-07 12:30:05.000000000 +0000 | ||
2 | +++ nfs-utils-1.0.6/config.mk.in 2004-11-07 12:30:19.000000000 +0000 | ||
3 | @@ -52,7 +52,7 @@ | ||
4 | LN_S = ln -sf | ||
5 | RANLIB = @RANLIB@ | ||
6 | INDENT = indent | ||
7 | -RPCGEN = $(TOP)bin/rpcgen | ||
8 | +RPCGEN = rpcgen | ||
9 | GETKVER = $(TOP)tools/getkversion | ||
10 | INSTALL = install | ||
11 | MAN2PS = groff -Tps -man | ||
diff --git a/meta/packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch b/meta/packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch deleted file mode 100644 index d0ae022461..0000000000 --- a/meta/packages/nfs-utils/nfs-utils-1.0.6/stat-include.patch +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | --- nfs-utils-1.0.6/utils/statd/statd.c~ 2003-09-11 20:24:29.000000000 -1000 | ||
2 | +++ nfs-utils-1.0.6/utils/statd/statd.c 2005-03-27 03:11:03.025582700 -1000 | ||
3 | @@ -19,6 +19,7 @@ | ||
4 | #include <rpc/pmap_clnt.h> | ||
5 | #include <rpcmisc.h> | ||
6 | #include <sys/resource.h> | ||
7 | +#include <sys/stat.h> | ||
8 | #include <grp.h> | ||
9 | #include "statd.h" | ||
10 | #include "version.h" | ||
11 | |||
diff --git a/meta/packages/nfs-utils/files/nfs-utils-1.0.6-uclibc.patch b/meta/packages/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch index ebd3276be2..336dc0e267 100644 --- a/meta/packages/nfs-utils/files/nfs-utils-1.0.6-uclibc.patch +++ b/meta/packages/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | --- ./support/nfs/svc_socket.c.orig 2004-12-12 06:43:52.000000000 +0000 | 1 | --- ./support/nfs/svc_socket.c.orig 2004-12-12 06:43:52.000000000 +0000 |
2 | +++ ./support/nfs/svc_socket.c 2004-12-12 06:50:04.000000000 +0000 | 2 | +++ ./support/nfs/svc_socket.c 2004-12-12 06:50:04.000000000 +0000 |
3 | @@ -66,6 +66,7 @@ | 3 | @@ -66,6 +66,7 @@ |
4 | __bzero ((char *) &addr, sizeof (addr)); | 4 | memset ((char *) &addr, sizeof (addr)); |
5 | addr.sin_family = AF_INET; | 5 | addr.sin_family = AF_INET; |
6 | 6 | ||
7 | +#ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */ | 7 | +#ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */ |
diff --git a/meta/packages/nfs-utils/files/nfsserver b/meta/packages/nfs-utils/nfs-utils/nfsserver index 9d02e85848..9d02e85848 100644 --- a/meta/packages/nfs-utils/files/nfsserver +++ b/meta/packages/nfs-utils/nfs-utils/nfsserver | |||
diff --git a/meta/packages/nfs-utils/nfs-utils_1.0.6.bb b/meta/packages/nfs-utils/nfs-utils_1.0.6.bb deleted file mode 100644 index 1ffb96a468..0000000000 --- a/meta/packages/nfs-utils/nfs-utils_1.0.6.bb +++ /dev/null | |||
@@ -1,78 +0,0 @@ | |||
1 | DESCRIPTION = "userspace utilities for kernel nfs" | ||
2 | HOMEPAGE = "http://nfs.sourceforge.net/" | ||
3 | SECTION = "console/network" | ||
4 | PRIORITY = "optional" | ||
5 | LICENSE = "GPLv2+" | ||
6 | PR = "r14" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \ | ||
9 | file://acinclude-lossage.patch;patch=1 \ | ||
10 | file://rpcgen-lossage.patch;patch=1 \ | ||
11 | file://stat-include.patch;patch=1 \ | ||
12 | file://nfs-utils-1.0.6-uclibc.patch;patch=1 \ | ||
13 | file://kernel-2.6.18+.patch;patch=1 \ | ||
14 | file://uclibc_bzero_fix.patch;patch=1 \ | ||
15 | file://nfsserver \ | ||
16 | file://forgotten-defines" | ||
17 | |||
18 | S = "${WORKDIR}/nfs-utils-${PV}/" | ||
19 | |||
20 | PARALLEL_MAKE = "" | ||
21 | |||
22 | # Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will | ||
23 | # pull in the remainder of the dependencies. | ||
24 | RDEPENDS = "portmap" | ||
25 | RRECOMMENDS = "kernel-module-nfsd" | ||
26 | |||
27 | INITSCRIPT_NAME = "nfsserver" | ||
28 | # The server has no dependencies at the user run levels, so just put | ||
29 | # it in at the default levels. It must be terminated before the network | ||
30 | # in the shutdown levels, but that works fine. | ||
31 | INITSCRIPT_PARAMS = "defaults" | ||
32 | |||
33 | inherit autotools update-rc.d | ||
34 | |||
35 | EXTRA_OECONF = "--with-statduser=nobody \ | ||
36 | --enable-nfsv3 \ | ||
37 | --with-statedir=/var/lib/nfs" | ||
38 | |||
39 | do_compile() { | ||
40 | # UGLY HACK ALERT | ||
41 | cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h | ||
42 | oe_runmake 'BUILD=1' | ||
43 | } | ||
44 | |||
45 | INHIBIT_AUTO_STAGE = "1" | ||
46 | |||
47 | do_install() { | ||
48 | install -d ${D}${sysconfdir}/init.d | ||
49 | install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver | ||
50 | |||
51 | install -d ${D}${sbindir} | ||
52 | install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs | ||
53 | install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd | ||
54 | install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd | ||
55 | install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd | ||
56 | install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat | ||
57 | install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph | ||
58 | install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums | ||
59 | install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun | ||
60 | install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone | ||
61 | install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad | ||
62 | install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount | ||
63 | install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd | ||
64 | |||
65 | install -d ${D}${mandir}/man8 | ||
66 | install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8 | ||
67 | install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8 | ||
68 | install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8 | ||
69 | install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8 | ||
70 | install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8 | ||
71 | install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8 | ||
72 | install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8 | ||
73 | install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8 | ||
74 | install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8 | ||
75 | install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8 | ||
76 | install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8 | ||
77 | install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8 | ||
78 | } | ||
diff --git a/meta/packages/nfs-utils/nfs-utils_1.2.2.bb b/meta/packages/nfs-utils/nfs-utils_1.2.2.bb new file mode 100644 index 0000000000..cbcddd8c74 --- /dev/null +++ b/meta/packages/nfs-utils/nfs-utils_1.2.2.bb | |||
@@ -0,0 +1,54 @@ | |||
1 | DESCRIPTION = "userspace utilities for kernel nfs" | ||
2 | HOMEPAGE = "http://nfs.sourceforge.net/" | ||
3 | SECTION = "console/network" | ||
4 | PRIORITY = "optional" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" | ||
8 | |||
9 | # util-linux for libblkid | ||
10 | DEPENDS = "libcap libnfsidmap libevent util-linux" | ||
11 | RDEPENDS = "portmap" | ||
12 | RRECOMMENDS = "kernel-module-nfsd" | ||
13 | |||
14 | PR = "r0" | ||
15 | |||
16 | SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.bz2 \ | ||
17 | file://nfs-utils-1.0.6-uclibc.patch \ | ||
18 | file://nfsserver" | ||
19 | |||
20 | S = "${WORKDIR}/nfs-utils-${PV}/" | ||
21 | |||
22 | PARALLEL_MAKE = "" | ||
23 | |||
24 | # Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will | ||
25 | # pull in the remainder of the dependencies. | ||
26 | |||
27 | INITSCRIPT_NAME = "nfsserver" | ||
28 | # The server has no dependencies at the user run levels, so just put | ||
29 | # it in at the default levels. It must be terminated before the network | ||
30 | # in the shutdown levels, but that works fine. | ||
31 | INITSCRIPT_PARAMS = "defaults" | ||
32 | |||
33 | inherit autotools update-rc.d | ||
34 | |||
35 | # --enable-uuid is need for cross-compiling | ||
36 | EXTRA_OECONF = "--with-statduser=nobody \ | ||
37 | --enable-nfsv41 \ | ||
38 | --enable-uuid \ | ||
39 | --disable-gss \ | ||
40 | --disable-tirpc \ | ||
41 | --without-tcp-wrappers \ | ||
42 | --with-statedir=/var/lib/nfs" | ||
43 | |||
44 | INHIBIT_AUTO_STAGE = "1" | ||
45 | |||
46 | do_install_append () { | ||
47 | install -d ${D}${sysconfdir}/init.d | ||
48 | install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver | ||
49 | |||
50 | # the following are built by CC_FOR_BUILD | ||
51 | rm -f ${D}${sbindir}/rpcdebug | ||
52 | rm -f ${D}${sbindir}/rpcgen | ||
53 | rm -f ${D}${sbindir}/locktest | ||
54 | } | ||