summaryrefslogtreecommitdiffstats
path: root/meta/packages/nfs-utils/nfs-utils_1.2.2.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-07 13:55:23 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 21:14:00 -0700
commit3451dc818787031b8dfd69db4baf213a4a085024 (patch)
tree957aeb63a77b9d8c1022cc5d3cbb34d1021fdd40 /meta/packages/nfs-utils/nfs-utils_1.2.2.bb
parent5bd2ba7e23cc90e1e4e99a19f19281f6449edc1e (diff)
downloadpoky-3451dc818787031b8dfd69db4baf213a4a085024.tar.gz
nfs-utils: upgrade to version 1.2.2
from 1.0.6 changes: - there are several new dependencies: tirpc, libcap libgss, libnfsimap, libevent and libwrap. disable tirpc, libgss, libwrap - several changes are in upstream now, include the bzero change and stat-include change, remove the patches - a new build system is used, custom macros are now moved to aclocal/, acinclude and rpcgen fixes are not necessary any more - rebase uclibc patch - enable nfsv41, nfsv3 and nfsv4 are default turned on - do_compile is no longer needed - the install target has changed a lot, instead of updating the file list manually, try to use oe_runmake install for installation. Several files are built against build environment, they are removed from the packages. Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/nfs-utils/nfs-utils_1.2.2.bb')
-rw-r--r--meta/packages/nfs-utils/nfs-utils_1.2.2.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/packages/nfs-utils/nfs-utils_1.2.2.bb b/meta/packages/nfs-utils/nfs-utils_1.2.2.bb
new file mode 100644
index 0000000000..cbcddd8c74
--- /dev/null
+++ b/meta/packages/nfs-utils/nfs-utils_1.2.2.bb
@@ -0,0 +1,54 @@
1DESCRIPTION = "userspace utilities for kernel nfs"
2HOMEPAGE = "http://nfs.sourceforge.net/"
3SECTION = "console/network"
4PRIORITY = "optional"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9# util-linux for libblkid
10DEPENDS = "libcap libnfsidmap libevent util-linux"
11RDEPENDS = "portmap"
12RRECOMMENDS = "kernel-module-nfsd"
13
14PR = "r0"
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.bz2 \
17 file://nfs-utils-1.0.6-uclibc.patch \
18 file://nfsserver"
19
20S = "${WORKDIR}/nfs-utils-${PV}/"
21
22PARALLEL_MAKE = ""
23
24# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
25# pull in the remainder of the dependencies.
26
27INITSCRIPT_NAME = "nfsserver"
28# The server has no dependencies at the user run levels, so just put
29# it in at the default levels. It must be terminated before the network
30# in the shutdown levels, but that works fine.
31INITSCRIPT_PARAMS = "defaults"
32
33inherit autotools update-rc.d
34
35# --enable-uuid is need for cross-compiling
36EXTRA_OECONF = "--with-statduser=nobody \
37 --enable-nfsv41 \
38 --enable-uuid \
39 --disable-gss \
40 --disable-tirpc \
41 --without-tcp-wrappers \
42 --with-statedir=/var/lib/nfs"
43
44INHIBIT_AUTO_STAGE = "1"
45
46do_install_append () {
47 install -d ${D}${sysconfdir}/init.d
48 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
49
50 # the following are built by CC_FOR_BUILD
51 rm -f ${D}${sbindir}/rpcdebug
52 rm -f ${D}${sbindir}/rpcgen
53 rm -f ${D}${sbindir}/locktest
54}