summaryrefslogtreecommitdiffstats
path: root/meta/packages/nfs-utils/nfs-utils_1.0.6.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-07 13:55:23 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 21:14:00 -0700
commit3451dc818787031b8dfd69db4baf213a4a085024 (patch)
tree957aeb63a77b9d8c1022cc5d3cbb34d1021fdd40 /meta/packages/nfs-utils/nfs-utils_1.0.6.bb
parent5bd2ba7e23cc90e1e4e99a19f19281f6449edc1e (diff)
downloadpoky-3451dc818787031b8dfd69db4baf213a4a085024.tar.gz
nfs-utils: upgrade to version 1.2.2
from 1.0.6 changes: - there are several new dependencies: tirpc, libcap libgss, libnfsimap, libevent and libwrap. disable tirpc, libgss, libwrap - several changes are in upstream now, include the bzero change and stat-include change, remove the patches - a new build system is used, custom macros are now moved to aclocal/, acinclude and rpcgen fixes are not necessary any more - rebase uclibc patch - enable nfsv41, nfsv3 and nfsv4 are default turned on - do_compile is no longer needed - the install target has changed a lot, instead of updating the file list manually, try to use oe_runmake install for installation. Several files are built against build environment, they are removed from the packages. Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/nfs-utils/nfs-utils_1.0.6.bb')
-rw-r--r--meta/packages/nfs-utils/nfs-utils_1.0.6.bb78
1 files changed, 0 insertions, 78 deletions
diff --git a/meta/packages/nfs-utils/nfs-utils_1.0.6.bb b/meta/packages/nfs-utils/nfs-utils_1.0.6.bb
deleted file mode 100644
index 1ffb96a468..0000000000
--- a/meta/packages/nfs-utils/nfs-utils_1.0.6.bb
+++ /dev/null
@@ -1,78 +0,0 @@
1DESCRIPTION = "userspace utilities for kernel nfs"
2HOMEPAGE = "http://nfs.sourceforge.net/"
3SECTION = "console/network"
4PRIORITY = "optional"
5LICENSE = "GPLv2+"
6PR = "r14"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
9 file://acinclude-lossage.patch;patch=1 \
10 file://rpcgen-lossage.patch;patch=1 \
11 file://stat-include.patch;patch=1 \
12 file://nfs-utils-1.0.6-uclibc.patch;patch=1 \
13 file://kernel-2.6.18+.patch;patch=1 \
14 file://uclibc_bzero_fix.patch;patch=1 \
15 file://nfsserver \
16 file://forgotten-defines"
17
18S = "${WORKDIR}/nfs-utils-${PV}/"
19
20PARALLEL_MAKE = ""
21
22# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
23# pull in the remainder of the dependencies.
24RDEPENDS = "portmap"
25RRECOMMENDS = "kernel-module-nfsd"
26
27INITSCRIPT_NAME = "nfsserver"
28# The server has no dependencies at the user run levels, so just put
29# it in at the default levels. It must be terminated before the network
30# in the shutdown levels, but that works fine.
31INITSCRIPT_PARAMS = "defaults"
32
33inherit autotools update-rc.d
34
35EXTRA_OECONF = "--with-statduser=nobody \
36 --enable-nfsv3 \
37 --with-statedir=/var/lib/nfs"
38
39do_compile() {
40 # UGLY HACK ALERT
41 cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
42 oe_runmake 'BUILD=1'
43}
44
45INHIBIT_AUTO_STAGE = "1"
46
47do_install() {
48 install -d ${D}${sysconfdir}/init.d
49 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
50
51 install -d ${D}${sbindir}
52 install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
53 install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd
54 install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
55 install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
56 install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
57 install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph
58 install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums
59 install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun
60 install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone
61 install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad
62 install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
63 install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
64
65 install -d ${D}${mandir}/man8
66 install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
67 install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8
68 install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
69 install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
70 install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
71 install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8
72 install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8
73 install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8
74 install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8
75 install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8
76 install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
77 install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
78}