summaryrefslogtreecommitdiffstats
path: root/meta/packages/netbase
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-03-28 09:46:31 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-03-28 09:46:31 +0000
commitbfb887efc05bdea0fc33a0cbe6d0b69404e0ff5d (patch)
tree1efe42138b4dd8b54dea13edf36a06c3daa4fddf /meta/packages/netbase
parent4454dbbe9531678ff5f545be79a3aba1aa8a5cd7 (diff)
downloadpoky-bfb887efc05bdea0fc33a0cbe6d0b69404e0ff5d.tar.gz
netbase: configure eth0 as static/auto to have them working without running ifconfig
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1396 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/netbase')
-rw-r--r--meta/packages/netbase/netbase/qemuarm/interfaces49
-rw-r--r--meta/packages/netbase/netbase/qemux86/interfaces49
-rw-r--r--meta/packages/netbase/netbase_4.21.bb2
3 files changed, 99 insertions, 1 deletions
diff --git a/meta/packages/netbase/netbase/qemuarm/interfaces b/meta/packages/netbase/netbase/qemuarm/interfaces
new file mode 100644
index 0000000000..9259c1d8f5
--- /dev/null
+++ b/meta/packages/netbase/netbase/qemuarm/interfaces
@@ -0,0 +1,49 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9wireless_mode managed
10wireless_essid any
11iface atml0 inet dhcp
12
13# Wired or wireless interfaces
14auto eth0
15iface eth0 inet static
16 address 192.168.7.2
17 netmask 255.255.255.0
18 network 192.168.7.0
19 gateway 192.168.7.1
20
21iface eth1 inet dhcp
22
23# Ethernet/RNDIS gadget (g_ether)
24# ... or on host side, usbnet and random hwaddr
25iface usb0 inet static
26 address 192.168.0.202
27 netmask 255.255.255.0
28 network 192.168.0.0
29 gateway 192.168.0.200
30
31
32# Zaurus 2.4 Lineo net_fd; obsolete
33iface usbd0 inet static
34 address 192.168.129.201
35 netmask 255.255.255.0
36 network 192.168.129.0
37 gateway 192.168.129.200
38
39# iPAQ 2.4 mach-sa1100/usb-eth
40# (192.168.0.202 is the iPAQ's IP, 192.168.0.200 is the host's IP)
41iface usbf inet static
42 address 192.168.0.202
43 netmask 255.255.255.0
44 network 192.168.0.0
45 gateway 192.168.0.200
46
47# Bluetooth networking
48iface bnep0 inet dhcp
49
diff --git a/meta/packages/netbase/netbase/qemux86/interfaces b/meta/packages/netbase/netbase/qemux86/interfaces
new file mode 100644
index 0000000000..9259c1d8f5
--- /dev/null
+++ b/meta/packages/netbase/netbase/qemux86/interfaces
@@ -0,0 +1,49 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9wireless_mode managed
10wireless_essid any
11iface atml0 inet dhcp
12
13# Wired or wireless interfaces
14auto eth0
15iface eth0 inet static
16 address 192.168.7.2
17 netmask 255.255.255.0
18 network 192.168.7.0
19 gateway 192.168.7.1
20
21iface eth1 inet dhcp
22
23# Ethernet/RNDIS gadget (g_ether)
24# ... or on host side, usbnet and random hwaddr
25iface usb0 inet static
26 address 192.168.0.202
27 netmask 255.255.255.0
28 network 192.168.0.0
29 gateway 192.168.0.200
30
31
32# Zaurus 2.4 Lineo net_fd; obsolete
33iface usbd0 inet static
34 address 192.168.129.201
35 netmask 255.255.255.0
36 network 192.168.129.0
37 gateway 192.168.129.200
38
39# iPAQ 2.4 mach-sa1100/usb-eth
40# (192.168.0.202 is the iPAQ's IP, 192.168.0.200 is the host's IP)
41iface usbf inet static
42 address 192.168.0.202
43 netmask 255.255.255.0
44 network 192.168.0.0
45 gateway 192.168.0.200
46
47# Bluetooth networking
48iface bnep0 inet dhcp
49
diff --git a/meta/packages/netbase/netbase_4.21.bb b/meta/packages/netbase/netbase_4.21.bb
index 8c0652daec..4590cf7649 100644
--- a/meta/packages/netbase/netbase_4.21.bb
+++ b/meta/packages/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
2infrastructure for basic TCP/IP based networking." 2infrastructure for basic TCP/IP based networking."
3SECTION = "base" 3SECTION = "base"
4LICENSE = "GPL" 4LICENSE = "GPL"
5PR = "r12" 5PR = "r13"
6 6
7inherit update-rc.d 7inherit update-rc.d
8 8