diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-04-22 17:36:22 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-04-22 17:36:22 +0100 |
commit | b2a619b79eff718317bec201a37ea5f6f92f6d46 (patch) | |
tree | a7c4474408497bec110c5faa9cf9bb1887323fd7 /meta/packages/mutter | |
parent | ef5600cf10bc3d2cd2748deb5b532524ad1fa2e1 (diff) | |
download | poky-b2a619b79eff718317bec201a37ea5f6f92f6d46.tar.gz |
metacity-clutter: Rename to mutter and point at the new upstream
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mutter')
-rw-r--r-- | meta/packages/mutter/mutter/crosscompile.patch | 55 | ||||
-rw-r--r-- | meta/packages/mutter/mutter/fix_pkgconfig.patch | 10 | ||||
-rw-r--r-- | meta/packages/mutter/mutter/nodocs.patch | 29 | ||||
-rw-r--r-- | meta/packages/mutter/mutter_git.bb | 51 |
4 files changed, 145 insertions, 0 deletions
diff --git a/meta/packages/mutter/mutter/crosscompile.patch b/meta/packages/mutter/mutter/crosscompile.patch new file mode 100644 index 0000000000..b27383b09a --- /dev/null +++ b/meta/packages/mutter/mutter/crosscompile.patch | |||
@@ -0,0 +1,55 @@ | |||
1 | Index: git/configure.in | ||
2 | =================================================================== | ||
3 | --- git.orig/configure.in 2009-01-27 14:49:10.000000000 +0000 | ||
4 | +++ git/configure.in 2009-01-27 15:29:41.000000000 +0000 | ||
5 | @@ -46,6 +46,32 @@ | ||
6 | AC_LIBTOOL_WIN32_DLL | ||
7 | AM_PROG_LIBTOOL | ||
8 | |||
9 | +if test x"$CC_FOR_BUILD" = x; then | ||
10 | + if test x"$cross_compiling" = xyes; then | ||
11 | + AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc) | ||
12 | + else | ||
13 | + CC_FOR_BUILD="$CC" | ||
14 | + fi | ||
15 | +fi | ||
16 | +AC_SUBST([CC_FOR_BUILD]) | ||
17 | +if test x"$CFLAGS_FOR_BUILD" = x; then | ||
18 | + if test x"$cross_compiling" = xyes; then | ||
19 | + AC_CHECK_PROGS(CFLAGS_FOR_BUILD, gcc cc) | ||
20 | + else | ||
21 | + CFLAGS_FOR_BUILD="$CFLAGS" | ||
22 | + fi | ||
23 | +fi | ||
24 | +AC_SUBST([CFLAGS_FOR_BUILD]) | ||
25 | +if test x"$LDFLAGS_FOR_BUILD" = x; then | ||
26 | + if test x"$cross_compiling" = xyes; then | ||
27 | + AC_CHECK_PROGS(LDFLAGS_FOR_BUILD, gcc cc) | ||
28 | + else | ||
29 | + LDFLAGS_FOR_BUILD="$LDFLAGS" | ||
30 | + fi | ||
31 | +fi | ||
32 | +AC_SUBST([LDFLAGS_FOR_BUILD]) | ||
33 | + | ||
34 | + | ||
35 | #### Integer sizes | ||
36 | |||
37 | AC_CHECK_SIZEOF(char) | ||
38 | Index: git/src/Makefile.am | ||
39 | =================================================================== | ||
40 | --- git.orig/src/Makefile.am 2009-01-27 15:25:31.000000000 +0000 | ||
41 | +++ git/src/Makefile.am 2009-01-27 15:39:54.000000000 +0000 | ||
42 | @@ -168,11 +168,9 @@ | ||
43 | metacity_dialog_SOURCES= \ | ||
44 | ui/metacity-dialog.c | ||
45 | |||
46 | -schema_bindings_SOURCES = \ | ||
47 | - core/schema-bindings.c \ | ||
48 | - metacity.schemas.in.in | ||
49 | +schema_bindings: | ||
50 | + @CC_FOR_BUILD@ core/schema-bindings.c -I./include -I ../ @CFLAGS_FOR_BUILD@ @LDFLAGS_FOR_BUILD@ -o schema_bindings | ||
51 | |||
52 | -schema_bindings_LDADD = @METACITY_LIBS@ | ||
53 | metacity.schemas.in: schema_bindings ${srcdir}/metacity.schemas.in.in | ||
54 | @echo Generating keybinding schemas... ${srcdir}/metacity.schemas.in.in | ||
55 | ${builddir}/schema_bindings ${srcdir}/metacity.schemas.in.in ${builddir}/metacity.schemas.in | ||
diff --git a/meta/packages/mutter/mutter/fix_pkgconfig.patch b/meta/packages/mutter/mutter/fix_pkgconfig.patch new file mode 100644 index 0000000000..3714383bc1 --- /dev/null +++ b/meta/packages/mutter/mutter/fix_pkgconfig.patch | |||
@@ -0,0 +1,10 @@ | |||
1 | Index: git/src/metacity-plugins.pc.in | ||
2 | =================================================================== | ||
3 | --- git.orig/src/metacity-plugins.pc.in 2008-12-17 22:42:19.000000000 +0000 | ||
4 | +++ git/src/metacity-plugins.pc.in 2008-12-17 22:42:25.000000000 +0000 | ||
5 | @@ -14,4 +14,4 @@ | ||
6 | Requires: @CLUTTER_PACKAGE@ | ||
7 | Version: @VERSION@ | ||
8 | Libs: @CLUTTER_LIBS@ | ||
9 | -Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\" | ||
10 | +Cflags: -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\" | ||
diff --git a/meta/packages/mutter/mutter/nodocs.patch b/meta/packages/mutter/mutter/nodocs.patch new file mode 100644 index 0000000000..98f43be5e8 --- /dev/null +++ b/meta/packages/mutter/mutter/nodocs.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | Index: git/Makefile.am | ||
2 | =================================================================== | ||
3 | --- git.orig/Makefile.am 2009-01-27 13:26:12.000000000 +0000 | ||
4 | +++ git/Makefile.am 2009-01-27 14:07:13.000000000 +0000 | ||
5 | @@ -1,5 +1,5 @@ | ||
6 | |||
7 | -SUBDIRS=src po doc | ||
8 | +SUBDIRS=src po | ||
9 | |||
10 | EXTRA_DIST = HACKING MAINTAINERS rationales.txt \ | ||
11 | intltool-extract.in intltool-merge.in intltool-update.in | ||
12 | Index: git/configure.in | ||
13 | =================================================================== | ||
14 | --- git.orig/configure.in 2009-01-27 13:26:12.000000000 +0000 | ||
15 | +++ git/configure.in 2009-01-27 14:11:16.000000000 +0000 | ||
16 | @@ -538,12 +538,9 @@ | ||
17 | |||
18 | # Warnings are there for a reason | ||
19 | if test "x$GCC" = "xyes"; then | ||
20 | - CFLAGS="$CFLAGS -Wall -Werror -ansi" | ||
21 | + CFLAGS="$CFLAGS -Wall -ansi" | ||
22 | fi | ||
23 | |||
24 | -# Use gnome-doc-utils: | ||
25 | -GNOME_DOC_INIT([0.8.0]) | ||
26 | - | ||
27 | AC_CONFIG_FILES([ | ||
28 | Makefile | ||
29 | doc/Makefile | ||
diff --git a/meta/packages/mutter/mutter_git.bb b/meta/packages/mutter/mutter_git.bb new file mode 100644 index 0000000000..7d3a3b8c4f --- /dev/null +++ b/meta/packages/mutter/mutter_git.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | SECTION = "x11/wm" | ||
2 | DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutter is metacity + clutter." | ||
3 | LICENSE = "GPL" | ||
4 | DEPENDS = "startup-notification gtk+ gconf clutter gdk-pixbuf-csource-native intltool glib-2.0-native" | ||
5 | PR = "r8" | ||
6 | PV = "2.25.1+git${SRCREV}" | ||
7 | inherit gnome update-alternatives | ||
8 | |||
9 | SRC_URI = "git://git.gnome.org/mutter.git;protocol=git;branch=master \ | ||
10 | file://nodocs.patch;patch=1 \ | ||
11 | file://crosscompile.patch;patch=1 \ | ||
12 | file://fix_pkgconfig.patch;patch=1" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | ALTERNATIVE_NAME = "x-window-manager" | ||
16 | ALTERNATIVE_LINK = "${bindir}/x-window-manager" | ||
17 | ALTERNATIVE_PATH = "${bindir}/metacity" | ||
18 | ALTERNATIVE_PRIORITY = "11" | ||
19 | |||
20 | EXTRA_OECONF += "--disable-verbose \ | ||
21 | --disable-xinerama \ | ||
22 | --with-clutter" | ||
23 | |||
24 | FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so" | ||
25 | FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*" | ||
26 | |||
27 | export CC_FOR_BUILD = "${BUILD_CC}" | ||
28 | export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include" | ||
29 | export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0" | ||
30 | |||
31 | do_configure_prepend () { | ||
32 | echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make | ||
33 | } | ||
34 | |||
35 | do_stage () { | ||
36 | autotools_stage_all | ||
37 | } | ||
38 | |||
39 | pkg_postinst_${PN} () { | ||
40 | #!/bin/sh -e | ||
41 | if [ "x$D" != "x" ]; then | ||
42 | exit 1 | ||
43 | fi | ||
44 | |||
45 | . ${sysconfdir}/init.d/functions | ||
46 | |||
47 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[default]' | ||
48 | |||
49 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/metacity/general/compositing_manager true | ||
50 | } | ||
51 | |||