diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-01-13 15:46:30 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-01-13 15:46:30 +0000 |
commit | 9a66ae02cb848d0576a91cf0e1bedc3bef4862f7 (patch) | |
tree | 728ff3d65c1e1150970fdc8c179a4e50fea1c756 /meta/packages/mutter | |
parent | 813e135deec6dd4c7f3ef54072877233bee991dd (diff) | |
download | poky-9a66ae02cb848d0576a91cf0e1bedc3bef4862f7.tar.gz |
mutter: Add 2.28.1 release
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mutter')
-rw-r--r-- | meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch | 10 | ||||
-rw-r--r-- | meta/packages/mutter/mutter.inc | 47 | ||||
-rw-r--r-- | meta/packages/mutter/mutter_2.28.1.bb | 9 | ||||
-rw-r--r-- | meta/packages/mutter/mutter_git.bb | 50 |
4 files changed, 59 insertions, 57 deletions
diff --git a/meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch b/meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch deleted file mode 100644 index 3714383bc1..0000000000 --- a/meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | Index: git/src/metacity-plugins.pc.in | ||
2 | =================================================================== | ||
3 | --- git.orig/src/metacity-plugins.pc.in 2008-12-17 22:42:19.000000000 +0000 | ||
4 | +++ git/src/metacity-plugins.pc.in 2008-12-17 22:42:25.000000000 +0000 | ||
5 | @@ -14,4 +14,4 @@ | ||
6 | Requires: @CLUTTER_PACKAGE@ | ||
7 | Version: @VERSION@ | ||
8 | Libs: @CLUTTER_LIBS@ | ||
9 | -Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\" | ||
10 | +Cflags: -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\" | ||
diff --git a/meta/packages/mutter/mutter.inc b/meta/packages/mutter/mutter.inc new file mode 100644 index 0000000000..860d9906d5 --- /dev/null +++ b/meta/packages/mutter/mutter.inc | |||
@@ -0,0 +1,47 @@ | |||
1 | SECTION = "x11/wm" | ||
2 | DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutter is metacity + clutter." | ||
3 | LICENSE = "GPLv2" | ||
4 | DEPENDS = "startup-notification gtk+ gconf clutter-1.0 gdk-pixbuf-csource-native intltool glib-2.0-native" | ||
5 | # gobject-introspection | ||
6 | inherit gnome update-alternatives | ||
7 | |||
8 | ALTERNATIVE_NAME = "x-window-manager" | ||
9 | ALTERNATIVE_LINK = "${bindir}/x-window-manager" | ||
10 | ALTERNATIVE_PATH = "${bindir}/mutter" | ||
11 | ALTERNATIVE_PRIORITY = "11" | ||
12 | |||
13 | EXTRA_OECONF += "--disable-verbose \ | ||
14 | --disable-xinerama \ | ||
15 | --without-introspection \ | ||
16 | --with-clutter" | ||
17 | |||
18 | #RDEPENDS_${PN} = "zenity" | ||
19 | |||
20 | FILES_${PN} += "${datadir}/themes ${libdir}/mutter/plugins/*.so ${datadir}/gnome/wm-properties/" | ||
21 | FILES_${PN}-dbg += "${libdir}/mutter/plugins/.debug/*" | ||
22 | |||
23 | export CC_FOR_BUILD = "${BUILD_CC}" | ||
24 | export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include" | ||
25 | export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0" | ||
26 | |||
27 | do_configure_prepend () { | ||
28 | echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make | ||
29 | } | ||
30 | |||
31 | do_stage () { | ||
32 | autotools_stage_all | ||
33 | } | ||
34 | |||
35 | pkg_postinst_${PN} () { | ||
36 | #!/bin/sh -e | ||
37 | if [ "x$D" != "x" ]; then | ||
38 | exit 1 | ||
39 | fi | ||
40 | |||
41 | . ${sysconfdir}/init.d/functions | ||
42 | |||
43 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/mutter/general/clutter_plugins '[default]' | ||
44 | |||
45 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/mutter/general/compositing_manager true | ||
46 | } | ||
47 | |||
diff --git a/meta/packages/mutter/mutter_2.28.1.bb b/meta/packages/mutter/mutter_2.28.1.bb new file mode 100644 index 0000000000..c4b8107899 --- /dev/null +++ b/meta/packages/mutter/mutter_2.28.1.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require mutter.inc | ||
2 | |||
3 | SRC_URI = "http://download.moblin.org/sources/mutter/2.28/mutter-2.28.1_0.0.tar.bz2 \ | ||
4 | file://nodocs.patch;patch=1 \ | ||
5 | file://nozenity.patch;patch=1 \ | ||
6 | file://fix_pkgconfig.patch;patch=1 \ | ||
7 | " | ||
8 | |||
9 | S = "${WORKDIR}/mutter-2.28.1_0.0" \ No newline at end of file | ||
diff --git a/meta/packages/mutter/mutter_git.bb b/meta/packages/mutter/mutter_git.bb index 7352cf8a95..b41bf1e505 100644 --- a/meta/packages/mutter/mutter_git.bb +++ b/meta/packages/mutter/mutter_git.bb | |||
@@ -1,11 +1,7 @@ | |||
1 | SECTION = "x11/wm" | 1 | require mutter.inc |
2 | DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutter is metacity + clutter." | 2 | |
3 | LICENSE = "GPLv2" | ||
4 | DEPENDS = "startup-notification gtk+ gconf clutter-1.0 gdk-pixbuf-csource-native intltool glib-2.0-native" | ||
5 | # gobject-introspection | ||
6 | PR = "r18" | ||
7 | PV = "2.28.1+git${SRCPV}" | 3 | PV = "2.28.1+git${SRCPV}" |
8 | inherit gnome update-alternatives | 4 | PR = "r18" |
9 | 5 | ||
10 | # Gnome is the upstream but moblin is under more active development atm | 6 | # Gnome is the upstream but moblin is under more active development atm |
11 | # git://git.gnome.org/mutter.git;protocol=git;branch=master | 7 | # git://git.gnome.org/mutter.git;protocol=git;branch=master |
@@ -19,43 +15,3 @@ SRC_URI = "git://git.moblin.org/mutter.git;protocol=git;branch=master \ | |||
19 | " | 15 | " |
20 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
21 | 17 | ||
22 | ALTERNATIVE_NAME = "x-window-manager" | ||
23 | ALTERNATIVE_LINK = "${bindir}/x-window-manager" | ||
24 | ALTERNATIVE_PATH = "${bindir}/mutter" | ||
25 | ALTERNATIVE_PRIORITY = "11" | ||
26 | |||
27 | EXTRA_OECONF += "--disable-verbose \ | ||
28 | --disable-xinerama \ | ||
29 | --without-introspection \ | ||
30 | --with-clutter" | ||
31 | |||
32 | #RDEPENDS_${PN} = "zenity" | ||
33 | |||
34 | FILES_${PN} += "${datadir}/themes ${libdir}/mutter/plugins/*.so ${datadir}/gnome/wm-properties/" | ||
35 | FILES_${PN}-dbg += "${libdir}/mutter/plugins/.debug/*" | ||
36 | |||
37 | export CC_FOR_BUILD = "${BUILD_CC}" | ||
38 | export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include" | ||
39 | export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0" | ||
40 | |||
41 | do_configure_prepend () { | ||
42 | echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make | ||
43 | } | ||
44 | |||
45 | do_stage () { | ||
46 | autotools_stage_all | ||
47 | } | ||
48 | |||
49 | pkg_postinst_${PN} () { | ||
50 | #!/bin/sh -e | ||
51 | if [ "x$D" != "x" ]; then | ||
52 | exit 1 | ||
53 | fi | ||
54 | |||
55 | . ${sysconfdir}/init.d/functions | ||
56 | |||
57 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/mutter/general/clutter_plugins '[default]' | ||
58 | |||
59 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/mutter/general/compositing_manager true | ||
60 | } | ||
61 | |||