diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-04-22 17:36:22 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-04-22 17:36:22 +0100 |
commit | b2a619b79eff718317bec201a37ea5f6f92f6d46 (patch) | |
tree | a7c4474408497bec110c5faa9cf9bb1887323fd7 /meta/packages/mutter/mutter_git.bb | |
parent | ef5600cf10bc3d2cd2748deb5b532524ad1fa2e1 (diff) | |
download | poky-b2a619b79eff718317bec201a37ea5f6f92f6d46.tar.gz |
metacity-clutter: Rename to mutter and point at the new upstream
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mutter/mutter_git.bb')
-rw-r--r-- | meta/packages/mutter/mutter_git.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/mutter/mutter_git.bb b/meta/packages/mutter/mutter_git.bb new file mode 100644 index 0000000000..7d3a3b8c4f --- /dev/null +++ b/meta/packages/mutter/mutter_git.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | SECTION = "x11/wm" | ||
2 | DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutter is metacity + clutter." | ||
3 | LICENSE = "GPL" | ||
4 | DEPENDS = "startup-notification gtk+ gconf clutter gdk-pixbuf-csource-native intltool glib-2.0-native" | ||
5 | PR = "r8" | ||
6 | PV = "2.25.1+git${SRCREV}" | ||
7 | inherit gnome update-alternatives | ||
8 | |||
9 | SRC_URI = "git://git.gnome.org/mutter.git;protocol=git;branch=master \ | ||
10 | file://nodocs.patch;patch=1 \ | ||
11 | file://crosscompile.patch;patch=1 \ | ||
12 | file://fix_pkgconfig.patch;patch=1" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | ALTERNATIVE_NAME = "x-window-manager" | ||
16 | ALTERNATIVE_LINK = "${bindir}/x-window-manager" | ||
17 | ALTERNATIVE_PATH = "${bindir}/metacity" | ||
18 | ALTERNATIVE_PRIORITY = "11" | ||
19 | |||
20 | EXTRA_OECONF += "--disable-verbose \ | ||
21 | --disable-xinerama \ | ||
22 | --with-clutter" | ||
23 | |||
24 | FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so" | ||
25 | FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*" | ||
26 | |||
27 | export CC_FOR_BUILD = "${BUILD_CC}" | ||
28 | export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include" | ||
29 | export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0" | ||
30 | |||
31 | do_configure_prepend () { | ||
32 | echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make | ||
33 | } | ||
34 | |||
35 | do_stage () { | ||
36 | autotools_stage_all | ||
37 | } | ||
38 | |||
39 | pkg_postinst_${PN} () { | ||
40 | #!/bin/sh -e | ||
41 | if [ "x$D" != "x" ]; then | ||
42 | exit 1 | ||
43 | fi | ||
44 | |||
45 | . ${sysconfdir}/init.d/functions | ||
46 | |||
47 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[default]' | ||
48 | |||
49 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/metacity/general/compositing_manager true | ||
50 | } | ||
51 | |||