summaryrefslogtreecommitdiffstats
path: root/meta/packages/mutter/mutter
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/mutter/mutter
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mutter/mutter')
-rw-r--r--meta/packages/mutter/mutter/crosscompile.patch55
-rw-r--r--meta/packages/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch10
-rw-r--r--meta/packages/mutter/mutter/fix_pkgconfig.patch10
-rw-r--r--meta/packages/mutter/mutter/nodocs.patch29
-rw-r--r--meta/packages/mutter/mutter/nozenity.patch16
5 files changed, 0 insertions, 120 deletions
diff --git a/meta/packages/mutter/mutter/crosscompile.patch b/meta/packages/mutter/mutter/crosscompile.patch
deleted file mode 100644
index b27383b09a..0000000000
--- a/meta/packages/mutter/mutter/crosscompile.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1Index: git/configure.in
2===================================================================
3--- git.orig/configure.in 2009-01-27 14:49:10.000000000 +0000
4+++ git/configure.in 2009-01-27 15:29:41.000000000 +0000
5@@ -46,6 +46,32 @@
6 AC_LIBTOOL_WIN32_DLL
7 AM_PROG_LIBTOOL
8
9+if test x"$CC_FOR_BUILD" = x; then
10+ if test x"$cross_compiling" = xyes; then
11+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
12+ else
13+ CC_FOR_BUILD="$CC"
14+ fi
15+fi
16+AC_SUBST([CC_FOR_BUILD])
17+if test x"$CFLAGS_FOR_BUILD" = x; then
18+ if test x"$cross_compiling" = xyes; then
19+ AC_CHECK_PROGS(CFLAGS_FOR_BUILD, gcc cc)
20+ else
21+ CFLAGS_FOR_BUILD="$CFLAGS"
22+ fi
23+fi
24+AC_SUBST([CFLAGS_FOR_BUILD])
25+if test x"$LDFLAGS_FOR_BUILD" = x; then
26+ if test x"$cross_compiling" = xyes; then
27+ AC_CHECK_PROGS(LDFLAGS_FOR_BUILD, gcc cc)
28+ else
29+ LDFLAGS_FOR_BUILD="$LDFLAGS"
30+ fi
31+fi
32+AC_SUBST([LDFLAGS_FOR_BUILD])
33+
34+
35 #### Integer sizes
36
37 AC_CHECK_SIZEOF(char)
38Index: git/src/Makefile.am
39===================================================================
40--- git.orig/src/Makefile.am 2009-01-27 15:25:31.000000000 +0000
41+++ git/src/Makefile.am 2009-01-27 15:39:54.000000000 +0000
42@@ -168,11 +168,9 @@
43 metacity_dialog_SOURCES= \
44 ui/metacity-dialog.c
45
46-schema_bindings_SOURCES = \
47- core/schema-bindings.c \
48- metacity.schemas.in.in
49+schema_bindings:
50+ @CC_FOR_BUILD@ core/schema-bindings.c -I./include -I ../ @CFLAGS_FOR_BUILD@ @LDFLAGS_FOR_BUILD@ -o schema_bindings
51
52-schema_bindings_LDADD = @METACITY_LIBS@
53 metacity.schemas.in: schema_bindings ${srcdir}/metacity.schemas.in.in
54 @echo Generating keybinding schemas... ${srcdir}/metacity.schemas.in.in
55 ${builddir}/schema_bindings ${srcdir}/metacity.schemas.in.in ${builddir}/metacity.schemas.in
diff --git a/meta/packages/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch b/meta/packages/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch
deleted file mode 100644
index 3714383bc1..0000000000
--- a/meta/packages/mutter/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch
+++ /dev/null
@@ -1,10 +0,0 @@
1Index: git/src/metacity-plugins.pc.in
2===================================================================
3--- git.orig/src/metacity-plugins.pc.in 2008-12-17 22:42:19.000000000 +0000
4+++ git/src/metacity-plugins.pc.in 2008-12-17 22:42:25.000000000 +0000
5@@ -14,4 +14,4 @@
6 Requires: @CLUTTER_PACKAGE@
7 Version: @VERSION@
8 Libs: @CLUTTER_LIBS@
9-Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
10+Cflags: -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
diff --git a/meta/packages/mutter/mutter/fix_pkgconfig.patch b/meta/packages/mutter/mutter/fix_pkgconfig.patch
deleted file mode 100644
index 5ac5ecc609..0000000000
--- a/meta/packages/mutter/mutter/fix_pkgconfig.patch
+++ /dev/null
@@ -1,10 +0,0 @@
1Index: git/src/mutter-plugins.pc.in
2===================================================================
3--- git.orig/src/mutter-plugins.pc.in 2009-07-03 17:30:39.000000000 +0100
4+++ git/src/mutter-plugins.pc.in 2009-07-03 18:03:09.000000000 +0100
5@@ -14,4 +14,4 @@
6 Requires: @CLUTTER_PACKAGE@
7 Version: @VERSION@
8 Libs: @CLUTTER_LIBS@
9-Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/mutter/mutter-private -DMUTTER_MAJOR_VERSION=${mutter_major_version} -DMUTTER_MINOR_VERSION=${mutter_minor_version} -DMUTTER_MICRO_VERSION=${mutter_micro_version} -DMUTTER_PLUGIN_API_VERSION=${mutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${plugindir}\"
10+Cflags: -DWITH_CLUTTER -I${includedir}/mutter/mutter-private -DMUTTER_MAJOR_VERSION=${mutter_major_version} -DMUTTER_MINOR_VERSION=${mutter_minor_version} -DMUTTER_MICRO_VERSION=${mutter_micro_version} -DMUTTER_PLUGIN_API_VERSION=${mutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${plugindir}\"
diff --git a/meta/packages/mutter/mutter/nodocs.patch b/meta/packages/mutter/mutter/nodocs.patch
deleted file mode 100644
index 98f43be5e8..0000000000
--- a/meta/packages/mutter/mutter/nodocs.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1Index: git/Makefile.am
2===================================================================
3--- git.orig/Makefile.am 2009-01-27 13:26:12.000000000 +0000
4+++ git/Makefile.am 2009-01-27 14:07:13.000000000 +0000
5@@ -1,5 +1,5 @@
6
7-SUBDIRS=src po doc
8+SUBDIRS=src po
9
10 EXTRA_DIST = HACKING MAINTAINERS rationales.txt \
11 intltool-extract.in intltool-merge.in intltool-update.in
12Index: git/configure.in
13===================================================================
14--- git.orig/configure.in 2009-01-27 13:26:12.000000000 +0000
15+++ git/configure.in 2009-01-27 14:11:16.000000000 +0000
16@@ -538,12 +538,9 @@
17
18 # Warnings are there for a reason
19 if test "x$GCC" = "xyes"; then
20- CFLAGS="$CFLAGS -Wall -Werror -ansi"
21+ CFLAGS="$CFLAGS -Wall -ansi"
22 fi
23
24-# Use gnome-doc-utils:
25-GNOME_DOC_INIT([0.8.0])
26-
27 AC_CONFIG_FILES([
28 Makefile
29 doc/Makefile
diff --git a/meta/packages/mutter/mutter/nozenity.patch b/meta/packages/mutter/mutter/nozenity.patch
deleted file mode 100644
index 06f5909533..0000000000
--- a/meta/packages/mutter/mutter/nozenity.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1Index: git/configure.in
2===================================================================
3--- git.orig/configure.in 2009-06-16 13:12:17.000000000 +0100
4+++ git/configure.in 2009-06-16 13:12:33.000000000 +0100
5@@ -575,11 +575,6 @@
6 GCONF_SCHEMAS_INSTALL_FALSE=
7 fi
8
9-AC_PATH_PROG(ZENITY, zenity, no)
10-if test x"$ZENITY" = xno; then
11- AC_MSG_ERROR([zenity not found in your path - needed for dialogs])
12-fi
13-
14 AC_ARG_ENABLE(debug,
15 [ --enable-debug enable debugging],,
16 enable_debug=no)