diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/mtools | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mtools')
-rw-r--r-- | meta/packages/mtools/mtools/mtools-makeinfo.patch | 63 | ||||
-rw-r--r-- | meta/packages/mtools/mtools/mtools.patch | 127 | ||||
-rw-r--r-- | meta/packages/mtools/mtools/no-x11.patch | 19 | ||||
-rw-r--r-- | meta/packages/mtools/mtools_3.9.9.bb | 22 |
4 files changed, 0 insertions, 231 deletions
diff --git a/meta/packages/mtools/mtools/mtools-makeinfo.patch b/meta/packages/mtools/mtools/mtools-makeinfo.patch deleted file mode 100644 index 35fae44aba..0000000000 --- a/meta/packages/mtools/mtools/mtools-makeinfo.patch +++ /dev/null | |||
@@ -1,63 +0,0 @@ | |||
1 | --- mtools-3.9.9/configure.in.orig 2006-04-14 16:05:54.337655192 -0600 | ||
2 | +++ mtools-3.9.9/configure.in 2006-04-14 16:12:29.736545424 -0600 | ||
3 | @@ -21,6 +21,33 @@ | ||
4 | AC_C_CONST | ||
5 | AC_C_INLINE | ||
6 | |||
7 | +AC_CHECK_PROG(MAKEINFO, makeinfo, makeinfo, ) | ||
8 | +if test "x$MAKEINFO" = "x"; then | ||
9 | + MAKEINFO="@echo makeinfo missing; true" | ||
10 | +fi | ||
11 | +AC_CHECK_PROG(TEXI2DVI, texi2dvi, texi2dvi, ) | ||
12 | +if test "x$TEXI2DVI" = "x"; then | ||
13 | + TEXI2DVI="@echo texi2dvi missing; true" | ||
14 | +fi | ||
15 | +AC_CHECK_PROG(TEXI2PDF, texi2pdf, texi2pdf, ) | ||
16 | +if test "x$TEXI2PDF" = "x"; then | ||
17 | + TEXI2PDF="@echo texi2pdf missing; true" | ||
18 | +fi | ||
19 | +AC_CHECK_PROG(TEXI2HTML, texi2html, texi2html, ) | ||
20 | +if test "x$TEXI2HTML" = "x"; then | ||
21 | + TEXI2HTML="@echo texi2html missing; true" | ||
22 | +fi | ||
23 | +AC_CHECK_PROG(DVI2PS, dvi2ps, dvi2ps, ) | ||
24 | +if test "x$DVI2PS" = "x"; then | ||
25 | + DVI2PS="@echo dvi2ps missing; true" | ||
26 | +fi | ||
27 | + | ||
28 | +AC_SUBST(MAKEINFO) | ||
29 | +AC_SUBST(TEXI2DVI) | ||
30 | +AC_SUBST(TEXI2PDF) | ||
31 | +AC_SUBST(TEXI2HTML) | ||
32 | +AC_SUBST(DVI2PS) | ||
33 | + | ||
34 | |||
35 | dnl Check for configuration options | ||
36 | dnl Enable OS/2 extended density format disks | ||
37 | --- mtools-3.9.9/Makefile.in.sav 2006-04-14 15:56:19.000000000 -0600 | ||
38 | +++ mtools-3.9.9/Makefile.in 2006-04-14 16:15:29.315245312 -0600 | ||
39 | @@ -11,10 +11,11 @@ | ||
40 | USERLDFLAGS = | ||
41 | USERLDLIBS = | ||
42 | |||
43 | -MAKEINFO = makeinfo | ||
44 | -TEXI2DVI = texi2dvi | ||
45 | -TEXI2PDF = texi2pdf | ||
46 | -TEXI2HTML = texi2html | ||
47 | +MAKEINFO = @MAKEINFO@ | ||
48 | +TEXI2DVI = @TEXI2DVI@ | ||
49 | +TEXI2PDF = @TEXI2PDF@ | ||
50 | +TEXI2HTML = @TEXI2HTML@ | ||
51 | +DVI2PS = @DVI2PS@ | ||
52 | |||
53 | |||
54 | # do not edit below this line | ||
55 | @@ -181,7 +182,7 @@ | ||
56 | |||
57 | ps: mtools.ps | ||
58 | %.ps: %.dvi | ||
59 | - dvips -f < $< > $@ | ||
60 | + $(DVI2PS) -f < $< > $@ | ||
61 | |||
62 | pdf: mtools.pdf | ||
63 | %.pdf: %.texi | ||
diff --git a/meta/packages/mtools/mtools/mtools.patch b/meta/packages/mtools/mtools/mtools.patch deleted file mode 100644 index 2abf534731..0000000000 --- a/meta/packages/mtools/mtools/mtools.patch +++ /dev/null | |||
@@ -1,127 +0,0 @@ | |||
1 | $NetBSD: patch-aa,v 1.10 2007/08/17 20:55:34 joerg Exp $ | ||
2 | |||
3 | --- | ||
4 | Makefile.in | 74 ++++++++++++++++++++++++++---------------------------------- | ||
5 | 1 file changed, 33 insertions(+), 41 deletions(-) | ||
6 | |||
7 | Index: mtools-3.9.9/Makefile.in | ||
8 | =================================================================== | ||
9 | --- mtools-3.9.9.orig/Makefile.in 2007-10-12 11:18:46.000000000 +0100 | ||
10 | +++ mtools-3.9.9/Makefile.in 2007-10-12 11:28:14.000000000 +0100 | ||
11 | @@ -195,30 +195,22 @@ html: mtools.html mtools_toc.html | ||
12 | |||
13 | # Don't cd, to avoid breaking install-sh references. | ||
14 | install-info: info | ||
15 | - $(top_srcdir)/mkinstalldirs $(infodir) | ||
16 | + $(top_srcdir)/mkinstalldirs ${DESTDIR}$(infodir) | ||
17 | if test -f mtools.info; then \ | ||
18 | for i in mtools.info*; do \ | ||
19 | - $(INSTALL_DATA) $$i $(infodir)/$$i; \ | ||
20 | + $(INSTALL_DATA) $$i ${DESTDIR}$(infodir)/$$i; \ | ||
21 | done; \ | ||
22 | else \ | ||
23 | for i in $(srcdir)/mtools.info*; do \ | ||
24 | - $(INSTALL_DATA) $$i $(infodir)/`echo $$i | sed 's|^$(srcdir)/||'`; \ | ||
25 | + $(INSTALL_DATA) $$i ${DESTDIR}$(infodir)/`echo $$i | sed 's|^$(srcdir)/||'`; \ | ||
26 | done; \ | ||
27 | fi; \ | ||
28 | - if [ -n "$(INSTALL_INFO)" ] ; then \ | ||
29 | - if [ -f $(infodir)/dir.info ] ; then \ | ||
30 | - $(INSTALL_INFO) $(infodir)/mtools.info $(infodir)/dir.info; \ | ||
31 | - fi; \ | ||
32 | - if [ -f $(infodir)/dir ] ; then \ | ||
33 | - $(INSTALL_INFO) $(infodir)/mtools.info $(infodir)/dir; \ | ||
34 | - fi; \ | ||
35 | - fi | ||
36 | |||
37 | uninstall-info: | ||
38 | cd $(infodir) && rm -f mtools.info* | ||
39 | |||
40 | -install: $(bindir)/mtools @BINFLOPPYD@ install-man install-links \ | ||
41 | - $(bindir)/mkmanifest install-scripts install-info | ||
42 | +install: ${DESTDIR}$(bindir)/mtools ${DESTDIR}$(bindir)/floppyd install-man install-links \ | ||
43 | + ${DESTDIR}$(bindir)/mkmanifest install-scripts install-info | ||
44 | |||
45 | uninstall: uninstall-bin uninstall-man uninstall-links \ | ||
46 | uninstall-scripts | ||
47 | @@ -228,52 +220,52 @@ distclean: clean texclean | ||
48 | maintainer-clean: distclean | ||
49 | |||
50 | |||
51 | -$(bindir)/floppyd: floppyd | ||
52 | - $(top_srcdir)/mkinstalldirs $(bindir) | ||
53 | - $(INSTALL_PROGRAM) floppyd $(bindir)/floppyd | ||
54 | +${DESTDIR}$(bindir)/floppyd: floppyd | ||
55 | + $(top_srcdir)/mkinstalldirs ${DESTDIR}$(bindir) | ||
56 | + $(INSTALL_PROGRAM) floppyd ${DESTDIR}$(bindir)/floppyd | ||
57 | |||
58 | -$(bindir)/floppyd_installtest: floppyd_installtest | ||
59 | - $(top_srcdir)/mkinstalldirs $(bindir) | ||
60 | - $(INSTALL_PROGRAM) floppyd_installtest $(bindir)/floppyd_installtest | ||
61 | +${DESTDIR}$(bindir)/floppyd_installtest: floppyd_installtest | ||
62 | + $(top_srcdir)/mkinstalldirs ${DESTDIR}$(bindir) | ||
63 | + $(INSTALL_PROGRAM) floppyd_installtest ${DESTDIR}$(bindir)/floppyd_installtest | ||
64 | |||
65 | -$(bindir)/mtools: mtools | ||
66 | - $(top_srcdir)/mkinstalldirs $(bindir) | ||
67 | - $(INSTALL_PROGRAM) mtools $(bindir)/mtools | ||
68 | +${DESTDIR}$(bindir)/mtools: mtools | ||
69 | + $(top_srcdir)/mkinstalldirs ${DESTDIR}$(bindir) | ||
70 | + $(INSTALL_PROGRAM) mtools ${DESTDIR}$(bindir)/mtools | ||
71 | |||
72 | -$(bindir)/mkmanifest: mkmanifest | ||
73 | - $(top_srcdir)/mkinstalldirs $(bindir) | ||
74 | - $(INSTALL_PROGRAM) mkmanifest $(bindir)/mkmanifest | ||
75 | +${DESTDIR}$(bindir)/mkmanifest: mkmanifest | ||
76 | + $(top_srcdir)/mkinstalldirs ${DESTDIR}$(bindir) | ||
77 | + $(INSTALL_PROGRAM) mkmanifest ${DESTDIR}$(bindir)/mkmanifest | ||
78 | |||
79 | #$(ETCDIR)/mtools: mtools.etc | ||
80 | # cp mtools.etc $(ETCDIR)/mtools | ||
81 | |||
82 | -install-links: $(bindir)/mtools | ||
83 | +install-links: ${DESTDIR}$(bindir)/mtools | ||
84 | @for j in $(LINKS); do \ | ||
85 | - rm -f $(bindir)/$$j ; \ | ||
86 | - $(LN_S) mtools $(bindir)/$$j ; \ | ||
87 | - echo $(bindir)/$$j ; \ | ||
88 | + rm -f ${DESTDIR}$(bindir)/$$j ; \ | ||
89 | + $(LN_S) mtools ${DESTDIR}$(bindir)/$$j ; \ | ||
90 | + echo ${DESTDIR}$(bindir)/$$j ; \ | ||
91 | done | ||
92 | |||
93 | ## "z" is the older version of "gz"; the name is just *too* short | ||
94 | -install-scripts: $(bindir)/mtools | ||
95 | - @$(top_srcdir)/mkinstalldirs $(bindir) | ||
96 | +install-scripts: ${DESTDIR}$(bindir)/mtools | ||
97 | + @$(top_srcdir)/mkinstalldirs ${DESTDIR}$(bindir) | ||
98 | @for j in $(SCRIPTS) ; do \ | ||
99 | - $(INSTALL_PROGRAM) $(srcdir)/scripts/$$j $(bindir)/$$j ; \ | ||
100 | - echo $(bindir)/$$j ; \ | ||
101 | + $(INSTALL_SCRIPT) $(srcdir)/scripts/$$j ${DESTDIR}$(bindir)/$$j ; \ | ||
102 | + echo ${DESTDIR}$(bindir)/$$j ; \ | ||
103 | done | ||
104 | - rm -f $(bindir)/lz | ||
105 | - $(LN_S) uz $(bindir)/lz | ||
106 | + rm -f ${DESTDIR}$(bindir)/lz | ||
107 | + $(LN_S) uz ${DESTDIR}$(bindir)/lz | ||
108 | |||
109 | install-man: | ||
110 | - @$(top_srcdir)/mkinstalldirs $(MAN1DIR) | ||
111 | + @$(top_srcdir)/mkinstalldirs ${DESTDIR}$(MAN1DIR) | ||
112 | @for j in $(MAN1); do \ | ||
113 | - $(INSTALL_DATA) $(srcdir)/$$j $(MAN1DIR)/$$j ; \ | ||
114 | - echo $(MAN1DIR)/$$j ; \ | ||
115 | + $(INSTALL_DATA) $(srcdir)/$$j ${DESTDIR}$(MAN1DIR)/$$j ; \ | ||
116 | + echo ${DESTDIR}$(MAN1DIR)/$$j ; \ | ||
117 | done | ||
118 | - @$(top_srcdir)/mkinstalldirs $(MAN5DIR) | ||
119 | + @$(top_srcdir)/mkinstalldirs ${DESTDIR}$(MAN5DIR) | ||
120 | @for j in $(MAN5); do \ | ||
121 | - $(INSTALL_DATA) $(srcdir)/$$j $(MAN5DIR)/$$j ; \ | ||
122 | - echo $(MAN5DIR)/$$j ; \ | ||
123 | + $(INSTALL_DATA) $(srcdir)/$$j ${DESTDIR}$(MAN5DIR)/$$j ; \ | ||
124 | + echo ${DESTDIR}$(MAN5DIR)/$$j ; \ | ||
125 | done | ||
126 | |||
127 | uninstall-bin: | ||
diff --git a/meta/packages/mtools/mtools/no-x11.patch b/meta/packages/mtools/mtools/no-x11.patch deleted file mode 100644 index 300f43f000..0000000000 --- a/meta/packages/mtools/mtools/no-x11.patch +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | --- | ||
2 | Makefile.in | 2 +- | ||
3 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
4 | |||
5 | --- mtools-3.9.9.orig/Makefile.in | ||
6 | +++ mtools-3.9.9/Makefile.in | ||
7 | @@ -128,11 +128,11 @@ X_EXTRA_LIBS = @X_EXTRA_LIBS@ | ||
8 | X_PRE_LIBS = @X_PRE_LIBS@ | ||
9 | CFLAGS = $(CPPFLAGS) $(DEFS) $(MYCFLAGS) -I. @extraincludedir@ -I@srcdir@ $(USERCFLAGS) | ||
10 | CXXFLAGS = $(CPPFLAGS) $(DEFS) $(MYCXXFLAGS) -I. @extraincludedir@ -I@srcdir@ $(USERCFLAGS) | ||
11 | LINK = $(CC) $(LDFLAGS) $(USERLDFLAGS) @extralibdir@ | ||
12 | ALLLIBS = $(USERLDLIBS) $(MACHDEPLIBS) $(SHLIB) $(LIBS) | ||
13 | -X_LDFLAGS = $(X_EXTRA_LIBS) $(X_LIBS) $(X_PRE_LIBS) -lXau -lX11 $(LIBS) | ||
14 | +X_LDFLAGS = $(X_EXTRA_LIBS) $(X_LIBS) $(X_PRE_LIBS) $(LIBS) | ||
15 | X_CCFLAGS = $(X_CFLAGS) $(CFLAGS) | ||
16 | |||
17 | all: mtools $(LINKS) mkmanifest @FLOPPYD@ | ||
18 | |||
19 | %.o: %.c | ||
diff --git a/meta/packages/mtools/mtools_3.9.9.bb b/meta/packages/mtools/mtools_3.9.9.bb deleted file mode 100644 index 932d88f2a3..0000000000 --- a/meta/packages/mtools/mtools_3.9.9.bb +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | # mtools OE build file | ||
2 | # Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved | ||
3 | # Released under the MIT license (see packages/COPYING) | ||
4 | |||
5 | DESCRIPTION="Mtools is a collection of utilities for accessing MS-DOS disks from Unix without mounting them." | ||
6 | HOMEPAGE="http://mtools.linux.lu" | ||
7 | LICENSE="GPL" | ||
8 | PR = "r4" | ||
9 | |||
10 | #http://mtools.linux.lu/mtools-${PV}.tar.gz | ||
11 | SRC_URI="http://folks.o-hand.com/richard/poky/sources/mtools-${PV}.tar.gz \ | ||
12 | file://mtools-makeinfo.patch;patch=1 \ | ||
13 | file://mtools.patch;patch=1 \ | ||
14 | file://no-x11.patch;patch=1" | ||
15 | |||
16 | S = "${WORKDIR}/mtools-${PV}" | ||
17 | |||
18 | inherit autotools | ||
19 | |||
20 | EXTRA_OECONF = "--without-x" | ||
21 | |||
22 | BBCLASSEXTEND = "native" | ||