summaryrefslogtreecommitdiffstats
path: root/meta/packages/mtd/mtd-utils/lzo_1x.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-07-23 16:33:20 +0000
committerRichard Purdie <richard@openedhand.com>2007-07-23 16:33:20 +0000
commit75c94643bb584a4b086344309108d16bd208647f (patch)
treef93d69ecf66f21304850924441204c9f29f930ca /meta/packages/mtd/mtd-utils/lzo_1x.patch
parentc572384a554b8145058f530ebd0b83c3c66badb9 (diff)
downloadpoky-75c94643bb584a4b086344309108d16bd208647f.tar.gz
mtd-utils: Work with lzo 1.x for now
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2213 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/mtd/mtd-utils/lzo_1x.patch')
-rw-r--r--meta/packages/mtd/mtd-utils/lzo_1x.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/mtd/mtd-utils/lzo_1x.patch b/meta/packages/mtd/mtd-utils/lzo_1x.patch
new file mode 100644
index 0000000000..b882d9f504
--- /dev/null
+++ b/meta/packages/mtd/mtd-utils/lzo_1x.patch
@@ -0,0 +1,26 @@
1Index: git/Makefile
2===================================================================
3--- git.orig/Makefile
4+++ git/Makefile
5@@ -60,7 +60,7 @@ $(BUILDDIR)/mkfs.jffs2: $(BUILDDIR)/crc3
6 $(BUILDDIR)/compr_zlib.o \
7 $(BUILDDIR)/compr_lzo.o \
8 $(BUILDDIR)/compr.o
9- $(CC) $(LDFLAGS) -o $@ $^ -lz -llzo2
10+ $(CC) $(LDFLAGS) -o $@ $^ -lz -llzo
11
12 $(BUILDDIR)/flash_eraseall: $(BUILDDIR)/crc32.o $(BUILDDIR)/flash_eraseall.o
13 $(CC) $(LDFLAGS) -o $@ $^
14Index: git/compr_lzo.c
15===================================================================
16--- git.orig/compr_lzo.c
17+++ git/compr_lzo.c
18@@ -26,7 +26,7 @@
19 #include <string.h>
20 #include <asm/types.h>
21 #include <linux/jffs2.h>
22-#include <lzo/lzo1x.h>
23+#include <lzo1x.h>
24 #include "compr.h"
25
26 extern int page_size;