summaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla-headless/mozilla-headless_hg.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-20 01:22:17 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-20 01:22:17 +0100
commit6c5d81946aac4f94ca42fdc02542420cb38ed756 (patch)
tree753a0196a5d55d453929286cb9256a13d6774d7f /meta/packages/mozilla-headless/mozilla-headless_hg.bb
parent25185d5bb2cc100c606d332482ba2243f0aab3c9 (diff)
downloadpoky-6c5d81946aac4f94ca42fdc02542420cb38ed756.tar.gz
mozilla-headless: Hardcode compiler options for now
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless_hg.bb')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless_hg.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless_hg.bb b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
index e8351703c7..44a829c7a3 100644
--- a/meta/packages/mozilla-headless/mozilla-headless_hg.bb
+++ b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
@@ -3,10 +3,12 @@ FIXEDREV = "f4348fd85697"
3 3
4SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=${FIXEDREV};module=offscreen \ 4SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=${FIXEDREV};module=offscreen \
5 file://configurefix.patch;patch=1 \ 5 file://configurefix.patch;patch=1 \
6 file://0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch;patch=1 \
7 file://mozilla-jemalloc.patch;patch=1 \
6 file://jsautocfg.h \ 8 file://jsautocfg.h \
7 file://mozconfig" 9 file://mozconfig"
8PV = "0.0+hg-1.0+${FIXEDREV}" 10PV = "0.0+hg-1.0+${FIXEDREV}"
9PR = "r0" 11PR = "r1"
10 12
11S = "${WORKDIR}/offscreen" 13S = "${WORKDIR}/offscreen"
12 14
@@ -16,6 +18,14 @@ FILES_${PN} += "${libdir}/xulrunner-1.9.2a1pre"
16FILES_${PN}-dev += "${libdir}/xulrunner-devel-1.9.2a1pre" 18FILES_${PN}-dev += "${libdir}/xulrunner-devel-1.9.2a1pre"
17FILES_${PN}-dbg += "${libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/.debug" 19FILES_${PN}-dbg += "${libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/.debug"
18 20
21TARGET_CC_ARCH = ""
22
23CFLAGS = "${TARGET_CFLAGS}"
24TARGET_CFLAGS = "-Os -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=core2 -msse3 -mtune=generic -mfpmath=sse -fasynchronous-unwind-tables"
25
26LDFLAGS = "${TARGET_LDFLAGS}"
27TARGET_LDFLAGS = "-Wl,-rpath,${libdir}/xulrunner-1.9.2a1pre"
28
19inherit autotools_stage mozilla 29inherit autotools_stage mozilla
20 30
21acpaths = "-I ${S}/build/autoconf " 31acpaths = "-I ${S}/build/autoconf "
@@ -41,8 +51,8 @@ do_install_append () {
41 echo ${libdir}/xulrunner-1.9.2a1pre/ > ${D}${sysconfdir}/ld.so.conf.d/mozilla-headless 51 echo ${libdir}/xulrunner-1.9.2a1pre/ > ${D}${sysconfdir}/ld.so.conf.d/mozilla-headless
42} 52}
43 53
44EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless \ 54EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless --with-pthreads \
45 --enable-pango --disable-optimize --disable-debug --disable-tests \ 55 --enable-pango --enable-optimize --disable-debug --disable-tests \
46 --disable-printing --disable-crashreporter --disable-accessibility \ 56 --disable-printing --disable-crashreporter --disable-accessibility \
47 --disable-javaxpcom --enable-plugins --enable-system-sqlite --disable-necko-wifi" 57 --disable-javaxpcom --enable-plugins --enable-system-sqlite --disable-necko-wifi"
48 58
@@ -55,5 +65,6 @@ do_stage_append () {
55 ln -fs ${STAGING_DIR_HOST}${layout_datadir}/xulrunner-1.9.2a1pre/unstable/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/idl 65 ln -fs ${STAGING_DIR_HOST}${layout_datadir}/xulrunner-1.9.2a1pre/unstable/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/idl
56 ln -fs ${STAGING_DIR_HOST}${layout_includedir}/xulrunner-1.9.2a1pre/unstable/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/include 66 ln -fs ${STAGING_DIR_HOST}${layout_includedir}/xulrunner-1.9.2a1pre/unstable/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/include
57 ln -fs ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/lib 67 ln -fs ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/lib
68 install -m 755 ${S}/dist/host/bin/host_xpidl ${STAGING_BINDIR_NATIVE}/xpidl
58} 69}
59 70