summaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla-headless/mozilla-headless_hg.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-12-10 14:00:23 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-12-10 14:00:23 +0000
commit7ab7ad82f47d17e629288e67dd94660722899f9e (patch)
tree625110c9e90908784a4d282b4e990c26ea1ed2dc /meta/packages/mozilla-headless/mozilla-headless_hg.bb
parent9e278010556d1a6bc5ba3bbf8c1aee976d4a64e4 (diff)
downloadpoky-7ab7ad82f47d17e629288e67dd94660722899f9e.tar.gz
mozilla-headless: Update to work with recent git changes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless_hg.bb')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless_hg.bb38
1 files changed, 28 insertions, 10 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless_hg.bb b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
index 9b0cbabfcd..58306da590 100644
--- a/meta/packages/mozilla-headless/mozilla-headless_hg.bb
+++ b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
@@ -2,13 +2,16 @@
2FIXEDREV = "${SRCREVMOZILLAHEADLESS}" 2FIXEDREV = "${SRCREVMOZILLAHEADLESS}"
3#file://0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch;patch=1 \ 3#file://0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch;patch=1 \
4SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;module=offscreen \ 4SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;module=offscreen \
5 file://configurefix.patch;patch=1 \ 5 file://configurefix-1a622cb7c384.patch;patch=1;rev=1a622cb7c384 \
6 file://configurefix.patch;patch=1;notrev=1a622cb7c384 \
6 file://mozilla-jemalloc.patch;patch=1 \ 7 file://mozilla-jemalloc.patch;patch=1 \
7 file://removebadrpath.patch;patch=1 \ 8 file://removebadrpath-1a622cb7c384.patch;patch=1;rev=1a622cb7c384 \
9 file://removebadrpath.patch;patch=1;notrev=1a622cb7c384 \
10 file://buildfixhack.patch;patch=1;notrev=1a622cb7c384 \
8 file://jsautocfg.h \ 11 file://jsautocfg.h \
9 file://mozconfig" 12 file://mozconfig"
10PV = "0.2+hg-1.0+${SRCPV}" 13PV = "0.2+hg-1.0+${SRCPV}"
11PR = "r5" 14PR = "r7"
12 15
13S = "${WORKDIR}/offscreen" 16S = "${WORKDIR}/offscreen"
14 17
@@ -26,6 +29,8 @@ TARGET_CFLAGS = "-Os -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-prote
26LDFLAGS = "${TARGET_LDFLAGS}" 29LDFLAGS = "${TARGET_LDFLAGS}"
27TARGET_LDFLAGS = "-Wl,-rpath,${libdir}/xulrunner-1.9.2a1pre" 30TARGET_LDFLAGS = "-Wl,-rpath,${libdir}/xulrunner-1.9.2a1pre"
28 31
32export target_alias=${TARGET_PREFIX}
33
29inherit autotools_stage mozilla 34inherit autotools_stage mozilla
30 35
31acpaths = "-I ${S}/build/autoconf " 36acpaths = "-I ${S}/build/autoconf "
@@ -33,6 +38,13 @@ acpaths = "-I ${S}/build/autoconf "
33export topsrcdir = "${S}" 38export topsrcdir = "${S}"
34 39
35do_configure () { 40do_configure () {
41 if [ "${SRCREV}" != "1a622cb7c384" ]; then
42 rm -rf ${S}/build/autoconf/acwinpaths.m4
43 rm -rf ${S}/js/src/build/autoconf/acwinpaths.m4
44 rm -rf ${S}/nsprpub/build/autoconf/acwinpaths.m4
45 mkdir -p ${S}/js/src/dist/include
46 ln -fs ../../../../nsprpub/dist/include/nspr ${S}/js/src/dist/include/nsprpub
47 fi
36 cp ${S}/build/autoconf/install-sh ${S} 48 cp ${S}/build/autoconf/install-sh ${S}
37 autotools_do_configure 49 autotools_do_configure
38 # Yes, we run this twice. The first pass sets up npsrpub-config which then 50 # Yes, we run this twice. The first pass sets up npsrpub-config which then
@@ -46,9 +58,11 @@ do_compile () {
46 base_do_compile 58 base_do_compile
47} 59}
48 60
61XULVERSION = "1.9.3a1pre"
62
49do_install_append () { 63do_install_append () {
50 install -d ${D}${sysconfdir}/ld.so.conf.d/ 64 install -d ${D}${sysconfdir}/ld.so.conf.d/
51 echo ${libdir}/xulrunner-1.9.2a1pre/ > ${D}${sysconfdir}/ld.so.conf.d/mozilla-headless 65 echo ${libdir}/xulrunner-${XULVERSION}/ > ${D}${sysconfdir}/ld.so.conf.d/mozilla-headless
52} 66}
53 67
54EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless --with-pthreads \ 68EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless --with-pthreads \
@@ -61,15 +75,19 @@ export LIBXUL_DIST="${S}/dist"
61SYSROOT_PREPROCESS_FUNCS += "mozilla_sysroot_preprocess" 75SYSROOT_PREPROCESS_FUNCS += "mozilla_sysroot_preprocess"
62 76
63mozilla_sysroot_preprocess () { 77mozilla_sysroot_preprocess () {
64 autotools_stage_dir ${D}/${libdir}/xulrunner-1.9.2a1pre ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-1.9.2a1pre/ 78 autotools_stage_dir ${D}/${libdir}/xulrunner-${XULVERSION} ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-${XULVERSION}/
65 autotools_stage_dir ${D}/${libdir}/xulrunner-devel-1.9.2a1pre ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-1.9.2a1pre/ 79 autotools_stage_dir ${D}/${libdir}/xulrunner-devel-${XULVERSION} ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-${XULVERSION}/
66 80
67 ln -fs ${STAGING_DIR_HOST}${libdir}/xulrunner-1.9.2a1pre/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-1.9.2a1pre/bin 81 ln -fs ${STAGING_DIR_HOST}${libdir}/xulrunner-${XULVERSION}/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-${XULVERSION}/bin
68 ln -fs ${STAGING_DIR_HOST}${datadir}/xulrunner-1.9.2a1pre/unstable/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-1.9.2a1pre/idl 82 ln -fs ${STAGING_DIR_HOST}${datadir}/xulrunner-${XULVERSION}/unstable/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-${XULVERSION}/idl
69 ln -fs ${STAGING_DIR_HOST}${includedir}/xulrunner-1.9.2a1pre/unstable/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-1.9.2a1pre/include 83 ln -fs ${STAGING_DIR_HOST}${includedir}/xulrunner-${XULVERSION}/unstable/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-${XULVERSION}/include
70 ln -fs ${STAGING_DIR_HOST}${libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-1.9.2a1pre/lib 84 ln -fs ${STAGING_DIR_HOST}${libdir}/xulrunner-devel-${XULVERSION}/sdk/lib/ ${SYSROOT_DESTDIR}${STAGING_DIR_HOST}${libdir}/xulrunner-devel-${XULVERSION}/lib
71 85
72 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS} 86 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}
73 install -m 755 ${S}/dist/host/bin/host_xpidl ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/xpidl 87 install -m 755 ${S}/dist/host/bin/host_xpidl ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/xpidl
74} 88}
75 89
90__anonymous () {
91 if bb.data.getVar("SRCREV", d, True) == "1a622cb7c384":
92 bb.data.setVar("XULVERSION", "1.9.2a1pre", d)
93}