summaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-12 23:27:15 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-12 23:27:15 +0100
commite1ee329a888bc406a92ba83e33af5fb63c74ce6a (patch)
treee7b9d8106af1084fb76c41268757ef79c27b369d /meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch
parent19592cf696d73e23beef34533958596ea4419696 (diff)
downloadpoky-e1ee329a888bc406a92ba83e33af5fb63c74ce6a.tar.gz
mozilla-headless: Catch up with upstream changes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch72
1 files changed, 32 insertions, 40 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch b/meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch
index b3972e78f7..db9e147990 100644
--- a/meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch
+++ b/meta/packages/mozilla-headless/mozilla-headless/0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch
@@ -21,11 +21,11 @@ the clipboard.
21 create mode 100644 widget/src/headless/nsImageToPixbuf.cpp 21 create mode 100644 widget/src/headless/nsImageToPixbuf.cpp
22 create mode 100644 widget/src/headless/nsImageToPixbuf.h 22 create mode 100644 widget/src/headless/nsImageToPixbuf.h
23 23
24diff --git a/widget/src/headless/Makefile.in b/widget/src/headless/Makefile.in 24Index: offscreen/widget/src/headless/Makefile.in
25index c8727d9..cbdf900 100644 25===================================================================
26--- a/widget/src/headless/Makefile.in 26--- offscreen.orig/widget/src/headless/Makefile.in 2009-05-16 18:23:25.000000000 +0100
27+++ b/widget/src/headless/Makefile.in 27+++ offscreen/widget/src/headless/Makefile.in 2009-06-12 14:14:05.000000000 +0100
28@@ -95,6 +95,12 @@ CPPSRCS = \ 28@@ -95,6 +95,12 @@
29 nsScreenManagerHeadless.cpp \ 29 nsScreenManagerHeadless.cpp \
30 $(NULL) 30 $(NULL)
31 31
@@ -38,11 +38,10 @@ index c8727d9..cbdf900 100644
38 # build our subdirs, too 38 # build our subdirs, too
39 SHARED_LIBRARY_LIBS = ../xpwidgets/libxpwidgets_s.a 39 SHARED_LIBRARY_LIBS = ../xpwidgets/libxpwidgets_s.a
40 40
41diff --git a/widget/src/headless/nsClipboard.cpp b/widget/src/headless/nsClipboard.cpp 41Index: offscreen/widget/src/headless/nsClipboard.cpp
42new file mode 100644 42===================================================================
43index 0000000..72a37fc 43--- /dev/null 1970-01-01 00:00:00.000000000 +0000
44--- /dev/null 44+++ offscreen/widget/src/headless/nsClipboard.cpp 2009-06-12 14:14:05.000000000 +0100
45+++ b/widget/src/headless/nsClipboard.cpp
46@@ -0,0 +1,948 @@ 45@@ -0,0 +1,948 @@
47+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */ 46+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
48+/* vim:expandtab:shiftwidth=4:tabstop=4: 47+/* vim:expandtab:shiftwidth=4:tabstop=4:
@@ -992,11 +991,10 @@ index 0000000..72a37fc
992+ wait_for_retrieval(clipboard, &context); 991+ wait_for_retrieval(clipboard, &context);
993+ return static_cast<gchar *>(context.data); 992+ return static_cast<gchar *>(context.data);
994+} 993+}
995diff --git a/widget/src/headless/nsClipboard.h b/widget/src/headless/nsClipboard.h 994Index: offscreen/widget/src/headless/nsClipboard.h
996new file mode 100644 995===================================================================
997index 0000000..dc690c0 996--- /dev/null 1970-01-01 00:00:00.000000000 +0000
998--- /dev/null 997+++ offscreen/widget/src/headless/nsClipboard.h 2009-06-12 14:14:05.000000000 +0100
999+++ b/widget/src/headless/nsClipboard.h
1000@@ -0,0 +1,93 @@ 998@@ -0,0 +1,93 @@
1001+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */ 999+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
1002+/* vim:expandtab:shiftwidth=4:tabstop=4: 1000+/* vim:expandtab:shiftwidth=4:tabstop=4:
@@ -1091,11 +1089,10 @@ index 0000000..dc690c0
1091+}; 1089+};
1092+ 1090+
1093+#endif /* __nsClipboard_h_ */ 1091+#endif /* __nsClipboard_h_ */
1094diff --git a/widget/src/headless/nsIImageToPixbuf.h b/widget/src/headless/nsIImageToPixbuf.h 1092Index: offscreen/widget/src/headless/nsIImageToPixbuf.h
1095new file mode 100644 1093===================================================================
1096index 0000000..1c46015 1094--- /dev/null 1970-01-01 00:00:00.000000000 +0000
1097--- /dev/null 1095+++ offscreen/widget/src/headless/nsIImageToPixbuf.h 2009-06-12 14:14:05.000000000 +0100
1098+++ b/widget/src/headless/nsIImageToPixbuf.h
1099@@ -0,0 +1,62 @@ 1096@@ -0,0 +1,62 @@
1100+/* ***** BEGIN LICENSE BLOCK ***** 1097+/* ***** BEGIN LICENSE BLOCK *****
1101+ * Version: MPL 1.1/GPL 2.0/LGPL 2.1 1098+ * Version: MPL 1.1/GPL 2.0/LGPL 2.1
@@ -1159,11 +1156,10 @@ index 0000000..1c46015
1159+NS_DEFINE_STATIC_IID_ACCESSOR(nsIImageToPixbuf, NSIIMAGETOPIXBUF_IID) 1156+NS_DEFINE_STATIC_IID_ACCESSOR(nsIImageToPixbuf, NSIIMAGETOPIXBUF_IID)
1160+ 1157+
1161+#endif 1158+#endif
1162diff --git a/widget/src/headless/nsImageToPixbuf.cpp b/widget/src/headless/nsImageToPixbuf.cpp 1159Index: offscreen/widget/src/headless/nsImageToPixbuf.cpp
1163new file mode 100644 1160===================================================================
1164index 0000000..496815c 1161--- /dev/null 1970-01-01 00:00:00.000000000 +0000
1165--- /dev/null 1162+++ offscreen/widget/src/headless/nsImageToPixbuf.cpp 2009-06-12 14:14:05.000000000 +0100
1166+++ b/widget/src/headless/nsImageToPixbuf.cpp
1167@@ -0,0 +1,196 @@ 1163@@ -0,0 +1,196 @@
1168+/* vim:set sw=4 sts=4 et cin: */ 1164+/* vim:set sw=4 sts=4 et cin: */
1169+/* ***** BEGIN LICENSE BLOCK ***** 1165+/* ***** BEGIN LICENSE BLOCK *****
@@ -1361,11 +1357,10 @@ index 0000000..496815c
1361+ 1357+
1362+ return ImgSurfaceToPixbuf(imgSurface, aWidth, aHeight); 1358+ return ImgSurfaceToPixbuf(imgSurface, aWidth, aHeight);
1363+} 1359+}
1364diff --git a/widget/src/headless/nsImageToPixbuf.h b/widget/src/headless/nsImageToPixbuf.h 1360Index: offscreen/widget/src/headless/nsImageToPixbuf.h
1365new file mode 100644 1361===================================================================
1366index 0000000..0e3f516 1362--- /dev/null 1970-01-01 00:00:00.000000000 +0000
1367--- /dev/null 1363+++ offscreen/widget/src/headless/nsImageToPixbuf.h 2009-06-12 14:14:05.000000000 +0100
1368+++ b/widget/src/headless/nsImageToPixbuf.h
1369@@ -0,0 +1,71 @@ 1364@@ -0,0 +1,71 @@
1370+/* vim:set sw=4 sts=4 et cin: */ 1365+/* vim:set sw=4 sts=4 et cin: */
1371+/* ***** BEGIN LICENSE BLOCK ***** 1366+/* ***** BEGIN LICENSE BLOCK *****
@@ -1438,10 +1433,10 @@ index 0000000..0e3f516
1438+ { 0x9e, 0x42, 0xb0, 0x5e, 0x5f, 0x06, 0x85, 0xb7 } } 1433+ { 0x9e, 0x42, 0xb0, 0x5e, 0x5f, 0x06, 0x85, 0xb7 } }
1439+ 1434+
1440+#endif 1435+#endif
1441diff --git a/widget/src/headless/nsWidgetFactory.cpp b/widget/src/headless/nsWidgetFactory.cpp 1436Index: offscreen/widget/src/headless/nsWidgetFactory.cpp
1442index eb94333..a215988 100644 1437===================================================================
1443--- a/widget/src/headless/nsWidgetFactory.cpp 1438--- offscreen.orig/widget/src/headless/nsWidgetFactory.cpp 2009-06-12 14:08:56.000000000 +0100
1444+++ b/widget/src/headless/nsWidgetFactory.cpp 1439+++ offscreen/widget/src/headless/nsWidgetFactory.cpp 2009-06-12 14:15:24.000000000 +0100
1445@@ -46,6 +46,10 @@ 1440@@ -46,6 +46,10 @@
1446 #include "nsWindow.h" 1441 #include "nsWindow.h"
1447 #include "nsTransferable.h" 1442 #include "nsTransferable.h"
@@ -1450,10 +1445,10 @@ index eb94333..a215988 100644
1450+#include "nsClipboardHelper.h" 1445+#include "nsClipboardHelper.h"
1451+#include "nsClipboard.h" 1446+#include "nsClipboard.h"
1452+#endif 1447+#endif
1453 //#include "nsFilePicker.h"
1454 #include "nsSound.h" 1448 #include "nsSound.h"
1455 #include "nsBidiKeyboard.h" 1449 #include "nsBidiKeyboard.h"
1456@@ -74,6 +78,10 @@ NS_GENERIC_FACTORY_CONSTRUCTOR(nsLookAndFeel) 1450 #include "nsScreenManagerHeadless.h"
1451@@ -66,6 +70,10 @@
1457 NS_GENERIC_FACTORY_CONSTRUCTOR(nsTransferable) 1452 NS_GENERIC_FACTORY_CONSTRUCTOR(nsTransferable)
1458 NS_GENERIC_FACTORY_CONSTRUCTOR(nsBidiKeyboard) 1453 NS_GENERIC_FACTORY_CONSTRUCTOR(nsBidiKeyboard)
1459 NS_GENERIC_FACTORY_CONSTRUCTOR(nsHTMLFormatConverter) 1454 NS_GENERIC_FACTORY_CONSTRUCTOR(nsHTMLFormatConverter)
@@ -1464,7 +1459,7 @@ index eb94333..a215988 100644
1464 NS_GENERIC_FACTORY_CONSTRUCTOR(nsSound) 1459 NS_GENERIC_FACTORY_CONSTRUCTOR(nsSound)
1465 NS_GENERIC_FACTORY_CONSTRUCTOR(nsScreenManagerHeadless) 1460 NS_GENERIC_FACTORY_CONSTRUCTOR(nsScreenManagerHeadless)
1466 //NS_GENERIC_FACTORY_CONSTRUCTOR(nsImageToPixbuf) 1461 //NS_GENERIC_FACTORY_CONSTRUCTOR(nsImageToPixbuf)
1467@@ -189,6 +197,16 @@ static const nsModuleComponentInfo components[] = 1462@@ -142,6 +150,16 @@
1468 NS_TRANSFERABLE_CID, 1463 NS_TRANSFERABLE_CID,
1469 "@mozilla.org/widget/transferable;1", 1464 "@mozilla.org/widget/transferable;1",
1470 nsTransferableConstructor }, 1465 nsTransferableConstructor },
@@ -1481,6 +1476,3 @@ index eb94333..a215988 100644
1481 { "HTML Format Converter", 1476 { "HTML Format Converter",
1482 NS_HTMLFORMATCONVERTER_CID, 1477 NS_HTMLFORMATCONVERTER_CID,
1483 "@mozilla.org/widget/htmlformatconverter;1", 1478 "@mozilla.org/widget/htmlformatconverter;1",
1484--
14851.6.0.4
1486