diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/modutils/modutils_2.4.27.bb | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/modutils/modutils_2.4.27.bb')
-rw-r--r-- | meta/packages/modutils/modutils_2.4.27.bb | 88 |
1 files changed, 88 insertions, 0 deletions
diff --git a/meta/packages/modutils/modutils_2.4.27.bb b/meta/packages/modutils/modutils_2.4.27.bb new file mode 100644 index 0000000000..56420f7de0 --- /dev/null +++ b/meta/packages/modutils/modutils_2.4.27.bb | |||
@@ -0,0 +1,88 @@ | |||
1 | SECTION = "base" | ||
2 | DESCRIPTION = "These utilities are intended to make a Linux modular kernel \ | ||
3 | manageable for all users, administrators and distribution maintainers." | ||
4 | LICENSE = "GPLv2" | ||
5 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/files" | ||
6 | PR = "r7" | ||
7 | |||
8 | SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/modutils/v2.4/modutils-${PV}.tar.bz2 \ | ||
9 | file://lex.l.diff;patch=1 \ | ||
10 | file://modutils-notest.patch;patch=1 \ | ||
11 | file://configure.patch;patch=1 \ | ||
12 | file://program_prefix.patch;patch=1 \ | ||
13 | file://armeb.patch;patch=1 \ | ||
14 | file://gcc4.patch;patch=1" | ||
15 | |||
16 | inherit autotools | ||
17 | |||
18 | # modutils go in /sbin | ||
19 | sbindir = "/sbin" | ||
20 | EXTRA_OECONF = "--disable-strip" | ||
21 | export BUILDCC = "${BUILD_CC}" | ||
22 | export BUILDCFLAGS = "${BUILD_CFLAGS}" | ||
23 | |||
24 | do_install () { | ||
25 | oe_runmake 'DESTDIR=${D}' install | ||
26 | install -d ${D}${sysconfdir} | ||
27 | rm ${D}${base_sbindir}/lsmod | ||
28 | install -d ${D}${base_bindir}/ | ||
29 | ln -s ../sbin/insmod ${D}${base_bindir}/lsmod | ||
30 | for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do mv ${D}/$f ${D}/$f.24 | ||
31 | done | ||
32 | } | ||
33 | |||
34 | pkg_postinst_modutils () { | ||
35 | #!/bin/sh | ||
36 | for f in sbin/insmod sbin/modprobe sbin/rmmod bin/lsmod; do | ||
37 | bn=`basename $f` | ||
38 | update-alternatives --install /$f $bn /$f.24 10 | ||
39 | done | ||
40 | if test -n "$D"; then | ||
41 | D="-r $D" | ||
42 | if test -n "`which ${TARGET_PREFIX}depmod-2.4`"; then | ||
43 | for kerneldir in `ls -p ${IMAGE_ROOTFS}/lib/modules|grep /`; do | ||
44 | kernelver=`basename $kerneldir` | ||
45 | ${TARGET_PREFIX}depmod-2.4 -a -b ${IMAGE_ROOTFS} -C ${IMAGE_ROOTFS}/${sysconfdir}/modules.conf -r $kernelver | ||
46 | done | ||
47 | fi | ||
48 | fi | ||
49 | update-rc.d $D modutils.sh start 20 S . | ||
50 | } | ||
51 | |||
52 | pkg_prerm_modutils () { | ||
53 | #!/bin/sh | ||
54 | for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do | ||
55 | bn=`basename $f` | ||
56 | update-alternatives --remove $bn /$f.24 | ||
57 | done | ||
58 | if test -n "$D"; then | ||
59 | D="-r $D" | ||
60 | fi | ||
61 | update-rc.d $D modutils.sh remove | ||
62 | } | ||
63 | |||
64 | pkg_postinst_modutils-depmod() { | ||
65 | #!/bin/sh | ||
66 | update-alternatives --install /sbin/depmod depmod /sbin/depmod.24 10 | ||
67 | } | ||
68 | |||
69 | pkg_postinst_modutils-modinfo() { | ||
70 | #!/bin/sh | ||
71 | update-alternatives --install /sbin/modinfo modinfo /sbin/modinfo.24 10 | ||
72 | } | ||
73 | |||
74 | pkg_prerm_modutils-depmod() { | ||
75 | #!/bin/sh | ||
76 | update-alternatives --remove depmod /sbin/depmod.24 | ||
77 | } | ||
78 | |||
79 | pkg_prerm_modutils-modinfo() { | ||
80 | #!/bin/sh | ||
81 | update-alternatives --remove modinfo /sbin/modinfo.24 | ||
82 | } | ||
83 | |||
84 | PACKAGES = "modutils-depmod modutils-modinfo modutils-doc modutils" | ||
85 | |||
86 | FILES_modutils-depmod = "sbin/depmod.24" | ||
87 | FILES_modutils-modinfo = "sbin/modinfo.24" | ||
88 | RDEPENDS_modutils = "modutils-depmod" | ||