diff options
author | Kevin Tian <kevin.tian@intel.com> | 2010-07-21 13:21:49 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-21 21:44:37 +0100 |
commit | b376a803cac9c6403ce7ddf2a4a479292ec9ba85 (patch) | |
tree | b642f0fbe43e030348858dde2c564b970d88d2d1 /meta/packages/module-init-tools/files | |
parent | 8a251accbfd68078fbab23a96411b76928cf1063 (diff) | |
download | poky-b376a803cac9c6403ce7ddf2a4a479292ec9ba85.tar.gz |
module-init-tools: upgrade to 3.12
[Patches]
KEEP _ignore_arch_directory_: ignore /etc/modprobe.d/arch, not sure reason now.
keep it and to be verified later
REMOVE _module-init-tools-remove-index.patch_: in upstream
NEW _disable_man.patch_: a simpler patch to replace below removed two
REMOVE _manpagesopt_: due to above new patch
REMOVE _no_man_rebuild_: ditto
KEEP _modutils_extension_: poky has its own name convention and thus need such knowledge
in code
[Recipe]
- adjust indention
- remove some old lines like ${S} and EXTRA_OECONF
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/module-init-tools/files')
9 files changed, 83 insertions, 160 deletions
diff --git a/meta/packages/module-init-tools/files/disable_man.patch b/meta/packages/module-init-tools/files/disable_man.patch new file mode 100644 index 0000000000..daf58248b1 --- /dev/null +++ b/meta/packages/module-init-tools/files/disable_man.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | # disable man page build | ||
2 | # | ||
3 | # by Kevin Tian <kevin.tian@intel.com>, 2010-07-21 | ||
4 | |||
5 | diff --git a/Makefile.am b/Makefile.am | ||
6 | index 6f83c12..32972a8 100644 | ||
7 | --- a/Makefile.am | ||
8 | +++ b/Makefile.am | ||
9 | @@ -39,13 +39,12 @@ modindex_LDADD = $(LDADD) libmodtools.a | ||
10 | MAN5 = modprobe.conf.5 modules.dep.5 depmod.conf.5 modprobe.d.5 | ||
11 | MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8 | ||
12 | SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml)) | ||
13 | -dist_man_MANS = $(MAN5) $(MAN8) | ||
14 | # If they haven't overridden mandir, fix it (never /man!) | ||
15 | mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi) | ||
16 | |||
17 | TESTSUITE := $(shell test -e @srcdir@/tests && find @srcdir@/tests -type f ! -name '*~') | ||
18 | |||
19 | -EXTRA_DIST = generate-modprobe.conf FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE) | ||
20 | +EXTRA_DIST = generate-modprobe.conf FAQ CODING stress_modules.sh install-with-care | ||
21 | |||
22 | sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo | ||
23 | if BUILD_STATIC_UTILS | ||
diff --git a/meta/packages/module-init-tools/files/ignore_arch_directory b/meta/packages/module-init-tools/files/ignore_arch_directory deleted file mode 100644 index 185ea7a3a5..0000000000 --- a/meta/packages/module-init-tools/files/ignore_arch_directory +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8 | ||
2 | --- module-init-tools-3.2-pre7/modprobe.8.orig 2005-07-05 13:52:32.000000000 +0200 | ||
3 | +++ module-init-tools-3.2-pre7/modprobe.8 2005-07-05 13:52:42.000000000 +0200 | ||
4 | @@ -31,6 +31,7 @@ | ||
5 | \fI/etc/modprobe.conf\fR configuration file and | ||
6 | \fI/etc/modprobe.d\fR directory | ||
7 | (see \fBmodprobe.conf\fR(5)). | ||
8 | +All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored. | ||
9 | .PP | ||
10 | Note that this version of \fBmodprobe\fR does not | ||
11 | do anything to the module itself: the work of resolving symbols | ||
12 | --- module-init-tools-3.2-pre7/modprobe.c.orig 2005-07-05 13:50:00.000000000 +0200 | ||
13 | +++ module-init-tools-3.2-pre7/modprobe.c 2005-07-05 13:50:15.000000000 +0200 | ||
14 | @@ -1158,6 +1158,10 @@ | ||
15 | DIR *dir; | ||
16 | int ret = 0; | ||
17 | |||
18 | + /* ignore everything in this directory */ | ||
19 | + if (streq(filename, "/etc/modprobe.d/arch")) | ||
20 | + return 1; | ||
21 | + | ||
22 | /* Reiser4 has file/directory duality: treat it as both. */ | ||
23 | dir = opendir(filename); | ||
24 | if (dir) { | ||
diff --git a/meta/packages/module-init-tools/files/ignore_arch_directory.patch b/meta/packages/module-init-tools/files/ignore_arch_directory.patch new file mode 100644 index 0000000000..7b30824802 --- /dev/null +++ b/meta/packages/module-init-tools/files/ignore_arch_directory.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | # not sure the reason yet. Keep for a while and verify later. | ||
2 | # | ||
3 | # comments added by Kevin Tian <kevin.tian@intel.com>, 2010-07-21 | ||
4 | |||
5 | diff -ruN module-init-tools-3.12.orig/modprobe.8 module-init-tools-3.12/modprobe.8 | ||
6 | --- module-init-tools-3.12/modprobe.8.orig | ||
7 | +++ module-init-tools-3.12/modprobe.8 | ||
8 | @@ -27,6 +27,7 @@ | ||
9 | (see \fBmodprobe.conf\fR(5)). \fBmodprobe\fR will also use module | ||
10 | options specified on the kernel command line in the form of | ||
11 | <module>\&.<option>\&. | ||
12 | +All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored. | ||
13 | .PP | ||
14 | Note that unlike in 2.4 series Linux kernels (which are not supported | ||
15 | by this tool) this version of \fBmodprobe\fR does not | ||
16 | --- module-init-tools-3.12/modprobe.c.orig | ||
17 | +++ module-init-tools-3.12/modprobe.c | ||
18 | @@ -1052,6 +1052,10 @@ | ||
19 | DIR *dir; | ||
20 | int ret = 0; | ||
21 | |||
22 | + /* ignore everything in this directory */ | ||
23 | + if (streq(filename, "/etc/modprobe.d/arch")) | ||
24 | + return 1; | ||
25 | + | ||
26 | dir = opendir(filename); | ||
27 | if (dir) { | ||
28 | struct file_entry { | ||
diff --git a/meta/packages/module-init-tools/files/manpagesopt b/meta/packages/module-init-tools/files/manpagesopt deleted file mode 100644 index 5d5cac609e..0000000000 --- a/meta/packages/module-init-tools/files/manpagesopt +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | Index: module-init-tools-3.2-pre9/configure.in | ||
2 | =================================================================== | ||
3 | --- module-init-tools-3.2-pre9.orig/configure.in 2005-08-09 04:31:26.000000000 +0000 | ||
4 | +++ module-init-tools-3.2-pre9/configure.in 2005-09-20 22:06:10.000000000 +0000 | ||
5 | @@ -41,5 +41,14 @@ | ||
6 | fi]) | ||
7 | AC_SUBST(MODULE_DIR) | ||
8 | |||
9 | -AC_OUTPUT([Makefile]) | ||
10 | +AC_ARG_ENABLE(manpages, | ||
11 | +[ --disable-manpages Disable man page generation.], | ||
12 | +[if test x"$enableval" != x"no"; then | ||
13 | + enable_manpages=yes | ||
14 | +else | ||
15 | + enable_manpages=no | ||
16 | +fi], | ||
17 | +[enable_manpages=yes]) | ||
18 | +AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes") | ||
19 | |||
20 | +AC_OUTPUT([Makefile]) | ||
21 | Index: module-init-tools-3.2-pre9/Makefile.am | ||
22 | =================================================================== | ||
23 | --- module-init-tools-3.2-pre9.orig/Makefile.am 2005-08-09 04:54:28.000000000 +0000 | ||
24 | +++ module-init-tools-3.2-pre9/Makefile.am 2005-09-20 22:09:03.000000000 +0000 | ||
25 | @@ -21,13 +21,14 @@ | ||
26 | MAN5 = modprobe.conf.5 modules.dep.5 | ||
27 | MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8 | ||
28 | SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml)) | ||
29 | -man_MANS = $(MAN5) $(MAN8) | ||
30 | # If they haven't overridden mandir, fix it (never /man!) | ||
31 | mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi) | ||
32 | |||
33 | TESTSUITE := $(shell find tests -type f ! -name '*~') tests/vg-suppressions | ||
34 | |||
35 | -EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE) | ||
36 | +if MANPAGES | ||
37 | +man_MANS = $(MAN5) $(MAN8) | ||
38 | +endif | ||
39 | |||
40 | sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static | ||
41 | bin_PROGRAMS = lsmod | ||
diff --git a/meta/packages/module-init-tools/files/module-init-tools-remove-index.patch b/meta/packages/module-init-tools/files/module-init-tools-remove-index.patch deleted file mode 100644 index c56532e007..0000000000 --- a/meta/packages/module-init-tools/files/module-init-tools-remove-index.patch +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | http://uclibc.org/cgi-bin/viewcvs.cgi/trunk/buildroot/package/module-init-tools/module-init-tools-remove-index.patch?rev=16782&view=auto | ||
2 | |||
3 | diff -ur module-init-tools-3.2.2/modprobe.c module-init-tools-3.2.2-patched/modprobe.c | ||
4 | --- module-init-tools-3.2.2/modprobe.c 2005-12-01 17:42:09.000000000 -0600 | ||
5 | +++ module-init-tools-3.2.2-patched/modprobe.c 2006-12-04 19:50:50.353237649 -0600 | ||
6 | @@ -270,7 +270,7 @@ | ||
7 | char *modname; | ||
8 | |||
9 | /* Ignore lines without : or which start with a # */ | ||
10 | - ptr = index(line, ':'); | ||
11 | + ptr = strchr(line, ':'); | ||
12 | if (ptr == NULL || line[strspn(line, "\t ")] == '#') | ||
13 | return 0; | ||
14 | |||
diff --git a/meta/packages/module-init-tools/files/modutils_extension b/meta/packages/module-init-tools/files/modutils_extension deleted file mode 100644 index fd84ca2550..0000000000 --- a/meta/packages/module-init-tools/files/modutils_extension +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | --- module-init-tools-3.0-pre10.orig/depmod.c | ||
2 | +++ module-init-tools-3.0-pre10/depmod.c | ||
3 | @@ -217,13 +217,13 @@ | ||
4 | { | ||
5 | char *sep; | ||
6 | char pathname[strlen(argv[0])+1]; | ||
7 | - char oldname[strlen("depmod") + strlen(argv[0]) + sizeof(".old")]; | ||
8 | + char oldname[strlen("depmod") + strlen(argv[0]) + sizeof(".24")]; | ||
9 | |||
10 | memset(pathname, 0, strlen(argv[0])+1); | ||
11 | sep = strrchr(argv[0], '/'); | ||
12 | if (sep) | ||
13 | memcpy(pathname, argv[0], sep - argv[0]+1); | ||
14 | - sprintf(oldname, "%s%s.old", pathname, "depmod"); | ||
15 | + sprintf(oldname, "%s%s.24", pathname, "depmod"); | ||
16 | |||
17 | /* Recursion detection: we need an env var since we can't | ||
18 | change argv[0] (as older modutils uses it to determine | ||
19 | --- module-init-tools-3.0-pre10.orig/backwards_compat.c | ||
20 | +++ module-init-tools-3.0-pre10/backwards_compat.c | ||
21 | @@ -21,13 +21,13 @@ | ||
22 | pid_t pid; | ||
23 | char ascii_pid[32]; | ||
24 | char pathname[strlen(argv[0])+1]; | ||
25 | - char oldname[strlen(progname) + strlen(argv[0]) + sizeof(".old")]; | ||
26 | + char oldname[strlen(progname) + strlen(argv[0]) + sizeof(".24")]; | ||
27 | |||
28 | memset(pathname, 0, strlen(argv[0])+1); | ||
29 | sep = strrchr(argv[0], '/'); | ||
30 | if (sep) | ||
31 | memcpy(pathname, argv[0], sep - argv[0]+1); | ||
32 | - sprintf(oldname, "%s%s.old", pathname, progname); | ||
33 | + sprintf(oldname, "%s%s.24", pathname, progname); | ||
34 | |||
35 | /* Recursion detection: we need an env var since we can't | ||
36 | change argv[0] (as older modutils uses it to determine | ||
37 | --- module-init-tools-3.0-pre10.orig/generate-modprobe.conf | ||
38 | +++ module-init-tools-3.0-pre10/generate-modprobe.conf | ||
39 | @@ -26,12 +26,12 @@ | ||
40 | cp $TESTING_MODPROBE_CONF $MODPROBECONF | ||
41 | elif [ "$STDIN" = "1" ]; then | ||
42 | cat > $MODPROBECONF | ||
43 | -elif [ -x /sbin/modprobe.old ]; then | ||
44 | +elif [ -x /sbin/modprobe.24 ]; then | ||
45 | # In sbin. | ||
46 | - /sbin/modprobe.old -c > $MODPROBECONF | ||
47 | -elif modprobe.old -c >/dev/null 2>&1; then | ||
48 | + /sbin/modprobe.24 -c > $MODPROBECONF | ||
49 | +elif modprobe.24 -c >/dev/null 2>&1; then | ||
50 | # Somewhere in path. | ||
51 | - modprobe.old -c > $MODPROBECONF | ||
52 | + modprobe.24 -c > $MODPROBECONF | ||
53 | elif /sbin/modprobe -V 2>/dev/null | grep -q 'modprobe version'; then | ||
54 | # Running /sbin/modprobe gives old version. | ||
55 | /sbin/modprobe -c > $MODPROBECONF | ||
diff --git a/meta/packages/module-init-tools/files/modutils_extension.patch b/meta/packages/module-init-tools/files/modutils_extension.patch new file mode 100644 index 0000000000..128c9531a1 --- /dev/null +++ b/meta/packages/module-init-tools/files/modutils_extension.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | # poky uses new name to differentiate from modutils, so reflect this new name in source | ||
2 | # | ||
3 | # comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-21 | ||
4 | --- module-init-tools-3.0-pre10.orig/generate-modprobe.conf | ||
5 | +++ module-init-tools-3.0-pre10/generate-modprobe.conf | ||
6 | @@ -45,12 +45,12 @@ | ||
7 | cp $TESTING_MODPROBE_CONF $MODPROBECONF | ||
8 | elif [ "$STDIN" = "1" ]; then | ||
9 | cat > $MODPROBECONF | ||
10 | -elif [ -x /sbin/modprobe.old ]; then | ||
11 | +elif [ -x /sbin/modprobe.24 ]; then | ||
12 | # In sbin. | ||
13 | - /sbin/modprobe.old -c > $MODPROBECONF || modprobe_abort | ||
14 | -elif modprobe.old -c >/dev/null 2>&1; then | ||
15 | + /sbin/modprobe.24 -c > $MODPROBECONF || modprobe_abort | ||
16 | +elif modprobe.24 -c >/dev/null 2>&1; then | ||
17 | # Somewhere in path. | ||
18 | - modprobe.old -c > $MODPROBECONF || modprobe_abort | ||
19 | + modprobe.24 -c > $MODPROBECONF || modprobe_abort | ||
20 | elif /sbin/modprobe -V 2>/dev/null | grep -q 'modprobe version'; then | ||
21 | # Running /sbin/modprobe gives old version. | ||
22 | /sbin/modprobe -c > $MODPROBECONF || modprobe_abort | ||
diff --git a/meta/packages/module-init-tools/files/no-static-binaries.patch b/meta/packages/module-init-tools/files/no-static-binaries.patch index a9fbb27bf6..ca83ec0755 100644 --- a/meta/packages/module-init-tools/files/no-static-binaries.patch +++ b/meta/packages/module-init-tools/files/no-static-binaries.patch | |||
@@ -3,25 +3,21 @@ | |||
3 | # so this patch just removes it. | 3 | # so this patch just removes it. |
4 | # | 4 | # |
5 | # - jdike@linux.intel.com | 5 | # - jdike@linux.intel.com |
6 | # | ||
7 | # Change to a simpler method by just disabling static link flag, since even | ||
8 | # removing those lines don't prevent insmod.static from compile | ||
9 | # | ||
10 | # by Kevin Tian <kevin.tian@intel.com>, 2010-07-21 | ||
6 | 11 | ||
7 | Index: module-init-tools-3.2.2/Makefile.am | 12 | Index: module-init-tools-3.2.2/Makefile.am |
8 | =================================================================== | 13 | =================================================================== |
9 | --- module-init-tools-3.2.2.orig/Makefile.am 2010-05-26 15:43:16.000000000 -0400 | 14 | --- module-init-tools-3.2.2.orig/Makefile.am 2010-05-26 15:43:16.000000000 -0400 |
10 | +++ module-init-tools-3.2.2/Makefile.am 2010-05-26 16:04:06.232990785 -0400 | 15 | +++ module-init-tools-3.2.2/Makefile.am 2010-05-26 16:04:06.232990785 -0400 |
11 | @@ -5,16 +5,10 @@ rmmod_SOURCES = rmmod.c testing.h | 16 | @@ -10,7 +10,6 @@ |
12 | depmod_SOURCES = depmod.c moduleops.c tables.c zlibsupport.c depmod.h moduleops.h tables.h list.h testing.h zlibsupport.h | 17 | modindex_SOURCES = modindex.c zlibsupport.c zlibsupport.h testing.h |
13 | modinfo_SOURCES = modinfo.c zlibsupport.c testing.h zlibsupport.h | ||
14 | 18 | ||
15 | -insmod_static_SOURCES = insmod.c | 19 | insmod_static_SOURCES = insmod.c |
16 | -insmod_static_LDFLAGS = -static | 20 | -insmod_static_LDFLAGS = -static |
17 | -# We don't want the $(zlib_flags) here: that makes a dynamic executable | 21 | # We don't want the $(zlib_flags) here: that makes a dynamic executable |
18 | -insmod_static_LDADD = | 22 | insmod_static_LDADD = libmodtools.a |
19 | - | ||
20 | EXTRA_insmod_SOURCES = backwards_compat.c | ||
21 | EXTRA_lsmod_SOURCES = backwards_compat.c | ||
22 | EXTRA_modprobe_SOURCES = backwards_compat.c | ||
23 | EXTRA_rmmod_SOURCES = backwards_compat.c | ||
24 | -EXTRA_insmod_static_SOURCES = backwards_compat.c | ||
25 | EXTRA_depmod_SOURCES = moduleops_core.c | ||
26 | EXTRA_modinfo_SOURCES = backwards_compat.c | ||
27 | 23 | ||
diff --git a/meta/packages/module-init-tools/files/no_man_rebuild b/meta/packages/module-init-tools/files/no_man_rebuild deleted file mode 100644 index d38866aece..0000000000 --- a/meta/packages/module-init-tools/files/no_man_rebuild +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | diff -ruN module-init-tools-3.1.orig/Makefile.in module-init-tools-3.1/Makefile.in | ||
2 | --- module-init-tools-3.1.orig/Makefile.in 2004-11-15 01:59:48.000000000 +0100 | ||
3 | +++ module-init-tools-3.1/Makefile.in 2004-11-21 02:18:58.000000000 +0100 | ||
4 | @@ -613,7 +613,7 @@ | ||
5 | check-am: all-am | ||
6 | $(MAKE) $(AM_MAKEFLAGS) check-TESTS | ||
7 | check: check-am | ||
8 | -all-am: Makefile $(PROGRAMS) $(SCRIPTS) $(MANS) | ||
9 | +all-am: Makefile $(PROGRAMS) $(SCRIPTS) #$(MANS) | ||
10 | |||
11 | installdirs: | ||
12 | $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(sbindir) $(DESTDIR)$(sbindir) $(DESTDIR)$(man5dir) $(DESTDIR)$(man8dir) | ||