summaryrefslogtreecommitdiffstats
path: root/meta/packages/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-11-12 11:06:34 +0000
committerRichard Purdie <richard@openedhand.com>2007-11-12 11:06:34 +0000
commit0e09147de182aeb96cff9ff59211b3d907ba83f7 (patch)
tree004da019bcbfcd9e2325f1855877eca18fc56587 /meta/packages/meta
parent19f1bad37806b5e0b4d971d09226eda51345c9d2 (diff)
downloadpoky-0e09147de182aeb96cff9ff59211b3d907ba83f7.tar.gz
Remove hardcoded staging layout assumptions
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3116 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/meta')
-rw-r--r--meta/packages/meta/external-poky-toolchain.bb4
-rw-r--r--meta/packages/meta/meta-toolchain.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/packages/meta/external-poky-toolchain.bb b/meta/packages/meta/external-poky-toolchain.bb
index 87c1ba4145..f26e5761f2 100644
--- a/meta/packages/meta/external-poky-toolchain.bb
+++ b/meta/packages/meta/external-poky-toolchain.bb
@@ -28,11 +28,11 @@ do_stage() {
28 install -d ${DEPLOY_DIR}/ipk/ 28 install -d ${DEPLOY_DIR}/ipk/
29 install -d ${STAGING_DIR}/pkgdata/ 29 install -d ${STAGING_DIR}/pkgdata/
30 install -d ${STAGING_DIR}/pkgmaps/ 30 install -d ${STAGING_DIR}/pkgmaps/
31 install -d ${STAGING_DIR}/${TARGET_SYS}/shlibs/ 31 install -d ${STAGING_DIR_TARGET}/shlibs/
32 32
33 cp -ar ${prefix}/ipk/* ${DEPLOY_DIR}/ipk/ 33 cp -ar ${prefix}/ipk/* ${DEPLOY_DIR}/ipk/
34 cp -ar ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/ 34 cp -ar ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/
35 cp -ar ${prefix}/pkgmaps/* ${STAGING_DIR}/pkgmaps/ 35 cp -ar ${prefix}/pkgmaps/* ${STAGING_DIR}/pkgmaps/
36 cp -ar ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR}/${TARGET_SYS}/shlibs/ 36 cp -ar ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR_TARGET}/shlibs/
37} 37}
38 38
diff --git a/meta/packages/meta/meta-toolchain.bb b/meta/packages/meta/meta-toolchain.bb
index 16e48a0c56..b6705e0a53 100644
--- a/meta/packages/meta/meta-toolchain.bb
+++ b/meta/packages/meta/meta-toolchain.bb
@@ -91,8 +91,8 @@ do_populate_sdk() {
91 if [ -e ${STAGING_DIR}/pkgmaps/debian/$subpkg ]; then 91 if [ -e ${STAGING_DIR}/pkgmaps/debian/$subpkg ]; then
92 cp ${STAGING_DIR}/pkgmaps/debian/$subpkg ${SDK_OUTPUT}/${prefix}/pkgmaps/debian/ 92 cp ${STAGING_DIR}/pkgmaps/debian/$subpkg ${SDK_OUTPUT}/${prefix}/pkgmaps/debian/
93 fi 93 fi
94 if [ -e ${STAGING_DIR}/${TARGET_SYS}/shlibs/$subpkg.list ]; then 94 if [ -e ${STAGING_DIR_TARGET}/shlibs/$subpkg.list ]; then
95 cp ${STAGING_DIR}/${TARGET_SYS}/shlibs/$subpkg.* ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/shlibs/ 95 cp ${STAGING_DIR_TARGET}/shlibs/$subpkg.* ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/shlibs/
96 fi 96 fi
97 done 97 done
98 break 98 break