diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-03-17 13:19:35 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-03-17 13:19:35 +0000 |
commit | 7177c20ad7d2f79a6979476696a1941efa6c3566 (patch) | |
tree | 5a313921972c0118b0dd0864e9eeeff1cbde07aa /meta/packages/meta/meta-toolchain.bb | |
parent | c00661591a921f28b0a697b3dcfe2f34877bf528 (diff) | |
download | poky-7177c20ad7d2f79a6979476696a1941efa6c3566.tar.gz |
meta-toolchain: switched to opkg
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4031 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/meta/meta-toolchain.bb')
-rw-r--r-- | meta/packages/meta/meta-toolchain.bb | 18 |
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/packages/meta/meta-toolchain.bb b/meta/packages/meta/meta-toolchain.bb index bf9b5765de..7ae0138458 100644 --- a/meta/packages/meta/meta-toolchain.bb +++ b/meta/packages/meta/meta-toolchain.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | DESCRIPTION = "Meta package for building a installable toolchain" | 1 | DESCRIPTION = "Meta package for building a installable toolchain" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | DEPENDS = "ipkg-native ipkg-utils-native fakeroot-native sed-native" | 3 | DEPENDS = "opkg-native ipkg-utils-native fakeroot-native sed-native" |
4 | 4 | ||
5 | inherit sdk meta | 5 | inherit sdk meta |
6 | 6 | ||
@@ -9,8 +9,8 @@ SDK_OUTPUT = "${SDK_DIR}/image" | |||
9 | SDK_OUTPUT2 = "${SDK_DIR}/image-extras" | 9 | SDK_OUTPUT2 = "${SDK_DIR}/image-extras" |
10 | SDK_DEPLOY = "${TMPDIR}/deploy/sdk" | 10 | SDK_DEPLOY = "${TMPDIR}/deploy/sdk" |
11 | 11 | ||
12 | IPKG_HOST = "ipkg-cl -f ${IPKGCONF_SDK} -o ${SDK_OUTPUT}" | 12 | IPKG_HOST = "opkg-cl -f ${IPKGCONF_SDK} -o ${SDK_OUTPUT}" |
13 | IPKG_TARGET = "ipkg-cl -f ${IPKGCONF_TARGET} -o ${SDK_OUTPUT}/${SDK_PREFIX}/${TARGET_SYS}" | 13 | IPKG_TARGET = "opkg-cl -f ${IPKGCONF_TARGET} -o ${SDK_OUTPUT}/${SDK_PREFIX}/${TARGET_SYS}" |
14 | 14 | ||
15 | TOOLCHAIN_HOST_TASK ?= "task-sdk-host" | 15 | TOOLCHAIN_HOST_TASK ?= "task-sdk-host" |
16 | TOOLCHAIN_TARGET_TASK ?= "task-poky-standalone-sdk-target task-poky-standalone-sdk-target-dbg" | 16 | TOOLCHAIN_TARGET_TASK ?= "task-poky-standalone-sdk-target task-poky-standalone-sdk-target-dbg" |
@@ -30,14 +30,14 @@ do_populate_sdk() { | |||
30 | done | 30 | done |
31 | 31 | ||
32 | ${IPKG_HOST} update | 32 | ${IPKG_HOST} update |
33 | ${IPKG_HOST} install ${TOOLCHAIN_HOST_TASK} ipkg-sdk | 33 | ${IPKG_HOST} install ${TOOLCHAIN_HOST_TASK} |
34 | 34 | ||
35 | ${IPKG_TARGET} update | 35 | ${IPKG_TARGET} update |
36 | ${IPKG_TARGET} install ${TOOLCHAIN_TARGET_TASK} | 36 | ${IPKG_TARGET} install ${TOOLCHAIN_TARGET_TASK} |
37 | 37 | ||
38 | install -d ${SDK_OUTPUT}/${prefix}/usr/lib/ipkg | 38 | install -d ${SDK_OUTPUT}/${prefix}/usr/lib/opkg |
39 | mv ${SDK_OUTPUT}/usr/lib/ipkg/* ${SDK_OUTPUT}/${prefix}/usr/lib/ipkg/ | 39 | mv ${SDK_OUTPUT}/usr/lib/opkg/* ${SDK_OUTPUT}/${prefix}/usr/lib/opkg/ |
40 | #rm -Rf ${SDK_OUTPUT}/usr/lib | 40 | rm -Rf ${SDK_OUTPUT}/usr/lib |
41 | 41 | ||
42 | install -d ${SDK_OUTPUT}/${sysconfdir} | 42 | install -d ${SDK_OUTPUT}/${sysconfdir} |
43 | install -m 0644 ${IPKGCONF_TARGET} ${IPKGCONF_SDK} ${SDK_OUTPUT}/${sysconfdir} | 43 | install -m 0644 ${IPKGCONF_TARGET} ${IPKGCONF_SDK} ${SDK_OUTPUT}/${sysconfdir} |
@@ -89,8 +89,8 @@ do_populate_sdk() { | |||
89 | echo 'export PKG_CONFIG_SYSROOT_DIR=${prefix}/${TARGET_SYS}' >> $script | 89 | echo 'export PKG_CONFIG_SYSROOT_DIR=${prefix}/${TARGET_SYS}' >> $script |
90 | echo 'export PKG_CONFIG_PATH=${prefix}/${TARGET_SYS}/lib/pkgconfig' >> $script | 90 | echo 'export PKG_CONFIG_PATH=${prefix}/${TARGET_SYS}/lib/pkgconfig' >> $script |
91 | echo 'export CONFIG_SITE=${prefix}/site-config' >> $script | 91 | echo 'export CONFIG_SITE=${prefix}/site-config' >> $script |
92 | echo "alias ipkg='LD_LIBRARY_PATH=${prefix}/lib ${prefix}/bin/ipkg-cl -f ${sysconfdir}/ipkg-sdk.conf -o ${prefix}'" >> $script | 92 | echo "alias opkg='LD_LIBRARY_PATH=${prefix}/lib ${prefix}/bin/opkg-cl -f ${sysconfdir}/ipkg-sdk.conf -o ${prefix}'" >> $script |
93 | echo "alias ipkg-target='LD_LIBRARY_PATH=${prefix}/lib ${prefix}/bin/ipkg-cl -f ${sysconfdir}/ipkg.conf -o ${prefix}/${TARGET_SYS}'" >> $script | 93 | echo "alias opkg-target='LD_LIBRARY_PATH=${prefix}/lib ${prefix}/bin/opkg-cl -f ${sysconfdir}/ipkg.conf -o ${prefix}/${TARGET_SYS}'" >> $script |
94 | 94 | ||
95 | # Add version information | 95 | # Add version information |
96 | versionfile=${SDK_OUTPUT}/${prefix}/version | 96 | versionfile=${SDK_OUTPUT}/${prefix}/version |