summaryrefslogtreecommitdiffstats
path: root/meta/packages/mesa
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-04-14 12:50:32 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-04-14 12:50:32 +0100
commit25dc55da0991f0e1ced12f317703ce23e5d04d3b (patch)
tree69ab3ecde58b35bb9d5acc985d0409dd7be5efc8 /meta/packages/mesa
parent7d5759aa4429c626e66f65e8e0807a999d324e6f (diff)
downloadpoky-25dc55da0991f0e1ced12f317703ce23e5d04d3b.tar.gz
mesa: Drop stale files
Diffstat (limited to 'meta/packages/mesa')
-rw-r--r--meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch30
-rw-r--r--meta/packages/mesa/mesa-7.0.2/mklib-rpath-link.patch23
2 files changed, 0 insertions, 53 deletions
diff --git a/meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch b/meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch
deleted file mode 100644
index d24d03d379..0000000000
--- a/meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1--- /src/mesa/x86/orig-Makefile 2005-07-01 04:54:38.000000000 +0300
2+++ /src/mesa/x86/Makefile 2007-06-07 21:52:31.000000000 +0300
3@@ -5,6 +5,7 @@
4
5
6 INCLUDE_DIRS = \
7+ -I/usr/include \
8 -I$(TOP)/include/GL \
9 -I$(TOP)/include \
10 -I.. \
11@@ -13,6 +14,10 @@
12 -I../glapi \
13 -I../tnl
14
15+OPT_FLAGS_host = -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os
16+
17+CFLAGS_host = -Wall -Wmissing-prototypes $(OPT_FLAGS_host) $(PIC_FLAGS) $(ARCH_FLAGS) \
18+ $(DEFINES) $(ASM_FLAGS) $(X11_INCLUDES) -std=c99 -ffast-math
19
20 default: gen_matypes matypes.h
21
22@@ -21,7 +26,7 @@
23
24
25 gen_matypes: gen_matypes.c
26- $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
27+ $(CC) $(INCLUDE_DIRS) $(CFLAGS_host) gen_matypes.c -o gen_matypes
28
29 # need some special rules here, unfortunately
30 matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes
diff --git a/meta/packages/mesa/mesa-7.0.2/mklib-rpath-link.patch b/meta/packages/mesa/mesa-7.0.2/mklib-rpath-link.patch
deleted file mode 100644
index 618f5b57ed..0000000000
--- a/meta/packages/mesa/mesa-7.0.2/mklib-rpath-link.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1--- /tmp/mklib 2007-12-08 11:03:23.000000000 +0100
2+++ Mesa-7.0.2/bin/mklib 2007-12-08 11:04:02.509863000 +0100
3@@ -106,6 +106,9 @@
4 -L*)
5 DEPS="$DEPS $1"
6 ;;
7+ -Wl*)
8+ DEPS="$DEPS $1"
9+ ;;
10 -pthread)
11 # this is a special case (see bugzilla 10876)
12 DEPS="$DEPS $1"
13--- /tmp/default 2007-12-08 11:04:17.000000000 +0100
14+++ Mesa-7.0.2/configs/default 2007-12-08 11:05:06.279863000 +0100
15@@ -76,7 +76,7 @@
16 GLW_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(GL_LIB) $(EXTRA_LIB_PATH) -lXt -lX11
17
18 # Program dependencies - specific GL/glut libraries added in Makefiles
19-APP_LIB_DEPS = -lm
20+APP_LIB_DEPS = $(EXTRA_LIB_PATH) -lm
21
22
23