diff options
author | Matthew Allum <mallum@openedhand.com> | 2006-12-20 16:05:28 +0000 |
---|---|---|
committer | Matthew Allum <mallum@openedhand.com> | 2006-12-20 16:05:28 +0000 |
commit | ce18f35f8e881b639821d3b009c0a122e533cfa6 (patch) | |
tree | 4effe12fb59e8b4dfe1098a0564db94e6f00fdec /meta/packages/matchbox-sato | |
parent | 5412e02d76a1bac5fee819558e595b2a7c726ca8 (diff) | |
download | poky-ce18f35f8e881b639821d3b009c0a122e533cfa6.tar.gz |
Add matchbox-sato
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1066 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-sato')
-rwxr-xr-x | meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session | 38 | ||||
-rw-r--r-- | meta/packages/matchbox-sato/matchbox-sato_0.1.bb | 24 |
2 files changed, 62 insertions, 0 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session new file mode 100755 index 0000000000..46419d8206 --- /dev/null +++ b/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session | |||
@@ -0,0 +1,38 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | module_id() { | ||
4 | awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo | ||
5 | } | ||
6 | |||
7 | SHOWCURSOR="no" | ||
8 | |||
9 | ## Start up machine specific input devices. Really needs to go in its own session | ||
10 | case `module_id` in | ||
11 | # On Zaurus models, zaurusd takes care of mbinputmgr for us in its hinge scripts | ||
12 | "Generic OMAP1510/1610/1710") | ||
13 | /usr/bin/mbinputmgr & | ||
14 | ;; | ||
15 | # qemu machines.. likely need better detection | ||
16 | "ARM-IntegratorCP" | "ARM-Versatile PB") | ||
17 | /usr/bin/mbinputmgr & | ||
18 | #SHOWCURSOR="yes" | ||
19 | ;; | ||
20 | esac | ||
21 | |||
22 | ## All this should be done by themeing/xsettings.. ## | ||
23 | matchbox-desktop --icon-size 48 \ | ||
24 | --icon-padding 64 \ | ||
25 | --font sans-16:bold \ | ||
26 | --titlefont sans-16:bold & | ||
27 | |||
28 | mb-applet-startup-monitor & | ||
29 | |||
30 | #matchbox-panel --orientation east \ | ||
31 | # --padding 4 \ | ||
32 | # --no-menu \ | ||
33 | # --no-session \ | ||
34 | # --default-apps mb-applet-home,mb-applet-clock,mb-applet-battery & | ||
35 | |||
36 | exec matchbox-window-manager -use_cursor $SHOWCURSOR $@ | ||
37 | |||
38 | |||
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb new file mode 100644 index 0000000000..64091bcd7f --- /dev/null +++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Custom MB session files for poky" | ||
2 | LICENSE = "GPL" | ||
3 | SECTION = "x11" | ||
4 | RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-engine-sato" | ||
5 | PR = "r1" | ||
6 | |||
7 | SRC_URI = "file://etc" | ||
8 | S = ${WORKDIR} | ||
9 | |||
10 | do_install() { | ||
11 | cp -R ${S}/etc ${D}/etc | ||
12 | rm -fR ${D}/etc/.svn | ||
13 | rm -fR ${D}/etc/matchbox/.svn | ||
14 | chmod -R 755 ${D}/etc | ||
15 | } | ||
16 | |||
17 | pkg_postinst_matchbox-poky () { | ||
18 | #!/bin/sh -e | ||
19 | if [ "x$D" != "x" ]; then | ||
20 | exit 1 | ||
21 | fi | ||
22 | |||
23 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato | ||
24 | } | ||