summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-sato
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-08-08 15:37:44 +0000
committerRoss Burton <ross@openedhand.com>2008-08-08 15:37:44 +0000
commit3478f415201c2136270a00b043c7cc0209211b27 (patch)
treea175ad846cbd8cad1099b26b4877126da7bb1793 /meta/packages/matchbox-sato
parente14a39f2808459a69ba0a549e133f93045b5e169 (diff)
downloadpoky-3478f415201c2136270a00b043c7cc0209211b27.tar.gz
matchbox-session-sato: magically munge the session script to remove applets depending on the machine features
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5042 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-sato')
-rw-r--r--meta/packages/matchbox-sato/matchbox-session-sato/session9
-rw-r--r--meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb19
2 files changed, 25 insertions, 3 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-session-sato/session b/meta/packages/matchbox-sato/matchbox-session-sato/session
index 010772a8c4..68aacd1d5f 100644
--- a/meta/packages/matchbox-sato/matchbox-session-sato/session
+++ b/meta/packages/matchbox-sato/matchbox-session-sato/session
@@ -10,6 +10,13 @@ fi
10 10
11matchbox-desktop & 11matchbox-desktop &
12 12
13matchbox-panel --titlebar --start-applets showdesktop,windowselector --end-applets clock,battery,systray,startup-notify,notify & 13# Lines containing feature-[foo] are removed at build time if the machine
14# doesn't have the feature "foo".
15
16START_APPLETS=showdesktop,windowselector
17END_APPLETS=clock,battery,systray,startup-notify,notify
18END_APPETS=openmoko-panel-gsm,$APPLETS # feature-phone
19
20matchbox-panel --titlebar --start-applets $START_APPLETS --end-applets $END_APPLETS &
14 21
15exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@ 22exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
index 76c8797d4f..4d208ddb70 100644
--- a/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -2,14 +2,29 @@ DESCRIPTION = "Custom MB session files for poky"
2LICENSE = "GPL" 2LICENSE = "GPL"
3SECTION = "x11" 3SECTION = "x11"
4RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session" 4RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session"
5PR = "r24" 5PR = "r25"
6
7# This package is architecture specific because the session script is modified
8# based on the machine architecture.
9PACKAGE_ARCH = "${MACHINE_ARCH}"
6 10
7SRC_URI = "file://session" 11SRC_URI = "file://session"
8S = "${WORKDIR}" 12S = "${WORKDIR}"
9 13
10do_install() { 14do_install() {
15 # This is the set of machine features that the script has markers for
16 FEATURES="phone"
17 SCRIPT="${S}/sedder"
18 rm -f $SCRIPT
19 touch $SCRIPT
20 for FEAT in $FEATURES; do
21 if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
22 echo "/feature-$FEAT/d" >> $SCRIPT
23 fi
24 done
25
11 install -d ${D}/${sysconfdir}/matchbox 26 install -d ${D}/${sysconfdir}/matchbox
12 install -m 0755 ${S}/session ${D}/${sysconfdir}/matchbox/ 27 sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
13} 28}
14 29
15pkg_postinst_${PN} () { 30pkg_postinst_${PN} () {