diff options
author | Ross Burton <ross@openedhand.com> | 2008-08-08 15:37:44 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2008-08-08 15:37:44 +0000 |
commit | 3478f415201c2136270a00b043c7cc0209211b27 (patch) | |
tree | a175ad846cbd8cad1099b26b4877126da7bb1793 /meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb | |
parent | e14a39f2808459a69ba0a549e133f93045b5e169 (diff) | |
download | poky-3478f415201c2136270a00b043c7cc0209211b27.tar.gz |
matchbox-session-sato: magically munge the session script to remove applets depending on the machine features
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5042 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb')
-rw-r--r-- | meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb | 19 |
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb index 76c8797d4f..4d208ddb70 100644 --- a/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb +++ b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb | |||
@@ -2,14 +2,29 @@ DESCRIPTION = "Custom MB session files for poky" | |||
2 | LICENSE = "GPL" | 2 | LICENSE = "GPL" |
3 | SECTION = "x11" | 3 | SECTION = "x11" |
4 | RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session" | 4 | RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session" |
5 | PR = "r24" | 5 | PR = "r25" |
6 | |||
7 | # This package is architecture specific because the session script is modified | ||
8 | # based on the machine architecture. | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | 10 | ||
7 | SRC_URI = "file://session" | 11 | SRC_URI = "file://session" |
8 | S = "${WORKDIR}" | 12 | S = "${WORKDIR}" |
9 | 13 | ||
10 | do_install() { | 14 | do_install() { |
15 | # This is the set of machine features that the script has markers for | ||
16 | FEATURES="phone" | ||
17 | SCRIPT="${S}/sedder" | ||
18 | rm -f $SCRIPT | ||
19 | touch $SCRIPT | ||
20 | for FEAT in $FEATURES; do | ||
21 | if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then | ||
22 | echo "/feature-$FEAT/d" >> $SCRIPT | ||
23 | fi | ||
24 | done | ||
25 | |||
11 | install -d ${D}/${sysconfdir}/matchbox | 26 | install -d ${D}/${sysconfdir}/matchbox |
12 | install -m 0755 ${S}/session ${D}/${sysconfdir}/matchbox/ | 27 | sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session |
13 | } | 28 | } |
14 | 29 | ||
15 | pkg_postinst_${PN} () { | 30 | pkg_postinst_${PN} () { |