diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/matchbox-poky | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-poky')
-rwxr-xr-x | meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session | 43 | ||||
-rw-r--r-- | meta/packages/matchbox-poky/matchbox-poky_0.1.bb | 20 |
2 files changed, 63 insertions, 0 deletions
diff --git a/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session new file mode 100755 index 0000000000..fede9e44b9 --- /dev/null +++ b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session | |||
@@ -0,0 +1,43 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | module_id() { | ||
4 | awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo | ||
5 | } | ||
6 | |||
7 | SHOWCURSOR="no" | ||
8 | |||
9 | ## Start up machine specific input devices. Really needs to go in its own session | ||
10 | case `module_id` in | ||
11 | "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi") | ||
12 | chkhinge26 /dev/input/event0 hinge-handler & | ||
13 | ;; | ||
14 | "Generic OMAP1510/1610/1710") | ||
15 | /usr/bin/mbinputmgr & | ||
16 | ;; | ||
17 | "ARM-IntegratorCP") | ||
18 | /usr/bin/mbinputmgr & | ||
19 | SHOWCURSOR="yes" | ||
20 | ;; | ||
21 | esac | ||
22 | |||
23 | ## All this should be done by themeing/xsettings.. ## | ||
24 | matchbox-desktop --icon-size 48 \ | ||
25 | --icon-padding 64 \ | ||
26 | --font sans-8:bold \ | ||
27 | --titlefont sans-8:bold & | ||
28 | |||
29 | # let theme set it | ||
30 | # --bg /usr/share/themes/Clearlooks/background/default.png \ | ||
31 | |||
32 | mb-applet-startup-monitor & | ||
33 | |||
34 | matchbox-panel --orientation east \ | ||
35 | --padding 4 \ | ||
36 | --no-menu \ | ||
37 | --no-session \ | ||
38 | --default-apps mb-applet-home,mb-applet-clock,mb-applet-battery & | ||
39 | |||
40 | ## eek ugly no cursor hack - transparent theme should do this | ||
41 | exec matchbox-window-manager -theme Clearlooks -use_cursor $SHOWCURSOR $@ | ||
42 | |||
43 | |||
diff --git a/meta/packages/matchbox-poky/matchbox-poky_0.1.bb b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb new file mode 100644 index 0000000000..041a6ea904 --- /dev/null +++ b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "Custom MB session files for poky" | ||
2 | LICENSE = "GPL" | ||
3 | SECTION = "x11" | ||
4 | RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks" | ||
5 | PR = "r15" | ||
6 | |||
7 | SRC_URI = "file://etc" | ||
8 | S = ${WORKDIR} | ||
9 | |||
10 | do_install() { | ||
11 | cp -R ${S}/etc ${D}/etc | ||
12 | rm -fR ${D}/etc/.svn | ||
13 | rm -fR ${D}/etc/matchbox/.svn | ||
14 | chmod -R 755 ${D}/etc | ||
15 | } | ||
16 | |||
17 | pkg_postinst_matchbox-poky () { | ||
18 | #!/bin/sh -e | ||
19 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/theme Clearlooks | ||
20 | } | ||