diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/matchbox-panel-hacks | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-panel-hacks')
6 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop new file mode 100644 index 0000000000..4e08dfd379 --- /dev/null +++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop | |||
@@ -0,0 +1,7 @@ | |||
1 | [Desktop Entry] | ||
2 | Name=Home | ||
3 | Comment=Home | ||
4 | Exec=mb-applet-home | ||
5 | Type=PanelApp | ||
6 | Icon=xrandr.png | ||
7 | Categories=Panel;Utility;MB | ||
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home new file mode 100755 index 0000000000..72aa76f227 --- /dev/null +++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home | |||
@@ -0,0 +1,2 @@ | |||
1 | #!/bin/sh | ||
2 | mb-applet-launcher -na -o -1 -l --title "Home" mbdesktop.png matchbox-remote -d | ||
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop new file mode 100644 index 0000000000..512e3771e4 --- /dev/null +++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop | |||
@@ -0,0 +1,7 @@ | |||
1 | [Desktop Entry] | ||
2 | Name=Screen Rotator | ||
3 | Comment=Panel based Rotation tool. | ||
4 | Exec=mb-applet-launcher -na -l --title "Screen Rotator" /usr/share/pixmaps/xrandr.png xrandr-panelapp.sh | ||
5 | Type=PanelApp | ||
6 | Icon=xrandr.png | ||
7 | Categories=Panel;Utility;MB | ||
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh new file mode 100755 index 0000000000..d17c805ffc --- /dev/null +++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh | |||
@@ -0,0 +1,9 @@ | |||
1 | #!/bin/sh | ||
2 | if [ -n "$(xrandr | grep rotation | grep left)" ] | ||
3 | then | ||
4 | xrandr -o normal | ||
5 | xmodmap /etc/X11/xmodmap-portrait | ||
6 | else | ||
7 | xrandr -o left | ||
8 | xmodmap /etc/X11/xmodmap-left | ||
9 | fi | ||
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png new file mode 100644 index 0000000000..08cd476e8a --- /dev/null +++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png | |||
Binary files differ | |||
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb new file mode 100644 index 0000000000..46b0acfe2e --- /dev/null +++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "Simple dockapps created with monolaunch and shell script" | ||
2 | DEPENDS = "matchbox xmodmap" | ||
3 | SRC_URI = "file://xrandr-panelapp.sh \ | ||
4 | file://xrandr-panelapp.desktop \ | ||
5 | file://mb-applet-home \ | ||
6 | file://home-panelapp.desktop \ | ||
7 | file://xrandr.png" | ||
8 | SECTION = "x11/wm" | ||
9 | PRIORITY = "optional" | ||
10 | PR = "r6" | ||
11 | LICENSE = "MIT" | ||
12 | |||
13 | do_install() { | ||
14 | install -d ${D}${bindir} | ||
15 | install -d ${D}${datadir}/applications | ||
16 | install -d ${D}${datadir}/pixmaps | ||
17 | install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/ | ||
18 | install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/ | ||
19 | install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/ | ||
20 | install -m 0755 ${WORKDIR}/mb-applet-home ${D}${bindir}/ | ||
21 | install -m 0644 ${WORKDIR}/home-panelapp.desktop ${D}${datadir}/applications/ | ||
22 | |||
23 | } | ||