diff options
author | Joshua Lock <josh@openedhand.com> | 2008-09-25 09:50:05 +0000 |
---|---|---|
committer | Joshua Lock <josh@openedhand.com> | 2008-09-25 09:50:05 +0000 |
commit | 8f8fbefd0f44f0f79b76aa3be75b4738129d4d26 (patch) | |
tree | c74935a504af0b66d57a601a8df1fd8dcf95f1b3 /meta/packages/matchbox-netbook | |
parent | c8ece75aea96cbd1120e385de22f50b4e4944b6c (diff) | |
download | poky-8f8fbefd0f44f0f79b76aa3be75b4738129d4d26.tar.gz |
Initial support for netbooks with a poky-image-netbook(-live) image target.
This needs much love from folk with UI and WM skills.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5266 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-netbook')
-rw-r--r-- | meta/packages/matchbox-netbook/matchbox-session-netbook/session | 22 | ||||
-rw-r--r-- | meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb | 43 |
2 files changed, 65 insertions, 0 deletions
diff --git a/meta/packages/matchbox-netbook/matchbox-session-netbook/session b/meta/packages/matchbox-netbook/matchbox-session-netbook/session new file mode 100644 index 0000000000..bd6bdba4ac --- /dev/null +++ b/meta/packages/matchbox-netbook/matchbox-session-netbook/session | |||
@@ -0,0 +1,22 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | . /etc/formfactor/config | ||
4 | |||
5 | if [ "$HAVE_TOUCHSCREEN" = "1" ]; then | ||
6 | SHOWCURSOR="no" | ||
7 | else | ||
8 | SHOWCURSOR="yes" | ||
9 | fi | ||
10 | |||
11 | matchbox-desktop & | ||
12 | |||
13 | # Lines containing feature-[foo] are removed at build time if the machine | ||
14 | # doesn't have the feature "foo". | ||
15 | |||
16 | START_APPLETS=showdesktop,windowselector | ||
17 | END_APPLETS=clock,battery,systray,startup-notify,notify | ||
18 | END_APPLETS=openmoko-panel-gsm,$END_APPLETS # feature-phone | ||
19 | |||
20 | matchbox-panel --titlebar --start-applets $START_APPLETS --end-applets $END_APPLETS & | ||
21 | |||
22 | exec metacity | ||
diff --git a/meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb b/meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb new file mode 100644 index 0000000000..19e77d8915 --- /dev/null +++ b/meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | DESCRIPTION = "Custom MB session files for poky" | ||
2 | LICENSE = "GPL" | ||
3 | SECTION = "x11" | ||
4 | RDEPENDS = "formfactor gtk-engines gtk-theme-darkilouche matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session" | ||
5 | PR = "r1" | ||
6 | |||
7 | # This package is architecture specific because the session script is modified | ||
8 | # based on the machine architecture. | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | SRC_URI = "file://session" | ||
12 | S = "${WORKDIR}" | ||
13 | |||
14 | do_install() { | ||
15 | # This is the set of machine features that the script has markers for | ||
16 | FEATURES="phone" | ||
17 | SCRIPT="${S}/sedder" | ||
18 | rm -f $SCRIPT | ||
19 | touch $SCRIPT | ||
20 | for FEAT in $FEATURES; do | ||
21 | if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then | ||
22 | echo "/feature-$FEAT/d" >> $SCRIPT | ||
23 | fi | ||
24 | done | ||
25 | |||
26 | install -d ${D}/${sysconfdir}/matchbox | ||
27 | sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session | ||
28 | chmod +x ${D}/${sysconfdir}/matchbox/session | ||
29 | } | ||
30 | |||
31 | pkg_postinst_${PN} () { | ||
32 | #!/bin/sh -e | ||
33 | if [ "x$D" != "x" ]; then | ||
34 | exit 1 | ||
35 | fi | ||
36 | |||
37 | . ${sysconfdir}/init.d/functions | ||
38 | |||
39 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato | ||
40 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato | ||
41 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/touchscreen true | ||
42 | |||
43 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 10" \ No newline at end of file | ||