summaryrefslogtreecommitdiffstats
path: root/meta/packages/maemo
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/maemo
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/maemo')
-rw-r--r--meta/packages/maemo/nokia770-init/fixup-770.sh25
-rw-r--r--meta/packages/maemo/nokia770-init_1.0.bb42
-rw-r--r--meta/packages/maemo/xpext/auxdir.patch13
-rw-r--r--meta/packages/maemo/xpext_1.0-5.bb27
-rw-r--r--meta/packages/maemo/xsp_1.0.0-8.bb20
5 files changed, 127 insertions, 0 deletions
diff --git a/meta/packages/maemo/nokia770-init/fixup-770.sh b/meta/packages/maemo/nokia770-init/fixup-770.sh
new file mode 100644
index 0000000000..b65fb131e3
--- /dev/null
+++ b/meta/packages/maemo/nokia770-init/fixup-770.sh
@@ -0,0 +1,25 @@
1#! /bin/sh
2case "$1" in
3 start)
4 echo -n "Unmounting virtual fs from initrd"
5 umount /mnt/initfs/sys
6 umount /mnt/initfs/proc
7 ln -s /dev/vc/0 /dev/tty0
8 ln -s /dev/vc/1 /dev/tty1
9 ln -s /dev/vc/2 /dev/tty2
10 ln -s /dev/vc/3 /dev/tty3
11 ln -s /dev/vc/4 /dev/tty4
12 ln -s /dev/vc/5 /dev/tty5
13 ln -s /dev/vc/6 /dev/tty6
14 ln -s /dev/vc/7 /dev/tty7
15 ;;
16 stop)
17 ;;
18 *)
19 echo "Usage: $SCRIPTNAME {start|stop}" >&2
20 exit 1
21 ;;
22esac
23
24exit 0
25 \ No newline at end of file
diff --git a/meta/packages/maemo/nokia770-init_1.0.bb b/meta/packages/maemo/nokia770-init_1.0.bb
new file mode 100644
index 0000000000..84c1e3c279
--- /dev/null
+++ b/meta/packages/maemo/nokia770-init_1.0.bb
@@ -0,0 +1,42 @@
1LICENSE = "GPL"
2MAINTAINER = "Florian Boor <florian@kernelconcepts.de"
3PR = "r5"
4
5DEPENDS = "base-passwd"
6#RDEPENDS = "hotplug"
7
8SRC_URI = "file://fixup-770.sh"
9
10FILES_${PN} = "${sysconfdir} ${libdir}"
11
12inherit update-rc.d
13
14
15INITSCRIPT_NAME = "fixup-770.sh"
16INITSCRIPT_PARAMS = "defaults 01"
17
18
19do_install () {
20 install -d ${D}${sysconfdir}/init.d
21 install -m 755 ${WORKDIR}/fixup-770.sh ${D}/${sysconfdir}/init.d/fixup-770.sh
22
23 install -d ${D}/lib/firmware
24}
25
26pkg_postinst () {
27#!/bin/sh
28
29# can't do adduser stuff offline
30if [ "x$D" != "x" ]; then
31 exit 1
32fi
33
34# set up some links to firmware and modules in initrd
35 mkdir -p /lib/firmware
36 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3825.arm /lib/firmware/3825.arm
37 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/brf6150fw.bin /lib/firmware/brf6150fw.bin
38 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3825.arm /lib/firmware/mtlm3825.arm
39
40# rm -rf /lib/modules
41# ln -s /mnt/initfs/lib/modules /lib/modules
42}
diff --git a/meta/packages/maemo/xpext/auxdir.patch b/meta/packages/maemo/xpext/auxdir.patch
new file mode 100644
index 0000000000..da5841a132
--- /dev/null
+++ b/meta/packages/maemo/xpext/auxdir.patch
@@ -0,0 +1,13 @@
1--- configure.ac.old 2005-06-03 12:53:28.000000000 +0200
2+++ configure.ac 2005-06-03 12:54:29.000000000 +0200
3@@ -25,9 +25,9 @@
4
5 AC_PREREQ([2.57])
6 AC_INIT([spext], [1.0], [lauri.leukkunen@nokia.com], spext)
7+AC_CONFIG_AUX_DIR(.)
8 AM_INIT_AUTOMAKE([dist-bzip2])
9 AM_MAINTAINER_MODE
10-AC_CONFIG_AUX_DIR(.)
11
12 dnl PKG_CHECK_MODULES(FIXESEXT, fixesext)
13
diff --git a/meta/packages/maemo/xpext_1.0-5.bb b/meta/packages/maemo/xpext_1.0-5.bb
new file mode 100644
index 0000000000..75b7903e84
--- /dev/null
+++ b/meta/packages/maemo/xpext_1.0-5.bb
@@ -0,0 +1,27 @@
1PR = "r0"
2LICENSE= "MIT"
3DESCRIPTION = "X Server Nokia 770 extensions library"
4SECTION = "x11/libs"
5PRIORITY = "optional"
6DEPENDS = "libx11 xextensions libxext"
7
8SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/${PN}/${PN}_${PV}.tar.gz \
9 file://auxdir.patch;patch=1;pnum=0"
10S = "${WORKDIR}/xpext-1.0"
11
12inherit autotools pkgconfig
13
14do_configure_prepend () {
15 cd ${S}
16 chmod +x ./autogen.sh
17 ./autogen.sh
18}
19
20do_stage() {
21 oe_runmake install prefix=${STAGING_DIR} \
22 bindir=${STAGING_BINDIR} \
23 includedir=${STAGING_INCDIR} \
24 libdir=${STAGING_LIBDIR} \
25 datadir=${STAGING_DATADIR} \
26 mandir=${STAGING_DATADIR}/man
27}
diff --git a/meta/packages/maemo/xsp_1.0.0-8.bb b/meta/packages/maemo/xsp_1.0.0-8.bb
new file mode 100644
index 0000000000..068193c6aa
--- /dev/null
+++ b/meta/packages/maemo/xsp_1.0.0-8.bb
@@ -0,0 +1,20 @@
1PR = "r0"
2LICENSE= "MIT"
3DESCRIPTION = "X Server Nokia 770 extensions library"
4SECTION = "x11/libs"
5PRIORITY = "optional"
6DEPENDS = "libx11 xextensions libxext xpext"
7
8SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/xsp/${PN}_${PV}.tar.gz"
9S = "${WORKDIR}/Xsp"
10
11inherit autotools pkgconfig
12
13do_stage() {
14 oe_runmake install prefix=${STAGING_DIR} \
15 bindir=${STAGING_BINDIR} \
16 includedir=${STAGING_INCDIR} \
17 libdir=${STAGING_LIBDIR} \
18 datadir=${STAGING_DATADIR} \
19 mandir=${STAGING_DATADIR}/man
20}