diff options
author | Ross Burton <ross@openedhand.com> | 2007-01-22 13:54:16 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2007-01-22 13:54:16 +0000 |
commit | 98f3b8b8504bd64d1d21d6e2a8cef86baf92b06b (patch) | |
tree | 0a9b814b961fc5e736e67927f154fc65910830a0 /meta/packages/lttng | |
parent | 248c3ed47739d7f8b56c377fd89f437c4d4ebfd5 (diff) | |
download | poky-98f3b8b8504bd64d1d21d6e2a8cef86baf92b06b.tar.gz |
Add a patch to stop versioning the plugin libraries
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1189 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lttng')
-rw-r--r-- | meta/packages/lttng/files/lttv-no-versions.patch | 135 | ||||
-rw-r--r-- | meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb | 7 |
2 files changed, 139 insertions, 3 deletions
diff --git a/meta/packages/lttng/files/lttv-no-versions.patch b/meta/packages/lttng/files/lttv-no-versions.patch new file mode 100644 index 0000000000..2b3c9e8fd6 --- /dev/null +++ b/meta/packages/lttng/files/lttv-no-versions.patch | |||
@@ -0,0 +1,135 @@ | |||
1 | Index: lttv/modules/gui/interrupts/Makefile.am | ||
2 | =================================================================== | ||
3 | --- lttv/modules/gui/interrupts/Makefile.am (revision 2340) | ||
4 | +++ lttv/modules/gui/interrupts/Makefile.am (working copy) | ||
5 | @@ -31,7 +31,7 @@ | ||
6 | libdir = ${lttvplugindir} | ||
7 | |||
8 | lib_LTLIBRARIES = libinterrupts.la | ||
9 | -libinterrupts_la_LDFLAGS = -module | ||
10 | +libinterrupts_la_LDFLAGS = -module -avoid-version | ||
11 | libinterrupts_la_SOURCES = interrupts.c | ||
12 | |||
13 | EXTRA_DIST = \ | ||
14 | Index: lttv/modules/gui/tracecontrol/Makefile.am | ||
15 | =================================================================== | ||
16 | --- lttv/modules/gui/tracecontrol/Makefile.am (revision 2340) | ||
17 | +++ lttv/modules/gui/tracecontrol/Makefile.am (working copy) | ||
18 | @@ -14,11 +14,9 @@ | ||
19 | libdir = ${lttvplugindir} | ||
20 | |||
21 | lib_LTLIBRARIES = libguitracecontrol.la | ||
22 | -libguitracecontrol_la_LDFLAGS = -module | ||
23 | +libguitracecontrol_la_LDFLAGS = -module -avoid-version | ||
24 | libguitracecontrol_la_SOURCES = tracecontrol.c | ||
25 | |||
26 | EXTRA_DIST = \ | ||
27 | hTraceControlInsert.xpm TraceControlStart.xpm TraceControlPause.xpm \ | ||
28 | TraceControlStop.xpm | ||
29 | - | ||
30 | - | ||
31 | Index: lttv/modules/gui/detailedevents/Makefile.am | ||
32 | =================================================================== | ||
33 | --- lttv/modules/gui/detailedevents/Makefile.am (revision 2340) | ||
34 | +++ lttv/modules/gui/detailedevents/Makefile.am (working copy) | ||
35 | @@ -31,7 +31,7 @@ | ||
36 | libdir = ${lttvplugindir} | ||
37 | |||
38 | lib_LTLIBRARIES = libguievents.la | ||
39 | -libguievents_la_LDFLAGS = -module | ||
40 | +libguievents_la_LDFLAGS = -module -avoid-version | ||
41 | libguievents_la_SOURCES = events.c | ||
42 | |||
43 | noinst_HEADERS = lttv_plugin_evd.h events.h | ||
44 | Index: lttv/modules/gui/filter/Makefile.am | ||
45 | =================================================================== | ||
46 | --- lttv/modules/gui/filter/Makefile.am (revision 2340) | ||
47 | +++ lttv/modules/gui/filter/Makefile.am (working copy) | ||
48 | @@ -12,10 +12,8 @@ | ||
49 | libdir = ${lttvplugindir} | ||
50 | |||
51 | lib_LTLIBRARIES = libguifilter.la | ||
52 | -libguifilter_la_LDFLAGS = -module | ||
53 | +libguifilter_la_LDFLAGS = -module -avoid-version | ||
54 | libguifilter_la_SOURCES = filter.c | ||
55 | |||
56 | EXTRA_DIST = \ | ||
57 | hGuiFilterInsert.xpm | ||
58 | - | ||
59 | - | ||
60 | Index: lttv/modules/gui/controlflow/Makefile.am | ||
61 | =================================================================== | ||
62 | --- lttv/modules/gui/controlflow/Makefile.am (revision 2340) | ||
63 | +++ lttv/modules/gui/controlflow/Makefile.am (working copy) | ||
64 | @@ -30,7 +30,7 @@ | ||
65 | libdir = ${lttvplugindir} | ||
66 | |||
67 | lib_LTLIBRARIES = libguicontrolflow.la | ||
68 | -libguicontrolflow_la_LDFLAGS = -module | ||
69 | +libguicontrolflow_la_LDFLAGS = -module -avoid-version | ||
70 | libguicontrolflow_la_SOURCES = module.c eventhooks.c cfv.c processlist.c\ | ||
71 | drawing.c drawitem.c lttv_plugin_cfv.c | ||
72 | |||
73 | Index: lttv/modules/gui/statistics/Makefile.am | ||
74 | =================================================================== | ||
75 | --- lttv/modules/gui/statistics/Makefile.am (revision 2340) | ||
76 | +++ lttv/modules/gui/statistics/Makefile.am (working copy) | ||
77 | @@ -12,7 +12,7 @@ | ||
78 | libdir = ${lttvplugindir} | ||
79 | |||
80 | lib_LTLIBRARIES = libguistatistics.la | ||
81 | -libguistatistics_la_LDFLAGS = -module | ||
82 | +libguistatistics_la_LDFLAGS = -module -avoid-version | ||
83 | libguistatistics_la_SOURCES = statistics.c | ||
84 | |||
85 | EXTRA_DIST = \ | ||
86 | Index: lttv/modules/gui/diskperformance/Makefile.am | ||
87 | =================================================================== | ||
88 | --- lttv/modules/gui/diskperformance/Makefile.am (revision 2340) | ||
89 | +++ lttv/modules/gui/diskperformance/Makefile.am (working copy) | ||
90 | @@ -31,7 +31,7 @@ | ||
91 | libdir = ${lttvplugindir} | ||
92 | |||
93 | lib_LTLIBRARIES = libdiskperformance.la | ||
94 | -libdiskperformance_la_LDFLAGS = -module | ||
95 | +libdiskperformance_la_LDFLAGS = -module -avoid-version | ||
96 | libdiskperformance_la_SOURCES = diskperformance.c | ||
97 | |||
98 | EXTRA_DIST = \ | ||
99 | Index: lttv/modules/gui/histogram/Makefile.am | ||
100 | =================================================================== | ||
101 | --- lttv/modules/gui/histogram/Makefile.am (revision 2340) | ||
102 | +++ lttv/modules/gui/histogram/Makefile.am (working copy) | ||
103 | @@ -31,7 +31,7 @@ | ||
104 | libdir = ${lttvplugindir} | ||
105 | |||
106 | lib_LTLIBRARIES = libguihistogram.la | ||
107 | -libguihistogram_la_LDFLAGS = -module | ||
108 | +libguihistogram_la_LDFLAGS = -module -avoid-version | ||
109 | libguihistogram_la_SOURCES = histomodule.c histoeventhooks.c histocfv.c \ | ||
110 | histobuttonwidget.c histodrawing.c histodrawitem.c | ||
111 | |||
112 | Index: lttv/modules/text/Makefile.am | ||
113 | =================================================================== | ||
114 | --- lttv/modules/text/Makefile.am (revision 2340) | ||
115 | +++ lttv/modules/text/Makefile.am (working copy) | ||
116 | @@ -1,16 +1,14 @@ | ||
117 | - | ||
118 | - | ||
119 | AM_CFLAGS = $(GLIB_CFLAGS) | ||
120 | LIBS += $(GLIB_LIBS) -lgobject-2.0 -L${top_srcdir}/ltt -llttvtraceread | ||
121 | |||
122 | libdir = ${lttvplugindir} | ||
123 | |||
124 | lib_LTLIBRARIES = libtextDump.la libbatchAnalysis.la libtextFilter.la | ||
125 | -libtextDump_la_LDFLAGS = -module | ||
126 | +libtextDump_la_LDFLAGS = -module -avoid-version | ||
127 | libtextDump_la_SOURCES = textDump.c | ||
128 | -libbatchAnalysis_la_LDFLAGS = -module | ||
129 | +libbatchAnalysis_la_LDFLAGS = -module -avoid-version | ||
130 | libbatchAnalysis_la_SOURCES = batchAnalysis.c | ||
131 | -libtextFilter_la_LDFLAGS = -module | ||
132 | +libtextFilter_la_LDFLAGS = -module -avoid-version | ||
133 | libtextFilter_la_SOURCES = textFilter.c | ||
134 | |||
135 | noinst_HEADERS = \ | ||
diff --git a/meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb b/meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb index 8738492fae..84142dab09 100644 --- a/meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb +++ b/meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb | |||
@@ -3,12 +3,13 @@ DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \ | |||
3 | extract program execution details from the Linux operating system and \ | 3 | extract program execution details from the Linux operating system and \ |
4 | interpret them." | 4 | interpret them." |
5 | LICENSE = "GPL" | 5 | LICENSE = "GPL" |
6 | PR = "r1" | 6 | PR = "r2" |
7 | DEPENDS = "gtk+ pango popt" | 7 | DEPENDS = "gtk+ pango popt" |
8 | 8 | ||
9 | ALTNAME = "LinuxTraceToolkitViewer-0.8.41-12052006" | 9 | ALTNAME = "LinuxTraceToolkitViewer-0.8.41-12052006" |
10 | 10 | ||
11 | SRC_URI = "http://ltt.polymtl.ca/packages/${ALTNAME}.tar.gz " | 11 | SRC_URI = "http://ltt.polymtl.ca/packages/${ALTNAME}.tar.gz \ |
12 | file://lttv-no-versions.patch;patch=1;pnum=0" | ||
12 | S = "${WORKDIR}/${ALTNAME}" | 13 | S = "${WORKDIR}/${ALTNAME}" |
13 | 14 | ||
14 | inherit autotools | 15 | inherit autotools |
@@ -16,7 +17,7 @@ inherit autotools | |||
16 | LEAD_SONAME = "liblttvtraceread*" | 17 | LEAD_SONAME = "liblttvtraceread*" |
17 | 18 | ||
18 | FILES_${PN} += "\ | 19 | FILES_${PN} += "\ |
19 | ${libdir}/lttv/plugins/* \ | 20 | ${libdir}/lttv/plugins/*.so \ |
20 | ${datadir}/LinuxTraceToolkitViewer/facilities/* \ | 21 | ${datadir}/LinuxTraceToolkitViewer/facilities/* \ |
21 | ${datadir}/LinuxTraceToolkitViewer/pixmaps/* " | 22 | ${datadir}/LinuxTraceToolkitViewer/pixmaps/* " |
22 | FILES_${PN}-dbg += "${libdir}/lttv/plugins/.debug/" | 23 | FILES_${PN}-dbg += "${libdir}/lttv/plugins/.debug/" |