summaryrefslogtreecommitdiffstats
path: root/meta/packages/lsof
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-08-08 21:08:42 +0000
committerRichard Purdie <richard@openedhand.com>2007-08-08 21:08:42 +0000
commit3ccd06b07d3d4d479a3ad5ce6584b85a600fcefe (patch)
treeca8a91bc4e93fe156dc8348d9e77c6e0fc9cdb38 /meta/packages/lsof
parent3838cc7dc1585ccda1b1a8d642021483edfd1121 (diff)
downloadpoky-3ccd06b07d3d4d479a3ad5ce6584b85a600fcefe.tar.gz
lsof/m4: Remove old versions
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2414 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lsof')
-rw-r--r--meta/packages/lsof/lsof_4.77.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/packages/lsof/lsof_4.77.bb b/meta/packages/lsof/lsof_4.77.bb
deleted file mode 100644
index 054875b861..0000000000
--- a/meta/packages/lsof/lsof_4.77.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
2Its name stands for LiSt Open Files, and it does just that."
3SECTION = "devel"
4LICENSE = "BSD"
5PR = "r1"
6
7SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
8LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
9S = "${WORKDIR}/lsof_${PV}_src"
10
11python do_unpack () {
12 bb.build.exec_func('base_do_unpack', d)
13 src_uri = bb.data.getVar('SRC_URI', d)
14 bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
15 bb.build.exec_func('base_do_unpack', d)
16 bb.data.setVar('SRC_URI', src_uri, d)
17}
18
19LSOF_OS = "${TARGET_OS}"
20LSOF_OS_linux-uclibc = "linux"
21LSOF_OS_linux-gnueabi = "linux"
22
23do_configure () {
24 yes | ./Configure ${LSOF_OS}
25}
26
27export I = "${STAGING_INCDIR}"
28export L = "${STAGING_INCDIR}"
29export EXTRA_OEMAKE = ""
30
31do_compile () {
32 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
33}
34
35do_install () {
36 install -d ${D}${sbindir} ${D}${mandir}/man8
37 install -m 4755 lsof ${D}${sbindir}/lsof
38 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
39}