summaryrefslogtreecommitdiffstats
path: root/meta/packages/lsof
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-08-08 16:37:40 +0000
committerRichard Purdie <richard@openedhand.com>2007-08-08 16:37:40 +0000
commit121b39d4a88c88c099ed8f9f6fa1f254efbc9b03 (patch)
tree90d8f30055abdec184a4a7893a5ffe94b4e2f510 /meta/packages/lsof
parent2ce9dd1cb0fe8b1128b4403b9c09d2d705e3c90a (diff)
downloadpoky-121b39d4a88c88c099ed8f9f6fa1f254efbc9b03.tar.gz
Add lsof 0.78 from OE with build fixes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2398 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lsof')
-rw-r--r--meta/packages/lsof/lsof_4.78.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/lsof/lsof_4.78.bb b/meta/packages/lsof/lsof_4.78.bb
new file mode 100644
index 0000000000..51f0b8b2c4
--- /dev/null
+++ b/meta/packages/lsof/lsof_4.78.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
2Its name stands for LiSt Open Files, and it does just that."
3SECTION = "devel"
4LICENSE = "BSD"
5
6SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
7LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
8S = "${WORKDIR}/lsof_${PV}_src"
9
10python do_unpack () {
11 bb.build.exec_func('base_do_unpack', d)
12 src_uri = bb.data.getVar('SRC_URI', d)
13 bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
14 bb.build.exec_func('base_do_unpack', d)
15 bb.data.setVar('SRC_URI', src_uri, d)
16}
17
18export LSOF_OS = "${TARGET_OS}"
19LSOF_OS_linux-uclibc = "linux"
20LSOF_OS_linux-gnueabi = "linux"
21export LSOF_INCLUDE = "${STAGING_INCDIR}"
22
23do_configure () {
24 yes | ./Configure ${LSOF_OS}
25}
26
27export I = "${STAGING_INCDIR}"
28export L = "${STAGING_INCDIR}"
29export EXTRA_OEMAKE = ""
30
31do_compile () {
32 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
33}
34
35do_install () {
36 install -d ${D}${sbindir} ${D}${mandir}/man8
37 install -m 4755 lsof ${D}${sbindir}/lsof
38 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
39}