summaryrefslogtreecommitdiffstats
path: root/meta/packages/lsof
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/lsof
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lsof')
-rw-r--r--meta/packages/lsof/lsof_4.75.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/lsof/lsof_4.75.bb b/meta/packages/lsof/lsof_4.75.bb
new file mode 100644
index 0000000000..0562a57fb1
--- /dev/null
+++ b/meta/packages/lsof/lsof_4.75.bb
@@ -0,0 +1,38 @@
1SECTION = "console/utils"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic \
3tool. Its name stands for LiSt Open Files, and it \
4does just that."
5LICENSE = "BSD"
6
7SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/OLD/lsof_${PV}.tar.bz2"
8LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
9S = "${WORKDIR}/lsof_${PV}_src"
10
11python do_unpack () {
12 bb.build.exec_func('base_do_unpack', d)
13 src_uri = bb.data.getVar('SRC_URI', d)
14 bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
15 bb.build.exec_func('base_do_unpack', d)
16 bb.data.setVar('SRC_URI', src_uri, d)
17}
18
19LSOF_OS = "${TARGET_OS}"
20LSOF_OS_linux-uclibc = "linux"
21
22do_configure () {
23 ./Configure ${LSOF_OS}
24}
25
26export I = "${STAGING_INCDIR}"
27export L = "${STAGING_INCDIR}"
28export EXTRA_OEMAKE = ""
29
30do_compile () {
31 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
32}
33
34do_install () {
35 install -d ${D}${sbindir} ${D}${mandir}/man8
36 install -m 4755 lsof ${D}${sbindir}/lsof
37 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
38}