summaryrefslogtreecommitdiffstats
path: root/meta/packages/lsof/lsof_4.75.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-06 11:19:13 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-06 11:19:13 +0000
commit03b90cc5baa384b66d13436743f92e7162603af9 (patch)
treecf0dc1212349ad88e5abca3f2a96cd90f0c183d0 /meta/packages/lsof/lsof_4.75.bb
parent62e66ef22dbba6d08ac8e35cc2eeeb7463020658 (diff)
downloadpoky-03b90cc5baa384b66d13436743f92e7162603af9.tar.gz
lsof: update to 4.77 (from OE) as 4.75 is not available upstream
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1448 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lsof/lsof_4.75.bb')
-rw-r--r--meta/packages/lsof/lsof_4.75.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/packages/lsof/lsof_4.75.bb b/meta/packages/lsof/lsof_4.75.bb
deleted file mode 100644
index 0562a57fb1..0000000000
--- a/meta/packages/lsof/lsof_4.75.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1SECTION = "console/utils"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic \
3tool. Its name stands for LiSt Open Files, and it \
4does just that."
5LICENSE = "BSD"
6
7SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/OLD/lsof_${PV}.tar.bz2"
8LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
9S = "${WORKDIR}/lsof_${PV}_src"
10
11python do_unpack () {
12 bb.build.exec_func('base_do_unpack', d)
13 src_uri = bb.data.getVar('SRC_URI', d)
14 bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
15 bb.build.exec_func('base_do_unpack', d)
16 bb.data.setVar('SRC_URI', src_uri, d)
17}
18
19LSOF_OS = "${TARGET_OS}"
20LSOF_OS_linux-uclibc = "linux"
21
22do_configure () {
23 ./Configure ${LSOF_OS}
24}
25
26export I = "${STAGING_INCDIR}"
27export L = "${STAGING_INCDIR}"
28export EXTRA_OEMAKE = ""
29
30do_compile () {
31 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
32}
33
34do_install () {
35 install -d ${D}${sbindir} ${D}${mandir}/man8
36 install -m 4755 lsof ${D}${sbindir}/lsof
37 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
38}