summaryrefslogtreecommitdiffstats
path: root/meta/packages/lirc/lirc-modules_0.8.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-06-16 11:39:44 +0000
committerRichard Purdie <richard@openedhand.com>2008-06-16 11:39:44 +0000
commit51948abc945bc7a6b7f7211398783d1bc1ce0e56 (patch)
treeb8ab3ec68d0829d23659d23f8a78c989f15f2ebf /meta/packages/lirc/lirc-modules_0.8.3.bb
parentba666174627faf2a4e1b0cf24ffac12d51c1f2b4 (diff)
downloadpoky-51948abc945bc7a6b7f7211398783d1bc1ce0e56.tar.gz
lirc: 0.7.1 -> 0.8.3
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4676 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/lirc/lirc-modules_0.8.3.bb')
-rw-r--r--meta/packages/lirc/lirc-modules_0.8.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/lirc/lirc-modules_0.8.3.bb b/meta/packages/lirc/lirc-modules_0.8.3.bb
new file mode 100644
index 0000000000..1605e2d5c5
--- /dev/null
+++ b/meta/packages/lirc/lirc-modules_0.8.3.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
2SECTION = "base"
3PRIORITY = "optional"
4LICENSE = "GPL"
5DEPENDS = "virtual/kernel fakeroot-native"
6PR = "r2"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
9 file://lirc_sir-sa1100.patch;patch=1"
10S = "${WORKDIR}/lirc-${PV}"
11
12inherit autotools module-base
13
14include lirc-config.inc
15
16do_compile() {
17 # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them
18 cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS=""
19}
20
21fakeroot do_install() {
22 oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
23 rm -rf ${D}/dev
24}
25
26pkg_postinst() {
27#!/bin/sh
28set -e
29if [ ! -c $D/dev/lirc ]; then mknod $D/dev/lirc c 61 0; fi
30exit 0
31}
32
33FILES_${PN} = "/lib/modules"