diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/lirc/lirc-modules_0.8.3.bb | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/lirc/lirc-modules_0.8.3.bb')
-rw-r--r-- | meta/packages/lirc/lirc-modules_0.8.3.bb | 33 |
1 files changed, 0 insertions, 33 deletions
diff --git a/meta/packages/lirc/lirc-modules_0.8.3.bb b/meta/packages/lirc/lirc-modules_0.8.3.bb deleted file mode 100644 index ee1de7194e..0000000000 --- a/meta/packages/lirc/lirc-modules_0.8.3.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls." | ||
2 | SECTION = "base" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "GPL" | ||
5 | DEPENDS = "virtual/kernel virtual/fakeroot-native" | ||
6 | PR = "r2" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \ | ||
9 | file://lirc_sir-sa1100.patch;patch=1" | ||
10 | S = "${WORKDIR}/lirc-${PV}" | ||
11 | |||
12 | inherit autotools module-base | ||
13 | |||
14 | include lirc-config.inc | ||
15 | |||
16 | do_compile() { | ||
17 | # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them | ||
18 | cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS="" | ||
19 | } | ||
20 | |||
21 | fakeroot do_install() { | ||
22 | oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install | ||
23 | rm -rf ${D}/dev | ||
24 | } | ||
25 | |||
26 | pkg_postinst() { | ||
27 | #!/bin/sh | ||
28 | set -e | ||
29 | if [ ! -c $D/dev/lirc ]; then mknod $D/dev/lirc c 61 0; fi | ||
30 | exit 0 | ||
31 | } | ||
32 | |||
33 | FILES_${PN} = "/lib/modules" | ||