summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux/linux_2.6.23.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 12:32:26 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 12:32:26 +0000
commit58df8e8af681ca604eda977c3ce10921e9613af1 (patch)
treec02a6e8dd65c7f83a1483fa4ef20b4be5fa30a52 /meta/packages/linux/linux_2.6.23.bb
parent523603f8d9679ee3b6a39ecdbf21db487d484c82 (diff)
downloadpoky-58df8e8af681ca604eda977c3ce10921e9613af1.tar.gz
linux: upgrade cm-x270 kernel to 2.6.23 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3005 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux/linux_2.6.23.bb')
-rw-r--r--meta/packages/linux/linux_2.6.23.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/packages/linux/linux_2.6.23.bb b/meta/packages/linux/linux_2.6.23.bb
new file mode 100644
index 0000000000..e042c7248b
--- /dev/null
+++ b/meta/packages/linux/linux_2.6.23.bb
@@ -0,0 +1,65 @@
1require linux.inc
2
3# Mark archs/machines that this kernel supports
4DEFAULT_PREFERENCE = "-1"
5DEFAULT_PREFERENCE_cm-x270 = "1"
6DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
7DEFAULT_PREFERENCE_mpc8323e-rdb = "1"
8
9PR = "r2"
10
11SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
12 file://binutils-buildid-arm.patch;patch=1 \
13 file://defconfig \
14 "
15
16SRC_URI_append_cm-x270 = "\
17 file://0001-cm-x270-base2.patch;patch=1 \
18 file://0002-cm-x270-match-type.patch;patch=1 \
19 file://0003-cm-x270-ide.patch;patch=1 \
20 file://0004-cm-x270-it8152.patch;patch=1 \
21 file://0005-cm-x270-pcmcia.patch;patch=1 \
22 file://0006-ramdisk_load.patch;patch=1 \
23 file://0007-mmcsd_large_cards-r0.patch;patch=1 \
24 file://0008-cm-x270-nand-simplify-name.patch;patch=1"
25
26CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
27
28FILES_kernel-image_cm-x270 = ""
29
30python do_compulab_image() {
31 import os
32 import os.path
33 import struct
34
35 machine = bb.data.getVar('MACHINE', d, 1)
36 if machine == "cm-x270":
37 deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
38 kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
39 img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
40
41 fo = open(img_file, 'wb')
42
43 image_data = open(kernel_file, 'rb').read()
44
45 # first write size into first 4 bytes
46 size_s = struct.pack('i', len(image_data))
47
48 # truncate size if we are running on a 64-bit host
49 size_s = size_s[:4]
50
51 fo.write(size_s)
52 fo.write(image_data)
53 fo.close()
54
55 os.chdir(deploy_dir)
56 link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
57 img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
58 try:
59 os.unlink(link_file)
60 except:
61 pass
62 os.symlink(img_file, link_file)
63}
64
65addtask compulab_image after do_deploy before do_package