summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux/linux-omap3-pm_git.bb
diff options
context:
space:
mode:
authorMike Turquette <mturquette@ti.com>2009-08-26 10:55:02 -0500
committerMike Turquette <mturquette@ti.com>2009-08-26 10:56:53 -0500
commit3f8afe492fffd7259e754b335df4839b4f0b2d41 (patch)
treea3ee4d6fe03b8d58e0caebaf002136fc5e37c3f5 /meta/packages/linux/linux-omap3-pm_git.bb
parentdb4cd6d67ec4c212bb175bd12f2929c57c3e1674 (diff)
downloadpoky-3f8afe492fffd7259e754b335df4839b4f0b2d41.tar.gz
linux-omap3-pm: refresh patches and remove some sed magic to boot zoom2
Signed-off-by: Mike Turquette <mturquette@ti.com>
Diffstat (limited to 'meta/packages/linux/linux-omap3-pm_git.bb')
-rw-r--r--meta/packages/linux/linux-omap3-pm_git.bb23
1 files changed, 9 insertions, 14 deletions
diff --git a/meta/packages/linux/linux-omap3-pm_git.bb b/meta/packages/linux/linux-omap3-pm_git.bb
index 6799eb1ddf..6432d869ae 100644
--- a/meta/packages/linux/linux-omap3-pm_git.bb
+++ b/meta/packages/linux/linux-omap3-pm_git.bb
@@ -8,20 +8,17 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PN}-git/${MACHINE}
8 8
9SRCREV = "${AUTOREV}" 9SRCREV = "${AUTOREV}"
10 10
11PV = "2.6.31-rc1+${PR}+git${SRCREV}" 11PV = "2.6.31-rc7+pm+${PR}+git${SRCREV}"
12PR = "r1" 12PR = "r3"
13 13
14SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;branch=pm;protocol=git" 14SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;branch=pm;protocol=git"
15 15
16SRC_URI_append_zoom2 = " \ 16SRC_URI_append_zoom2 = " \
17 file://0002-OMAP3-Zoom2-Add-TWL4030-support.patch;patch=1 \ 17 file://0001-OMAP1-2-3-4-DEBUG_LL-cleanup.patch;patch=1 \
18 file://0003-OMAP3-Zoom2-Update-board-defconfig.patch;patch=1 \ 18 file://0002-OMAP1-2-3-4-Adapt-board-files-for-cleand-DEBUG_LL-in.patch;patch=1 \
19 file://0004-serial-8250-add-IRQ-trigger-support.patch;patch=1 \ 19 file://0003-OMAP-Zoom2-Add-DEBUG_LL-interface-using-external-Qua.patch;patch=1 \
20 file://0005-OMAP2-Zoom2-Pass-irqflags-to-8250-driver.patch;patch=1 \ 20 file://0005-OMAP-Zoom2-Release-Dbg-board-detect-gpio.patch;patch=1 \
21 file://0006-OMAP3-Zoom2-ext-UART-needs-plaform_device.id-3.patch;patch=1 \ 21 "
22 file://0007-omap-zoom2-add-external-uart-DEBUG_LL-support-to-zoo.patch;patch=1 \
23 file://0008-omap2-add-support-for-DEBUG_LL-on-external-UART.patch;patch=1 \
24 "
25 22
26COMPATIBLE_MACHINE = "beagleboard|omap-3430sdp|omap3evm|overo|rx51|zoom2" 23COMPATIBLE_MACHINE = "beagleboard|omap-3430sdp|omap3evm|overo|rx51|zoom2"
27 24
@@ -42,7 +39,7 @@ do_configure_prepend() {
42 yes '' | oe_runmake ${MACHINE}_external_defconfig 39 yes '' | oe_runmake ${MACHINE}_external_defconfig
43 else 40 else
44 case ${MACHINE} in 41 case ${MACHINE} in
45 omap-3430sdp|omap3evm) 42 omap-3430sdp | omap3evm)
46 # works out of the box 43 # works out of the box
47 yes '' | oe_runmake omap3_pm_defconfig 44 yes '' | oe_runmake omap3_pm_defconfig
48 ;; 45 ;;
@@ -56,11 +53,9 @@ do_configure_prepend() {
56 -i ${S}/.config 53 -i ${S}/.config
57 ;; 54 ;;
58 zoom2) 55 zoom2)
59 # adjust LL_DEBUG console for these boards 56 # adjust LL_DEBUG console for this board
60 yes '' | oe_runmake omap3_pm_defconfig 57 yes '' | oe_runmake omap3_pm_defconfig
61 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \ 58 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
62 -e "s/CONFIG_MMC_BLOCK=m/CONFIG_MMC_BLOCK=y/" \
63 -e "s/CONFIG_MMC_OMAP_HS=m/CONFIG_MMC_OMAP_HS=y/" \
64 -i ${S}/.config 59 -i ${S}/.config
65 echo "CONFIG_OMAP_LL_DEBUG_UART_EXT=y" >> ${S}/.config 60 echo "CONFIG_OMAP_LL_DEBUG_UART_EXT=y" >> ${S}/.config
66 ;; 61 ;;