diff options
author | Joshua Lock <josh@linux.intel.com> | 2010-05-20 15:48:22 +0100 |
---|---|---|
committer | Joshua Lock <josh@linux.intel.com> | 2010-05-20 15:50:16 +0100 |
commit | d887296baa34054e5841b48d5344ccbfc4979611 (patch) | |
tree | 30091f5d460a4a3c66321e727c3e2edecdab5197 /meta/packages/linux-libc-headers | |
parent | 2c3437d0ae4beac017663e9e71e923e5aac14c79 (diff) | |
download | poky-d887296baa34054e5841b48d5344ccbfc4979611.tar.gz |
linux-libc-headers: add 2.6.33 headers
Add kernel headers to match our preferred/default kernel version and set them
as the preferred version for the Poky and Moblin distributions.
Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/linux-libc-headers')
-rw-r--r-- | meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb new file mode 100644 index 0000000000..e706988070 --- /dev/null +++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | require linux-libc-headers.inc | ||
2 | |||
3 | INHIBIT_DEFAULT_DEPS = "1" | ||
4 | DEPENDS += "unifdef-native" | ||
5 | PR = "r0" | ||
6 | |||
7 | SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2" | ||
8 | |||
9 | S = "${WORKDIR}/linux-${PV}" | ||
10 | |||
11 | set_arch() { | ||
12 | case ${TARGET_ARCH} in | ||
13 | alpha*) ARCH=alpha ;; | ||
14 | arm*) ARCH=arm ;; | ||
15 | cris*) ARCH=cris ;; | ||
16 | hppa*) ARCH=parisc ;; | ||
17 | i*86*) ARCH=i386 ;; | ||
18 | ia64*) ARCH=ia64 ;; | ||
19 | mips*) ARCH=mips ;; | ||
20 | m68k*) ARCH=m68k ;; | ||
21 | powerpc*) ARCH=powerpc ;; | ||
22 | s390*) ARCH=s390 ;; | ||
23 | sh*) ARCH=sh ;; | ||
24 | sparc64*) ARCH=sparc64 ;; | ||
25 | sparc*) ARCH=sparc ;; | ||
26 | x86_64*) ARCH=x86_64 ;; | ||
27 | avr32*) ARCH=avr32 ;; | ||
28 | bfin*) ARCH=blackfin ;; | ||
29 | esac | ||
30 | } | ||
31 | |||
32 | do_configure() { | ||
33 | set_arch | ||
34 | oe_runmake allnoconfig ARCH=$ARCH | ||
35 | } | ||
36 | |||
37 | do_compile () { | ||
38 | } | ||
39 | |||
40 | do_install() { | ||
41 | set_arch | ||
42 | oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH | ||
43 | } | ||
44 | |||
45 | BBCLASSEXTEND = "nativesdk" | ||