summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux-libc-headers
diff options
context:
space:
mode:
authorTomas Frydrych <tf@openedhand.com>2006-09-18 15:23:13 +0000
committerTomas Frydrych <tf@openedhand.com>2006-09-18 15:23:13 +0000
commit02059b7a72b03de846f78ab9a2c24d660b29d59e (patch)
tree5b059c6d2a705c596e72604c572d866aa4afee2b /meta/packages/linux-libc-headers
parentde35d836b450951eddb505acb4b60de18d368df1 (diff)
downloadpoky-02059b7a72b03de846f78ab9a2c24d660b29d59e.tar.gz
files for using csl2005q3-2 toolchain
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@723 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux-libc-headers')
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_csl-arm-2005q3-2.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_csl-arm-2005q3-2.bb b/meta/packages/linux-libc-headers/linux-libc-headers_csl-arm-2005q3-2.bb
new file mode 100644
index 0000000000..136d9e7eee
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_csl-arm-2005q3-2.bb
@@ -0,0 +1,88 @@
1SECTION = "devel"
2DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
3# This package is derived from the original linux-libc-headers at
4# http://ep09.pld-linux.org/~mmazur/linux-libc-headers/
5# More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with
6# the official linux patches (where applicable) and then fixed up just
7# enough to build glibc-2.4. BEWARE!
8#
9# license note from the linux-libc-headers package:
10# Linux-libc-headers are derived from linux kernel headers. For license of a
11# particular header, check it's content, and if copyright notice isn't present,
12# standard linux kernel license applies.
13# since we assume GPL for linux i think we can also assume it here
14LICENSE = "GPL"
15DEFAULT_PREFERENCE = "-1"
16INHIBIT_DEFAULT_DEPS = "1"
17PR = "r4"
18PV = "2.6.12rc3+csl-arm-2005q3-2"
19
20SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-linux-gnueabi/arm-2005q3-2-arm-none-linux-gnueabi.src.tar.bz2"
21
22#unpack the inner tarball, extract the include directory and do little
23#cleanup
24do_unpack2() {
25 cd ${WORKDIR}
26 tar -xvjf ./arm-2005q3-2-arm-none-linux-gnueabi/linux-2005q3-2.tar.bz2
27 mkdir -p linux-include
28 mv ./linux-2.6.12rc3/include ./linux-include
29 rm ./linux-include/include/asm-arm/arch
30 rm -rf ./arm-2005q3-2-arm-none-linux-gnuabi
31 rm -rf ./linux-2.6.12.rc3
32}
33
34addtask unpack2 after do_unpack before do_patch
35
36S = "${WORKDIR}/linux-include"
37
38do_configure () {
39 case ${TARGET_ARCH} in
40 alpha*) ARCH=alpha ;;
41 arm*) ARCH=arm ;;
42 cris*) ARCH=cris ;;
43 hppa*) ARCH=parisc ;;
44 i*86*) ARCH=i386 ;;
45 ia64*) ARCH=ia64 ;;
46 mips*) ARCH=mips ;;
47 m68k*) ARCH=m68k ;;
48 powerpc*) ARCH=ppc ;;
49 s390*) ARCH=s390 ;;
50 sh*) ARCH=sh ;;
51 sparc64*) ARCH=sparc64 ;;
52 sparc*) ARCH=sparc ;;
53 x86_64*) ARCH=x86_64 ;;
54 esac
55 if test ! -e include/asm-$ARCH; then
56 oefatal unable to create asm symlink in kernel headers
57 fi
58 rm "include/asm"
59 cp -pPR "include/asm-$ARCH" "include/asm"
60 if test "$ARCH" = "arm"; then
61 cp -pPR include/asm/arch-ebsa285 include/asm/arch
62 elif test "$ARCH" = "sh"; then
63 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
64 fi
65}
66
67do_stage () {
68 install -d ${STAGING_INCDIR}
69 rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
70 cp -pfLR include/linux ${STAGING_INCDIR}/
71 cp -pfLR include/asm ${STAGING_INCDIR}/
72 cp -pfLR include/asm-generic ${STAGING_INCDIR}/
73 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
74 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
75 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm-generic
76 install -d ${CROSS_DIR}/${TARGET_SYS}/include
77 cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
78 cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
79 cp -pfLR include/asm-generic ${CROSS_DIR}/${TARGET_SYS}/include/
80}
81
82do_install() {
83 install -d ${D}${includedir}
84 cp -pfLR include/linux ${D}${includedir}/
85 cp -pfLR include/asm ${D}${includedir}/
86 cp -pfLR include/asm-generic ${D}${includedir}/
87}
88