diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2010-06-21 04:56:52 -0700 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-02 15:28:54 +0100 |
commit | f8a8ec5ceb4b5f7a03e4a0024e5fe06ec8e7ad0a (patch) | |
tree | a073a9119d2f4b7dca54564db65fe126c1dc671a /meta/packages/linux-libc-headers/linux-libc-headers_2.6.34.bb | |
parent | 4d5ad73238d8811b29833fb500774a69f3d6810e (diff) | |
download | poky-f8a8ec5ceb4b5f7a03e4a0024e5fe06ec8e7ad0a.tar.gz |
linux-libc-headers: upgrade from 2.6.33 to 2.6.34
added a new patch to fix glibc build issue on powerpc
ppc_glibc_build_fix.patch
Added attribution to the hayes-gone.patch.
And updated the metadata variables like LICENSE & LIC_CHKSUM_FILES
And removing all the older recipes and related files
Change the linux-libc-header version inpoky-default.inc
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/linux-libc-headers/linux-libc-headers_2.6.34.bb')
-rw-r--r-- | meta/packages/linux-libc-headers/linux-libc-headers_2.6.34.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.34.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.34.bb new file mode 100644 index 0000000000..31c305854f --- /dev/null +++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.34.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | require linux-libc-headers.inc | ||
2 | |||
3 | INHIBIT_DEFAULT_DEPS = "1" | ||
4 | DEPENDS += "unifdef-native" | ||
5 | PR = "r0" | ||
6 | |||
7 | SRC_URI += "file://hayes-gone.patch \ | ||
8 | file://ppc_glibc_build_fix.patch" | ||
9 | |||
10 | S = "${WORKDIR}/linux-${PV}" | ||
11 | |||
12 | set_arch() { | ||
13 | case ${TARGET_ARCH} in | ||
14 | alpha*) ARCH=alpha ;; | ||
15 | arm*) ARCH=arm ;; | ||
16 | cris*) ARCH=cris ;; | ||
17 | hppa*) ARCH=parisc ;; | ||
18 | i*86*) ARCH=i386 ;; | ||
19 | ia64*) ARCH=ia64 ;; | ||
20 | mips*) ARCH=mips ;; | ||
21 | m68k*) ARCH=m68k ;; | ||
22 | powerpc*) ARCH=powerpc ;; | ||
23 | s390*) ARCH=s390 ;; | ||
24 | sh*) ARCH=sh ;; | ||
25 | sparc64*) ARCH=sparc64 ;; | ||
26 | sparc*) ARCH=sparc ;; | ||
27 | x86_64*) ARCH=x86_64 ;; | ||
28 | avr32*) ARCH=avr32 ;; | ||
29 | bfin*) ARCH=blackfin ;; | ||
30 | esac | ||
31 | } | ||
32 | |||
33 | do_configure() { | ||
34 | set_arch | ||
35 | oe_runmake allnoconfig ARCH=$ARCH | ||
36 | } | ||
37 | |||
38 | do_compile () { | ||
39 | } | ||
40 | |||
41 | do_install() { | ||
42 | set_arch | ||
43 | oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH | ||
44 | # Kernel should not be exporting this header | ||
45 | rm -f ${D}${exec_prefix}/include/scsi/scsi.h | ||
46 | } | ||
47 | |||
48 | BBCLASSEXTEND = "nativesdk" | ||