diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2010-06-26 01:25:11 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2010-07-19 11:03:13 -0400 |
commit | 3e86c5e644584bea9ab8de1d002d7db2b7deb14a (patch) | |
tree | ba4ad6ba901de26eb05f17f951c03252cd296cc7 /meta/packages/linux-libc-headers/linux-libc-headers-wrs_git.bb | |
parent | 68974e8e9f187327656cace2d12473854fe6096c (diff) | |
download | poky-3e86c5e644584bea9ab8de1d002d7db2b7deb14a.tar.gz |
linux-libc-headers: create a libc-headers based on Wind River kernel
Put PREFERRED_PROVIDER_linux-libc-headers = "linux-libc-headers-wrs"
in your configuration, and this package will be used to generate a
set of kernel headers from the -standard branch of the Wind River kernel.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/packages/linux-libc-headers/linux-libc-headers-wrs_git.bb')
-rw-r--r-- | meta/packages/linux-libc-headers/linux-libc-headers-wrs_git.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-wrs_git.bb b/meta/packages/linux-libc-headers/linux-libc-headers-wrs_git.bb new file mode 100644 index 0000000000..ab25e500ba --- /dev/null +++ b/meta/packages/linux-libc-headers/linux-libc-headers-wrs_git.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | require linux-libc-headers.inc | ||
2 | |||
3 | INHIBIT_DEFAULT_DEPS = "1" | ||
4 | DEPENDS += "unifdef-native" | ||
5 | PROVIDES = "linux-libc-headers" | ||
6 | PV = "2.6.34+git-${SRCPV}" | ||
7 | PR = "r0" | ||
8 | |||
9 | SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;fullclone=1" | ||
10 | |||
11 | S = "${WORKDIR}/linux" | ||
12 | |||
13 | set_arch() { | ||
14 | case ${TARGET_ARCH} in | ||
15 | arm*) ARCH=arm ;; | ||
16 | i*86*) ARCH=i386 ;; | ||
17 | ia64*) ARCH=ia64 ;; | ||
18 | mips*) ARCH=mips ;; | ||
19 | powerpc*) ARCH=powerpc ;; | ||
20 | x86_64*) ARCH=x86_64 ;; | ||
21 | esac | ||
22 | } | ||
23 | |||
24 | do_configure() { | ||
25 | set_arch | ||
26 | oe_runmake allnoconfig ARCH=$ARCH | ||
27 | } | ||
28 | |||
29 | do_wrlinux_checkout() { | ||
30 | if [ -d ${WORKDIR}/.git/refs/remotes/origin ]; then | ||
31 | rm -rf ${S} | ||
32 | mkdir ${S} | ||
33 | mv ${WORKDIR}/.git ${S} | ||
34 | mv ${S}/.git/refs/remotes/origin/* ${S}/.git/refs/heads | ||
35 | rmdir ${S}/.git/refs/remotes/origin | ||
36 | fi | ||
37 | cd ${S} | ||
38 | git checkout -f standard | ||
39 | } | ||
40 | |||
41 | addtask wrlinux_checkout before do_patch after do_unpack | ||
42 | |||
43 | do_compile () { | ||
44 | } | ||
45 | |||
46 | do_install() { | ||
47 | set_arch | ||
48 | oe_runmake headers_install_all INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH | ||
49 | } | ||
50 | |||
51 | BBCLASSEXTEND = "nativesdk" | ||