diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/linux-hotplug/linux-hotplug_20040920.bb | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux-hotplug/linux-hotplug_20040920.bb')
-rw-r--r-- | meta/packages/linux-hotplug/linux-hotplug_20040920.bb | 73 |
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/packages/linux-hotplug/linux-hotplug_20040920.bb b/meta/packages/linux-hotplug/linux-hotplug_20040920.bb new file mode 100644 index 0000000000..c6bcbb66e6 --- /dev/null +++ b/meta/packages/linux-hotplug/linux-hotplug_20040920.bb | |||
@@ -0,0 +1,73 @@ | |||
1 | DESCRIPTION = "This package contains the scripts necessary \ | ||
2 | for hotplug Linux support, and lets you plug in new devices \ | ||
3 | and use them immediately." | ||
4 | HOMEPAGE = "http://linux-hotplug.sourceforge.net/" | ||
5 | LICENSE = "GPL" | ||
6 | RPROVIDES_${PN} = "hotplug" | ||
7 | RCONFLICTS_${PN} = "hotplug" | ||
8 | RREPLACES_${PN} = "hotplug" | ||
9 | SECTION = "base" | ||
10 | RSUGGESTS = "pciutils usbutils" | ||
11 | PR = "r8" | ||
12 | |||
13 | SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-2004_09_20.tar.gz \ | ||
14 | file://userspecified_hcd.patch;patch=1 \ | ||
15 | file://hotplug-net-agent-usb.patch;patch=1 \ | ||
16 | file://usbrc-busybox.patch;patch=1 \ | ||
17 | file://fix-net.agent \ | ||
18 | file://update-usb.usermap \ | ||
19 | file://logcheck-ignore \ | ||
20 | file://sleeve.agent \ | ||
21 | file://sleeve.rc \ | ||
22 | file://mmc.agent \ | ||
23 | file://usbd.agent \ | ||
24 | file://usbd \ | ||
25 | file://sysconfig-hotplug \ | ||
26 | file://sysconfig-usb \ | ||
27 | file://isapnp-exit.diff;patch=1 \ | ||
28 | file://usb-storage \ | ||
29 | file://soc.agent" | ||
30 | |||
31 | SRC_URI_append_openzaurus = " file://quiet-pci.patch;patch=1" | ||
32 | |||
33 | S = "${WORKDIR}/hotplug-2004_09_20" | ||
34 | |||
35 | INITSCRIPT_NAME = "hotplug" | ||
36 | INITSCRIPT_PARAMS = "start 40 S . stop 89 0 6 ." | ||
37 | |||
38 | inherit update-rc.d | ||
39 | |||
40 | do_compile () { | ||
41 | : | ||
42 | } | ||
43 | |||
44 | oldmandir := "${mandir}" | ||
45 | oldsbindir := "${sbindir}" | ||
46 | prefix = "" | ||
47 | exec_prefix = "" | ||
48 | FILES_${PN} += "${oldsbindir}" | ||
49 | FILES_${PN}-doc += "${oldmandir}" | ||
50 | |||
51 | export DEBFIX = "sed -e 's:sysconfig/usb:default/hotplug.usb:'" | ||
52 | do_install () { | ||
53 | install -d ${D}${sysconfdir}/logcheck/ignore.d | ||
54 | install -d ${D}${oldmandir} | ||
55 | install -d ${D}${oldsbindir} | ||
56 | #install -d ${D}${sysconfdir}/default | ||
57 | oe_runmake prefix=${D}${prefix} exec_prefix=${D}${exec_prefix} \ | ||
58 | etcdir=${D}${sysconfdir} sbindir=${D}${sbindir} \ | ||
59 | mandir=${D}${oldmandir} INSTALL=install install | ||
60 | sh ${WORKDIR}/fix-net.agent ${D} || : | ||
61 | install -m 0755 ${WORKDIR}/update-usb.usermap ${D}${oldsbindir}/ | ||
62 | install -m 0644 ${WORKDIR}/logcheck-ignore ${D}${sysconfdir}/logcheck/ignore.d/hotplug | ||
63 | install -m 0755 ${WORKDIR}/sleeve.agent ${D}${sysconfdir}/hotplug/ | ||
64 | install -m 0755 ${WORKDIR}/sleeve.rc ${D}${sysconfdir}/hotplug/ | ||
65 | install -m 0755 ${WORKDIR}/mmc.agent ${D}${sysconfdir}/hotplug/ | ||
66 | install -m 0755 ${WORKDIR}/usbd.agent ${D}${sysconfdir}/hotplug/ | ||
67 | install -m 0755 ${WORKDIR}/soc.agent ${D}${sysconfdir}/hotplug/ | ||
68 | #install -m 0755 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd | ||
69 | install -d ${D}${sysconfdir}/sysconfig | ||
70 | install -m 0644 ${WORKDIR}/sysconfig-hotplug ${D}${sysconfdir}/sysconfig/hotplug | ||
71 | install -m 0644 ${WORKDIR}/sysconfig-usb ${D}${sysconfdir}/sysconfig/usb | ||
72 | install -m 0755 ${WORKDIR}/usb-storage ${D}${sysconfdir}/hotplug/usb | ||
73 | } | ||