summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxslt
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-19 17:00:44 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-19 17:00:44 +0000
commitc3a4acb22d264e778014660f4944b544ab20de84 (patch)
treeb512c9a2f84ed830216f2c5f6fb9c70f89f20e9f /meta/packages/libxslt
parentab5c2b9ebbfb8acb9a459cfc0e9af2fc01e3e768 (diff)
downloadpoky-c3a4acb22d264e778014660f4944b544ab20de84.tar.gz
libxslt: Upgrade to 1.1.22 with pkgconfig fixes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4073 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxslt')
-rw-r--r--meta/packages/libxslt/files/destdir.patch10
-rw-r--r--meta/packages/libxslt/libxslt_1.1.20.bb44
-rw-r--r--meta/packages/libxslt/libxslt_1.1.22.bb23
3 files changed, 23 insertions, 54 deletions
diff --git a/meta/packages/libxslt/files/destdir.patch b/meta/packages/libxslt/files/destdir.patch
deleted file mode 100644
index 8df1b206bc..0000000000
--- a/meta/packages/libxslt/files/destdir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
1Index: libxslt-1.1.17/libxslt/Makefile.am
2===================================================================
3--- libxslt-1.1.17.orig/libxslt/Makefile.am 2005-10-02 11:25:21.000000000 +0200
4+++ libxslt-1.1.17/libxslt/Makefile.am 2006-09-29 23:13:35.000000000 +0200
5@@ -61,4 +61,4 @@
6 @(cd ../xsltproc ; $(MAKE))
7
8 install-exec-hook:
9- $(mkinstalldirs) "$(libdir)/libxslt-plugins"
10+ $(mkinstalldirs) "$(DESTDIR)$(libdir)/libxslt-plugins"
diff --git a/meta/packages/libxslt/libxslt_1.1.20.bb b/meta/packages/libxslt/libxslt_1.1.20.bb
deleted file mode 100644
index 6ec59f14be..0000000000
--- a/meta/packages/libxslt/libxslt_1.1.20.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1DESCRIPTION = "GNOME XSLT library"
2SECTION = "libs"
3PRIORITY = "optional"
4DEPENDS = "libxml2"
5LICENSE = "MIT"
6
7SRC_URI = "ftp://xmlsoft.org/libxml2/${PN}-${PV}.tar.gz"
8S = "${WORKDIR}/${PN}-${PV}"
9
10inherit autotools pkgconfig
11
12EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
13
14xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
15 keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
16 templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
17 xsltexports.h xsltutils.h"
18exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
19
20do_stage () {
21 oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
22 oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
23
24 mkdir -p ${STAGING_INCDIR}/libxslt
25 for i in ${xsltheaders}; do
26 install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
27 done
28 mkdir -p ${STAGING_INCDIR}/libexslt
29 for i in ${exsltheaders}; do
30 install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
31 done
32
33 cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_DIR_HOST}${layout_prefix}," \
34 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_DIR_HOST}${layout_exec_prefix}," \
35 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
36 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xslt-config
37 chmod a+rx ${STAGING_BINDIR_CROSS}/xslt-config
38 install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
39}
40
41PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
42
43FILES_${PN}-dev += "${bindir}/xslt-config"
44FILES_${PN}-utils += "${bindir}"
diff --git a/meta/packages/libxslt/libxslt_1.1.22.bb b/meta/packages/libxslt/libxslt_1.1.22.bb
new file mode 100644
index 0000000000..86fe70dff2
--- /dev/null
+++ b/meta/packages/libxslt/libxslt_1.1.22.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "GNOME XSLT library"
2SECTION = "libs"
3PRIORITY = "optional"
4DEPENDS = "libxml2 (>=2.6.27)"
5LICENSE = "MIT"
6PR = "r1"
7
8SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
9 file://pkgconfig_fix.patch;patch=1"
10S = "${WORKDIR}/libxslt-${PV}"
11
12inherit autotools pkgconfig
13
14EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
15
16do_stage () {
17 autotools_stage_all
18}
19
20PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
21
22FILES_${PN}-dev += "${bindir}/xslt-config"
23FILES_${PN}-utils += "${bindir}"