diff options
author | Ross Burton <ross@openedhand.com> | 2007-05-04 15:23:09 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2007-05-04 15:23:09 +0000 |
commit | 11f5ec6e8962f74b6b2437030ab4b747a09f5a9c (patch) | |
tree | 34e996ddafdd1fce5464ec73b31ea79ceadbd382 /meta/packages/libxslt | |
parent | 0efc0dfc20f452ea25630b45aa5e13cf3e074e46 (diff) | |
download | poky-11f5ec6e8962f74b6b2437030ab4b747a09f5a9c.tar.gz |
Add libxslt for gnome-doc-utils
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1596 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxslt')
-rw-r--r-- | meta/packages/libxslt/files/destdir.patch | 10 | ||||
-rw-r--r-- | meta/packages/libxslt/libxslt_1.1.17.bb | 46 |
2 files changed, 56 insertions, 0 deletions
diff --git a/meta/packages/libxslt/files/destdir.patch b/meta/packages/libxslt/files/destdir.patch new file mode 100644 index 0000000000..8df1b206bc --- /dev/null +++ b/meta/packages/libxslt/files/destdir.patch | |||
@@ -0,0 +1,10 @@ | |||
1 | Index: libxslt-1.1.17/libxslt/Makefile.am | ||
2 | =================================================================== | ||
3 | --- libxslt-1.1.17.orig/libxslt/Makefile.am 2005-10-02 11:25:21.000000000 +0200 | ||
4 | +++ libxslt-1.1.17/libxslt/Makefile.am 2006-09-29 23:13:35.000000000 +0200 | ||
5 | @@ -61,4 +61,4 @@ | ||
6 | @(cd ../xsltproc ; $(MAKE)) | ||
7 | |||
8 | install-exec-hook: | ||
9 | - $(mkinstalldirs) "$(libdir)/libxslt-plugins" | ||
10 | + $(mkinstalldirs) "$(DESTDIR)$(libdir)/libxslt-plugins" | ||
diff --git a/meta/packages/libxslt/libxslt_1.1.17.bb b/meta/packages/libxslt/libxslt_1.1.17.bb new file mode 100644 index 0000000000..7abd2c30b6 --- /dev/null +++ b/meta/packages/libxslt/libxslt_1.1.17.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | DESCRIPTION = "GNOME XSLT library" | ||
2 | SECTION = "libs" | ||
3 | PRIORITY = "optional" | ||
4 | DEPENDS = "libxml2" | ||
5 | LICENSE = "MIT" | ||
6 | PR = "r2" | ||
7 | |||
8 | SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \ | ||
9 | file://destdir.patch;patch=1" | ||
10 | S = "${WORKDIR}/libxslt-${PV}" | ||
11 | |||
12 | inherit autotools pkgconfig | ||
13 | |||
14 | EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto" | ||
15 | |||
16 | xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \ | ||
17 | keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \ | ||
18 | templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \ | ||
19 | xsltexports.h xsltutils.h" | ||
20 | exsltheaders = "exslt.h exsltconfig.h exsltexports.h" | ||
21 | |||
22 | do_stage () { | ||
23 | oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR} | ||
24 | oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR} | ||
25 | |||
26 | mkdir -p ${STAGING_INCDIR}/libxslt | ||
27 | for i in ${xsltheaders}; do | ||
28 | install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i | ||
29 | done | ||
30 | mkdir -p ${STAGING_INCDIR}/libexslt | ||
31 | for i in ${exsltheaders}; do | ||
32 | install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i | ||
33 | done | ||
34 | |||
35 | cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_DIR}/${HOST_SYS}," \ | ||
36 | -e "s,^exec_prefix=.*,exec_prefix=${STAGING_DIR}/${HOST_SYS}," \ | ||
37 | -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \ | ||
38 | -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xslt-config | ||
39 | chmod a+rx ${STAGING_BINDIR_CROSS}/xslt-config | ||
40 | install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/ | ||
41 | } | ||
42 | |||
43 | PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale" | ||
44 | |||
45 | FILES_${PN}-dev += "${bindir}/xslt-config" | ||
46 | FILES_${PN}-utils += "${bindir}" | ||