summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxslt/libxslt_1.1.20.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-08-02 11:30:51 +0000
committerRoss Burton <ross@openedhand.com>2007-08-02 11:30:51 +0000
commit22c85055348c01f86dffbe926a0eccf8fac3b1f9 (patch)
treea0e441d0a3d52995d063e9309d0dc80bfe922658 /meta/packages/libxslt/libxslt_1.1.20.bb
parenta2defd4d88e300d8d272cecc68cb8a55fd08cbce (diff)
downloadpoky-22c85055348c01f86dffbe926a0eccf8fac3b1f9.tar.gz
Upgrade libxml/libxslt
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2328 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxslt/libxslt_1.1.20.bb')
-rw-r--r--meta/packages/libxslt/libxslt_1.1.20.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/packages/libxslt/libxslt_1.1.20.bb b/meta/packages/libxslt/libxslt_1.1.20.bb
new file mode 100644
index 0000000000..fa063142b6
--- /dev/null
+++ b/meta/packages/libxslt/libxslt_1.1.20.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "GNOME XSLT library"
2SECTION = "libs"
3PRIORITY = "optional"
4DEPENDS = "libxml2"
5LICENSE = "MIT"
6
7SRC_URI = "ftp://xmlsoft.org/libxml2/${PN}-${PV}.tar.gz"
8S = "${WORKDIR}/${PN}-${PV}"
9
10inherit autotools pkgconfig
11
12EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
13
14xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
15 keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
16 templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
17 xsltexports.h xsltutils.h"
18exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
19
20do_stage () {
21 oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
22 oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
23
24 mkdir -p ${STAGING_INCDIR}/libxslt
25 for i in ${xsltheaders}; do
26 install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
27 done
28 mkdir -p ${STAGING_INCDIR}/libexslt
29 for i in ${exsltheaders}; do
30 install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
31 done
32
33 cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_DIR}/${HOST_SYS}," \
34 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_DIR}/${HOST_SYS}," \
35 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
36 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xslt-config
37 chmod a+rx ${STAGING_BINDIR_CROSS}/xslt-config
38 install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
39}
40
41PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
42
43FILES_${PN}-dev += "${bindir}/xslt-config"
44FILES_${PN}-utils += "${bindir}"